Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Compilation error while installing AMDGPU
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Brainzman
n00b
n00b


Joined: 24 Jun 2017
Posts: 4
Location: France

PostPosted: Sat Jun 24, 2017 9:56 pm    Post subject: [SOLVED]Compilation error while installing AMDGPU Reply with quote

Hi guys! :D
Today I have for the first time installed Gentoo with UEFI support (my previous attempt with no UEFI failed) and I am really happy with it.
So, just after that I wanted to install X.org so I go to the AMDGPU page and follow the guide. I have configured my kernel and launch the compilation but I get this error message.

http://termbin.com/lv4s

I was thinking that the error come from CONFIG_EXTRA_FIRMWARE and CONFIG_EXTRA_FIRMWARE_DIR but no.

Thanks by advance.[/bug]


Last edited by Brainzman on Sun Jun 25, 2017 9:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7127
Location: almost Mile High in the USA

PostPosted: Sat Jun 24, 2017 10:21 pm    Post subject: Reply with quote

How are you planning to deal with the firmware? Your post does not seem clear.

If you're planning to embed the firmware, do you have the firmware available for embedding? Installed sys-kernel/linux-firmware ?

This shouldn't happen if you are not planning to embed, which will work if you plan to use amdgpu as a module.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3076
Location: Illinois, USA

PostPosted: Sat Jun 24, 2017 10:22 pm    Post subject: Reply with quote

What kernel? What compiler version?
Back to top
View user's profile Send private message
Brainzman
n00b
n00b


Joined: 24 Jun 2017
Posts: 4
Location: France

PostPosted: Sun Jun 25, 2017 7:41 am    Post subject: Reply with quote

I plan to incorporate the AMDGPU firmware in my kernel as told here.

Kernel version : 4.9.16-gentoo
Compiler version : gcc 5.40/make 4.2.1[/url]
Back to top
View user's profile Send private message
Brainzman
n00b
n00b


Joined: 24 Jun 2017
Posts: 4
Location: France

PostPosted: Sun Jun 25, 2017 7:58 am    Post subject: Reply with quote

Okay I figured out that the error come from the {} in CONFIG_EXTRA_FIMWARE=amdgpu/polaris11_{ce,mc,me,mec2,mec,pfp,rlc,sdma1,sdma,smc,smc_sk,uvd,vce}.bin
Because when I do CONFIG_EXTRA_FIMWARE=amdgpu/polaris11_ce.bin or CONFIG_EXTRA_FIMWARE=amdgpu/polaris11_smc.bin
It's not failling
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Sun Jun 25, 2017 2:14 pm    Post subject: Reply with quote

Code:
echo amdgpu/polaris11_{ce,mc,me,mec2,mec,pfp,rlc,sdma1,sdma,smc,smc_sk,uvd,vce}.bin
in a terminal, then select/copy paste the list into your kernel config.

Though personally, I find it easier to use sys-kernel/linux-firmware and a list of the specific modules I want installed on my machine; then load the (kernel) module at startup with /etc/modules.d/autoload (I think it is.)
Back to top
View user's profile Send private message
Brainzman
n00b
n00b


Joined: 24 Jun 2017
Posts: 4
Location: France

PostPosted: Sun Jun 25, 2017 9:54 pm    Post subject: Reply with quote

Thanks you ! I have found it just before.I seen your message. :D
I add SOLVED in the title
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum