Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
amd r7 260x don't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Newbie_chen
n00b
n00b


Joined: 01 Jul 2017
Posts: 6

PostPosted: Wed Jul 05, 2017 6:05 am    Post subject: amd r7 260x don't work Reply with quote

at first, i think r7 260x is GCN2.0, so i followed Gentoo wiki AMDGPU tutorial, then the video card do not work(do lsmod, there is no amdgpu, do modprobe amdgpu there is still no amdgpu)
then, i konw that this card is GCN1.1, so i followed Gentoo wiki radeon tutorial, then the video card do not work too.(do lsmod there is no radeon, do modprobe radeon, there is stiil no radeon)
after i startx, there are always errors say that [KMS] drm report modesetting isn't supported, no screens found(EE).

i think this video card is not driven, how can i check if it is driven? what should i do ? by the way my video card is msi r7 260x Gamming 1G. thanks
Back to top
View user's profile Send private message
Telemin
l33t
l33t


Joined: 25 Aug 2005
Posts: 734
Location: Glasgow, UK

PostPosted: Wed Jul 05, 2017 11:12 am    Post subject: Reply with quote

I imagine you are missing the firmware but we need much more information. Can you please provide your kernel config via pastebin or similar, and also the output of "lspci -k", and "emerge --info" please.

-Telemin-
_________________
The Geek formerly known as -Freestyling-
When you feel your problem has been solved please add [Solved] to the topic title.
Please adopt an unanswered post
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1519
Location: KUUSANKOSKI, Finland

PostPosted: Wed Jul 05, 2017 11:47 am    Post subject: Re: amd r7 260x don't work Reply with quote

Newbie_chen wrote:
do lsmod, there is no amdgpu, do modprobe amdgpu there is still no amdgpu
Do you get any lines on dmesg while trying to modprobe amdgpu?
Do you have amdgpu compiled in-kernel or as a module?
Please check that you have all the required kernel configs turned on.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
Newbie_chen
n00b
n00b


Joined: 01 Jul 2017
Posts: 6

PostPosted: Fri Jul 07, 2017 1:45 am    Post subject: Reply with quote

Telemin wrote:
I imagine you are missing the firmware but we need much more information. Can you please provide your kernel config via pastebin or similar, and also the output of "lspci -k", and "emerge --info" please.

-Telemin-


Thank you for your helping, i have re-installed gentoo, every thing is ok now
Back to top
View user's profile Send private message
Newbie_chen
n00b
n00b


Joined: 01 Jul 2017
Posts: 6

PostPosted: Fri Jul 07, 2017 1:46 am    Post subject: Re: amd r7 260x don't work Reply with quote

Zucca wrote:
Newbie_chen wrote:
do lsmod, there is no amdgpu, do modprobe amdgpu there is still no amdgpu
Do you get any lines on dmesg while trying to modprobe amdgpu?
Do you have amdgpu compiled in-kernel or as a module?
Please check that you have all the required kernel configs turned on.


Thank you for your helping;)
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1519
Location: KUUSANKOSKI, Finland

PostPosted: Fri Jul 07, 2017 9:12 am    Post subject: Reply with quote

Newbie_chen wrote:
i have re-installed gentoo, every thing is ok now
To learn what is wrong, reinstalling the whole system isn't the answer. However I'm glad that you don't have the problem anymore. :)
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
pcmaster
Advocate
Advocate


Joined: 04 Dec 2003
Posts: 2156
Location: Barcelona

PostPosted: Sun Jul 30, 2017 7:59 am    Post subject: Reply with quote

Do you have the linux-firmware package installed?
_________________
pcmaster
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum