Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How I can force my laptop to use only Intel VGA ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
saeb
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2017
Posts: 82
Location: iran

PostPosted: Fri Jul 07, 2017 7:55 am    Post subject: How I can force my laptop to use only Intel VGA ? Reply with quote

hi there
I have a Fujitsu LH532 Laptop
Details is here :
http://www.fujitsu.com/hk/products/computing/pc/ap/notebooks/lseries/lh532ap/#a02
I switched from arch to gentoo today.
I think my laptop using NVIDIA vga card
its always hot and its fan working crazy
my vga details :
Code:
 ✘ saeb@Fujitsu  ~/Downloads/git/papirus-icon-theme   master  sudo lspci|grep -i VGA
Password:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 620M] (rev a1)

how I can make my laptop use only intel vga?
_________________
I`m noob and I have a jillion question
Back to top
View user's profile Send private message
snkmoorthy
Guru
Guru


Joined: 19 Nov 2002
Posts: 376

PostPosted: Fri Jul 07, 2017 9:34 am    Post subject: Reply with quote

please post
Code:
lspci -k
for the VGA cards. It will list which modules are in use. If the Nvidia card is using a driver you can add them to the modules blacklist.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43195
Location: 56N 3W

PostPosted: Fri Jul 07, 2017 10:52 am    Post subject: Reply with quote

saeb,

That looks like an Optimus graphics system.

Examine the /var/log/Xorg.0.log file to see which driver is in use.
Use wgetpaste to share the file with us if you want a second opinion.

Its not always a case of which graphics is in use, you also need to power down the nVidia chip when its not used.

Your fan may be running all the time because you don't have kernel support to be able to control. it, not because your system is actually hot.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
saeb
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2017
Posts: 82
Location: iran

PostPosted: Fri Jul 07, 2017 12:01 pm    Post subject: Reply with quote

snkmoorthy wrote:
please post
Code:
lspci -k
for the VGA cards. It will list which modules are in use. If the Nvidia card is using a driver you can add them to the modules blacklist.


it seems I use intel VGA tnx.
Code:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
   Subsystem: Fujitsu Limited. 3rd Gen Core processor Graphics Controller
   Kernel driver in use: i915
   Kernel modules: i915

but if it used NVIDIA how I must let that to blacklist?
_________________
I`m noob and I have a jillion question
Back to top
View user's profile Send private message
saeb
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2017
Posts: 82
Location: iran

PostPosted: Fri Jul 07, 2017 12:23 pm    Post subject: Reply with quote

NeddySeagoon wrote:
saeb,

That looks like an Optimus graphics system.

Examine the /var/log/Xorg.0.log file to see which driver is in use.
Use wgetpaste to share the file with us if you want a second opinion.

Its not always a case of which graphics is in use, you also need to power down the nVidia chip when its not used.

Your fan may be running all the time because you don't have kernel support to be able to control. it, not because your system is actually hot.


the /var/log/Xorg.0.log is :
https://beepaste.io/view/m4BF8d

Is there any way i can make kernel control it?
_________________
I`m noob and I have a jillion question
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43195
Location: 56N 3W

PostPosted: Fri Jul 07, 2017 2:15 pm    Post subject: Reply with quote

saeb,

Your system has loaded the open source drivers for both graphics chip sets.

Code:
[    34.614] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160919
[    34.634] (--) NOUVEAU(G0): Chipset: "NVIDIA NVC1"


Its not possible to say if the nVidia card is actually being used from the log, just that the driver is loaded.

Do you have a BIOS option to disable the nVidia card?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
tberger2
n00b
n00b


Joined: 05 Feb 2013
Posts: 69

PostPosted: Tue Jul 11, 2017 6:57 am    Post subject: Reply with quote

IMHO your system uses intel as the default card. So does mine and there is no need to blacklist the nouveau driver.

If unsure:

#/etc/modprobe.d/blacklist.conf
blacklist nouveau
blacklist nvidia

Code:
xrandr --listproviders

will show the cards you can use.

Code:
glxinfo | grep "OpenGL renderer"

will probably show your intel device.

If you'd like to use PRIME (i. e. using your NVIDIA device on demand)

Code:
xrandr --setprovideroffloadsink nouveau Intel

Code:
DRI_PRIME=1 glxinfo | grep "OpenGL renderer"

which will show your NVIDIA device.

https://wiki.archlinux.org/index.php/PRIME
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum