Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201705-09 ] Apache Tomcat
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Mon Jul 10, 2017 3:26 pm    Post subject: [ GLSA 201705-09 ] Apache Tomcat Reply with quote

Gentoo Linux Security Advisory

Title: Apache Tomcat: Multiple vulnerabilities (GLSA 201705-09)
Severity: high
Exploitable: local, remote
Date: 2017-05-18
Bug(s): #575796, #586966, #595978, #615868
ID: 201705-09

Synopsis

Multiple vulnerabilities have been found in Apache Tomcat, the
worst of which could lead to privilege escalation.


Background

Apache Tomcat is a Servlet-3.0/JSP-2.2 Container.

Affected Packages

Package: www-servers/tomcat
Vulnerable: < 8.0.36
Unaffected: >= 8.0.36
Unaffected: >= 7.0.70
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in Tomcat. Please review
the CVE identifiers referenced below for details.


Impact

A remote attacker may be able to cause a Denial of Service condition,
obtain sensitive information, bypass protection mechanisms and
authentication restrictions.
A local attacker, who is a tomcat’s system user or belongs to
tomcat’s group, could potentially escalate privileges.


Workaround

There is no known workaround at this time.

Resolution

All Apache Tomcat users have to manually check their Tomcat runscripts
to make sure that they don’t use an old, vulnerable runscript. In
addition:
All Apache Tomcat 7 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=www-servers/tomcat-7.0.70:7"
   
All Apache Tomcat 8 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=www-servers/tomcat-8.0.36:8"
   


References

CVE-2015-5174
CVE-2015-5345
CVE-2015-5346
CVE-2015-5351
CVE-2016-0706
CVE-2016-0714
CVE-2016-0763
CVE-2016-1240
CVE-2016-3092
CVE-2016-8745
CVE-2017-5647
CVE-2017-5648
CVE-2017-5650
CVE-2017-5651
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum