Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201706-24 ] jbig2dec
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Tue Jul 11, 2017 9:26 pm    Post subject: [ GLSA 201706-24 ] jbig2dec Reply with quote

Gentoo Linux Security Advisory

Title: jbig2dec: Multiple vulnerabilities (GLSA 201706-24)
Severity: normal
Exploitable: remote
Date: 2017-06-22
Bug(s): #545234, #607188
ID: 201706-24

Synopsis

Multiple vulnerabilities have been found in jbig2dec, the worst of
which might allow remote attackers to execute arbitrary code.


Background

jbig2dec is a decoder implementation of the JBIG2 image compression
format.


Affected Packages

Package: media-libs/jbig2dec
Vulnerable: < 0.13-r1
Unaffected: >= 0.13-r1
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in jbig2dec. Please review
the CVE identifiers referenced below for details.


Impact

A remote attacker could entice a user or automated system to process a
specially crafted JBIG2 image file using an application linked against
jbig2dec library, possibly resulting in execution of arbitrary code with
the privileges of the process or a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All jbig2dec users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-libs/jbig2dec-0.13-r1"
   


References

CVE-2016-9601
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum