Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Console without framebuffer in UEFI mode
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Wed Jul 26, 2017 8:00 am    Post subject: Reply with quote

Code:

CONFIG_FB=y
CONFIG_FB_EFI=y
CONFIG_FRAMEBUFFER_CONSOLE=y


Code:

[    0.291074] efifb: probing for efifb
[    0.291093] efifb: framebuffer at 0xc0000000, using 5120k, total 5120k
[    0.291100] efifb: mode is 1280x1024x32, linelength=5120, pages=1
[    0.291106] efifb: scrolling: redraw
[    0.291112] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    0.297452] Console: switching to colour frame buffer device 160x64
[    0.303670] fb0: EFI VGA frame buffer device
[    1.436878] fb: switching to radeondrmfb from EFI VGA


Now I can see the kernel and systemd messages but then all goes blank. I can't see the login prompt.
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Wed Jul 26, 2017 8:09 am    Post subject: Reply with quote

Code:
fb: switching to radeondrmfb from EFI VGA
needs
Code:
CONFIG_FB_RADEON=m
CONFIG_DRM_RADEON=m
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Wed Jul 26, 2017 8:58 am    Post subject: Reply with quote

josephg wrote:
Code:
fb: switching to radeondrmfb from EFI VGA
needs
Code:
CONFIG_FB_RADEON=m
CONFIG_DRM_RADEON=m


Still not working:

Code:

#
# Graphics support
#
# CONFIG_AGP is not set
CONFIG_VGA_ARB=y
CONFIG_VGA_ARB_MAX_GPUS=16
# CONFIG_VGA_SWITCHEROO is not set
CONFIG_DRM=y
# CONFIG_DRM_DP_AUX_CHARDEV is not set
# CONFIG_DRM_DEBUG_MM is not set
# CONFIG_DRM_DEBUG_MM_SELFTEST is not set
CONFIG_DRM_KMS_HELPER=m
# CONFIG_DRM_FBDEV_EMULATION is not set
# CONFIG_DRM_LOAD_EDID_FIRMWARE is not set
CONFIG_DRM_TTM=m

#
# I2C encoder or helper chips
#
# CONFIG_DRM_I2C_CH7006 is not set
# CONFIG_DRM_I2C_SIL164 is not set
# CONFIG_DRM_I2C_NXP_TDA998X is not set
CONFIG_DRM_RADEON=m
CONFIG_DRM_RADEON_USERPTR=y
CONFIG_DRM_AMDGPU=m
# CONFIG_DRM_AMDGPU_SI is not set
CONFIG_DRM_AMDGPU_CIK=y
CONFIG_DRM_AMDGPU_USERPTR=y
# CONFIG_DRM_AMDGPU_GART_DEBUGFS is not set

#
# Frame buffer Devices
#
CONFIG_FB=y
# CONFIG_FIRMWARE_EDID is not set
CONFIG_FB_CMDLINE=y
CONFIG_FB_NOTIFY=y
CONFIG_FB_DDC=m
# CONFIG_FB_BOOT_VESA_SUPPORT is not set
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
# CONFIG_FB_CFB_REV_PIXELS_IN_BYTE is not set
# CONFIG_FB_SYS_FILLRECT is not set
# CONFIG_FB_SYS_COPYAREA is not set
# CONFIG_FB_SYS_IMAGEBLIT is not set
# CONFIG_FB_PROVIDE_GET_FB_UNMAPPED_AREA is not set
# CONFIG_FB_FOREIGN_ENDIAN is not set
# CONFIG_FB_SYS_FOPS is not set
# CONFIG_FB_SVGALIB is not set
# CONFIG_FB_MACMODES is not set
CONFIG_FB_BACKLIGHT=y
CONFIG_FB_MODE_HELPERS=y
# CONFIG_FB_TILEBLITTING is not set

#
# Frame buffer hardware drivers
#
# CONFIG_FB_CIRRUS is not set
# CONFIG_FB_PM2 is not set
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_ARC is not set
# CONFIG_FB_ASILIANT is not set
# CONFIG_FB_IMSTT is not set
# CONFIG_FB_VGA16 is not set
# CONFIG_FB_UVESA is not set
# CONFIG_FB_VESA is not set
CONFIG_FB_EFI=y
# CONFIG_FB_N411 is not set
# CONFIG_FB_HGA is not set
# CONFIG_FB_OPENCORES is not set
# CONFIG_FB_S1D13XXX is not set
# CONFIG_FB_NVIDIA is not set
# CONFIG_FB_RIVA is not set
# CONFIG_FB_I740 is not set
# CONFIG_FB_LE80578 is not set
# CONFIG_FB_MATROX is not set
CONFIG_FB_RADEON=m
CONFIG_FB_RADEON_I2C=y
CONFIG_FB_RADEON_BACKLIGHT=y
# CONFIG_FB_RADEON_DEBUG is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_ATY is not set
# CONFIG_FB_S3 is not set
# CONFIG_FB_SAVAGE is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_NEOMAGIC is not set
# CONFIG_FB_KYRO is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_VT8623 is not set
# CONFIG_FB_TRIDENT is not set
# CONFIG_FB_ARK is not set
# CONFIG_FB_PM3 is not set
# CONFIG_FB_CARMINE is not set
# CONFIG_FB_SMSCUFX is not set
# CONFIG_FB_UDL is not set
# CONFIG_FB_IBM_GXT4500 is not set
# CONFIG_FB_VIRTUAL is not set
# CONFIG_FB_METRONOME is not set
# CONFIG_FB_MB862XX is not set
# CONFIG_FB_BROADSHEET is not set
# CONFIG_FB_AUO_K190X is not set
# CONFIG_FB_SIMPLE is not set
# CONFIG_FB_SM712 is not set

#
# Console display driver support
#
CONFIG_VGA_CONSOLE=y
# CONFIG_VGACON_SOFT_SCROLLBACK is not set
CONFIG_DUMMY_CONSOLE=y
CONFIG_DUMMY_CONSOLE_COLUMNS=80
CONFIG_DUMMY_CONSOLE_ROWS=25
CONFIG_FRAMEBUFFER_CONSOLE=y
# CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY is not set
# CONFIG_FRAMEBUFFER_CONSOLE_ROTATION is not set
# CONFIG_FB_CON_DECOR is not set
# CONFIG_LOGO is not set

Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Wed Jul 26, 2017 11:08 am    Post subject: Reply with quote

To make it work I had to enable fbdev support for KMS.

These are the kernel options:
Code:

Graphics support
| [m] ATI Radeon (DRM_RADEON)
|----- [y] Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) (DRM)
|---------- [y] Enable legacy fbdev support for your modesetting driver (DRM_FBDEV_EMULATION)
|----- Frame buffer Devices
|---------- [y] EFI-based Framebuffer Support (FB_EFI)


Code:

[    0.288875] efifb: probing for efifb
[    0.288893] efifb: framebuffer at 0xc0000000, using 5120k, total 5120k
[    0.288900] efifb: mode is 1280x1024x32, linelength=5120, pages=1
[    0.288905] efifb: scrolling: redraw
[    0.288912] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    0.301478] fb0: EFI VGA frame buffer device
[    1.417872] fb: switching to radeondrmfb from EFI VGA
[    2.759589] [drm] fb mappable at 0xC0722000
[    2.759614] [drm] fb depth is 24
[    2.759939] fbcon: radeondrmfb (fb0) is primary device
[    2.776402] radeon 0000:00:01.0: fb0: radeondrmfb frame buffer device
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Wed Jul 26, 2017 1:29 pm    Post subject: Reply with quote

sebaro wrote:
Enable legacy fbdev support for your modesetting driver (DRM_FBDEV_EMULATION)

ah yes, i hit that myself.. a while back :oops: got thrown off by the words "legacy" "emulation" etc, and decided i didn't need it. took me a while to figure out :roll:
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Wed Jul 26, 2017 3:29 pm    Post subject: Reply with quote

I've marked this topic solved and added the conclusions on first post.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum