Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
delete vfat partition with question marks?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
nordic bro
Guru
Guru


Joined: 25 Oct 2003
Posts: 582

PostPosted: Fri Aug 11, 2017 7:22 am    Post subject: delete vfat partition with question marks? Reply with quote

this is my first go around with uefi/gpt and I somehow ended up with this (/dev/sda1):

Code:
df /mnt/
Filesystem     Type 1K-blocks  Used Available Use% Mounted on
/dev/sda1      vfat     00000 00000     00000  28% /mnt


Code:
ls -la /mnt
ls: cannot access '/mnt/EFI': Input/output error
total 4508
drwxr-xr-x  4 root root     512 Dec 31  1969 .
drwxr-xr-x 26 root root    4096 Aug  7 15:22 ..
d?????????  ? ?    ?          ?            ? EFI
-rwxr-xr-x  1 root root 4610496 Jun  8 02:37 vmlinuz_4.11.3_ck1


Code:
GPT fdisk (gdisk) version 1.0.1

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 1953525168 sectors, 931.5 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): C5E519D8-219D-40A1-AAD7-21AF1451F54C
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1953525134
Partitions will be aligned on 2048-sector boundaries
Total free space is 4029 sectors (2.0 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048            6143   2.0 MiB     EF02  grub
   2            6144          268287   128.0 MiB   EF00  boot
   3          268288        31743999   15.0 GiB    8300  rootfs
   4        31744000        62463999   14.6 GiB    8300 
   5        62464000        82943999   9.8 GiB     8300 
   6        82944000       123903999   19.5 GiB    8300 
   7       123904000       205823999   39.1 GiB    8300
   8       205824000       328703999   58.6 GiB    8300 
   9       328704000      1277683711   452.5 GiB   8E00 
  10      1277683712      1953523119   322.3 GiB   8300

this was after using the gentoo handbook. I'm 99% I put that vmlinuz file there and maybe made the efi dir when I was trying to figure out how all this worked. but notice the kernel img is supposedly twice the size of the partition. and what are all the ? on efi dir?

I want to remove that kernel img but keep getting 'read-only' msgs. is there any risk doing mkfs.fat ... again to wipe out sda1? my fear is I don't know how it got this way so am afraid I'll erase some critical boot info my asus efi/bios put there. or maybe something the win8.1 bios/mbr install to sdb put there. I'm changing from grub to refind so if grub did this in the process of its install I have no problem losing that.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7130
Location: almost Mile High in the USA

PostPosted: Fri Aug 11, 2017 7:46 am    Post subject: Reply with quote

It looks like somehow you got your disk corrupted.

- Check 'dmesg' to see if your disk is having trouble reading.

- Perhaps you copied something to /dev/sdXXX by mistake instead of copying to a mounted directory? Or tried installing MBR GRUB to a GPT disk somehow (not sure what happens in this case...)

The ????'s are usually because the program couldn't parse the data read from the disk, usually due to corruption.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
nordic bro
Guru
Guru


Joined: 25 Oct 2003
Posts: 582

PostPosted: Fri Aug 11, 2017 7:59 pm    Post subject: Reply with quote

thanks. if it's partition corruption that should mean it won't be a disaster if I run mkfs.fat on sda1 and clear it out? or when you say "disk corrupted" you mean something about the disk itself that's more than just sda1? for example sda1 may 'bleed' into sda2 and mkfs on sda1 would wipe out sda2?

there is nothing I know of on sda1 I care about unless motherboard boot loader put something there and that's the reason sda1 looks the way it does. I wondered if grub/motherboard boot loader used a filesystem trick that for a typical mount results in the "????" in order to make that efi dir unviewable/inaccessible and protect it from a user change?

to answer the things you bring up I never did a 'grub-install /dev/sdX'. I grep'd -i serr/sata in dmesg and it's all ok. I happen to have a cronjob running that scans /var/log/messages for serr (past sata cable/connector issues on my old machine) and nothing has shown up since installing sda. before initially getting the gentoo sda build set up a couple months ago I ran the wd tool to do a thorough scan of the new disk and that went ok too.

I only made sda1 because of the gentoo handbook and have linux efi boot working from sda2. I could just leave sda1 alone but the problem is I need to have refind do a manual/hdbios scan to offer booting the bios win7 on mbr/sdc and bios win 8.1 on mbr/sdb. in the process of doing that it keeps adding the sda1 kernel img to the list and so far I haven't figured out how to tell refind to quit showing that one. the easiest thing is to reformat sda1 but seeing the weirdness about it in op makes me afraid to try :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum