Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NVM-SOLVED: Ryzen specs in GCC/make.conf issue
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 14 Aug 2017
Posts: 1

PostPosted: Mon Aug 14, 2017 11:21 pm    Post subject: NVM-SOLVED: Ryzen specs in GCC/make.conf issue Reply with quote

SOLVED: -mclzero was not recognized as a CFLAG.

Had nothing to do with my USE definitions, I guess. So far!


I'm installing gentoo, first time user.... I started over but this time I'm making sure I specialize it for Ryzen rather than go ahead with the normal build, which didn't work the first time.

Emerge syncing/updating/commands were working until I edited the USE tags. I edited the list of USE= in /etc/portage/make.conf and my next emerge call gave back errors.

So I followed emerge's advice and called
(chroot) livecd / # emerge --info '=dev-libs/libedit-20130712.3.1::gentoo'

which gave:

Portage 2.3.6 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop, gcc-5.4.0, glibc-2.23-r4, 4.5.2-aufs-r1 x86_64)
                         System Settings
System uname: Linux-4.5.2-aufs-r1-x86_64-AMD_Ryzen_5_1600_Six-Core_Processor-with-gentoo-2.3
KiB Mem:    12237168 total,   7765464 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Mon, 14 Aug 2017 23:00:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28 p1.2) 2.28
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.1-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.28::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.15-r2::gentoo
sys-devel/binutils:       2.28-r2::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r4::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

CFLAGS="-march=bdver4 -mno-fma4 -mno-tbm -mno-xop -mno-lwp -mclzero -madx -mrdseed -mmwaitx -msha -mxsavec -mxsaves -mclflushopt -mpopcnt -02"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=bdver4 -mno-fma4 -mno-tbm -mno-xop -mno-lwp -mclzero -madx -mrdseed -mmwaitx -msha -mxsavec -mxsaves -mclflushopt -mpopcnt -02"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac aalib acl acpi alsa amd64 apache2 apm audiofile berkdb bidi bluetooth branding bsf bzip2 cairo calendar cdda cddb cdr cgi cli consolekit cracklib crypt cups curl cxx dbi dbm dbus debug dga djvu doc dri dts dvb dvd dvdr emacs emboss encode examples exif expat fam fastcgi fbcon firefox flac flatfile fltk fontconfig fortran ftp gcj gd gdbm geoip ggi gif gimp git glamor glut gmp gnome gnome-keyring gnuplot gnutls gphoto2 gpm gps graphviz gsl gsm gstreamer gtk guile gzip hddtemp hdf5 hscolour iconv icu idn ieee1394 imagemagick imap imlib infiniband inifile inotify introspection ipv6 jack java javascript jbig jit jpeg jpeg2k ladspa lame lapack lash latex lcms ldap libass libcaca libedit libffi libnotify lm_sensors lzma lzo mad matrox memcached memlimit mhash mikmod milter mime mmap mms mng modplug modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mssql mtp mule multilib musepack mysql mysqli nas ncurses neXt netcdf networkmanager nls nntp nocd nptl odbc ogg openal openexr opengl openmp oracle osc oss pam pango pcmcia pcntl pcre pda pdf perl php plotutils png policykit portaudio posix postscript ppds profile pulseaudio python qt3support qt4 qt5 quicktime raw readline recode rss ruby sasl scanner sdl seccomp session sharedmem shorten simplexml slang slp smartcard smp sndfile snmp soap sockets socks5 sound source sox speex spell sqlite ssl startup-notification svg symlink syslog sysvipc szip taglib tcl tcpd theora threads tidy tiff timidity tk tokenizer truetype udev udisks unicode upnp upnp-av upower usb v4l vaapi vala vcd vdpau vhosts videos vim-syntax vorbis wavpack wddx webkit wifi wmf wxwidgets x264 xattr xcb xcomposite xemacs xft xine xinerama xinetd xml xmp xmpp xpm xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Can someone tell me why this didn't work? Thank you in advance!

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message

Joined: 25 Jul 2006
Posts: 3850
Location: Illinois, USA

PostPosted: Tue Aug 15, 2017 12:03 am    Post subject: Reply with quote

This includes the most important things.

You seem to have set every use flag in the book. I thought I had a lot of use flags!
USE="-acl -perl -gnome -policykit -caps -consolekit -ldap -nls -systemd \
     -libav -mysql -orc -udev -dbus -udisks -upower -networkmanager \
     -bluetooth dvb dvd dvdr ffmpeg v4l ftp jpeg gbm guile \
     gstreamer python scanner sndfile samba sqlite suid tahoma truetype tk xpm \
     xv multislot gtk3 -qt4 qt5 -ipv6"
Many Gentooers would say that list is too many! Notice that I have a bias against redhat, hence nine flags are to keep redhat stuff off the machine. Some of those are turned back on in package.use. I really have no problem with perl, but gentoo perl updates are such a PITA that I prefer to use as little as possible. The "-qt4 -qt5" is to allow only qt6. Qt and kde are also big update messes.

The use flag hierarchy is as follows:

1. Your profile sets your basic use flags. They have been pre-selected for you as likely what you need for your profile. I have heard of users that have nothing for use flags in make.conf. A bit extreme IMHO.

2. Use flags set in make.conf override or supplement the flags in your profile. Notice that I have explained most of my flags above.

3. Use flags set on a per package basis in package.use override those set in (1) and (2). For instance I have dbus enabled on some packages because they will not build or run without it.

The most basic thing for you to decide is systemd or not. If you want systemd (want herpes too?), you should set a systemd profile and I would add the systemd flag in make.conf for suspenders AND belt. Likewise if you don't want systemd.

Which profile have you selected?
Available profile symlink targets:
  [1]   default/linux/amd64/13.0
  [2]   default/linux/amd64/13.0/selinux
  [3]   default/linux/amd64/13.0/desktop *
  [4]   default/linux/amd64/13.0/desktop/gnome
  [5]   default/linux/amd64/13.0/desktop/gnome/systemd
  [6]   default/linux/amd64/13.0/desktop/plasma
  [7]   default/linux/amd64/13.0/desktop/plasma/systemd
  [8]   default/linux/amd64/13.0/developer
  [9]   default/linux/amd64/13.0/no-multilib
  [10]  default/linux/amd64/13.0/systemd
  [11]  default/linux/amd64/13.0/x32
  [12]  hardened/linux/amd64
  [13]  hardened/linux/amd64/selinux
  [14]  hardened/linux/amd64/no-multilib
  [15]  hardened/linux/amd64/no-multilib/selinux
  [16]  hardened/linux/amd64/x32
  [17]  hardened/linux/musl/amd64
  [18]  hardened/linux/musl/amd64/x32
  [19]  default/linux/uclibc/amd64
  [20]  hardened/linux/uclibc/amd64

Next you should set some basic variables. I suggest these:
CFLAGS="-march=native -O2 -pipe"
PYTHON_TARGETS="python2_7 python3_4"
USE_PYTHON='2.7 3.4 '
The j4 is because this (real) example runs on an Athlon II X3. My Phenom II X6 has j7.
The Python settings are extremely conservative. that's my personality.

To say more I would need to know what machine you are running and how you intend to use it. This short list is appropriate for a tricore PC running an X server. If you like KDE or GNOME or no X, then things would change.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum