Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Freeze at boot but not on reboot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Lokesh
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2012
Posts: 131

PostPosted: Sun Aug 13, 2017 4:55 pm    Post subject: [solved] Freeze at boot but not on reboot Reply with quote

Hello again,
every week another issue. This time:
when I start the computer, the boot process freezes immediately after the grub boot selection. In case of Gentoo, not in case of the other OS, which is a Debian. When I boot into Debian and then reboot, Gentoo will load normal, with the observation that the system time is reset to UTC. This implies to me that it is NOT a grub issue or any of its settings.

I have no idea where to look into. Therefore apologies for presenting almost nil information. I checked /var/log/syslog, but nothing.

Any help?

Lokesh
_________________
Sometimes frustrated Linux User


Last edited by Lokesh on Mon Aug 14, 2017 9:41 am; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Sun Aug 13, 2017 6:27 pm    Post subject: Reply with quote

Check your /etc/conf.d/hwclock:
Code:

# Set CLOCK to "UTC" if your Hardware Clock is set to UTC (also known as
# Greenwich Mean Time).  If that clock is set to the local time, then
# set CLOCK to "local".  Note that if you dual boot with Windows, then
# you should set it to "local".
clock="UTC"


Try setting it to "local". It says "Windows" above, but this might apply to dual-booting with any other OS.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13831

PostPosted: Mon Aug 14, 2017 12:49 am    Post subject: Reply with quote

Strictly speaking, it applies to dual booting any OS that, like Windows, improperly stores local time instead of UTC into the hardware clock. Generally, Linux systems store UTC unless told not to. I would expect Debian is using UTC.

Lokesh: what is printed before Gentoo hangs?
Back to top
View user's profile Send private message
Lokesh
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2012
Posts: 131

PostPosted: Mon Aug 14, 2017 5:31 am    Post subject: Reply with quote

Hu wrote:
Lokesh: what is printed before Gentoo hangs?

IGood morning,

I am getting to the grub menu list, where the options (OSs) are listet. Selecting Gentoo is followed by "Gentoo is being loaded" or so, just like the grub entry's last line, that appears when I press "e" to edit it (it says "echo blabla"). The setting for the vmlinux-version-gentoo is correct, including the root credentials

I don't think it is a Grub thing, since the grub menu appears properly, Debian can be bootet through it. Even worse, simple reboot from Debian into Gentoo works like a charm.
_________________
Sometimes frustrated Linux User
Back to top
View user's profile Send private message
Lokesh
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2012
Posts: 131

PostPosted: Mon Aug 14, 2017 5:37 am    Post subject: Reply with quote

audiodef wrote:
Check your /etc/conf.d/hwclock:
Code:

# Set CLOCK to "UTC" if your Hardware Clock is set to UTC (also known as
# Greenwich Mean Time).  If that clock is set to the local time, then
# set CLOCK to "local".  Note that if you dual boot with Windows, then
# you should set it to "local".
clock="UTC"


Try setting it to "local". It says "Windows" above, but this might apply to dual-booting with any other OS.

Hm, I had problems with my system time discussed in this thread. Fitzcarraldo offered the solution which works since, but it includes to set the clock to UTC.
_________________
Sometimes frustrated Linux User
Back to top
View user's profile Send private message
Lokesh
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2012
Posts: 131

PostPosted: Mon Aug 14, 2017 5:51 am    Post subject: Reply with quote

Hu wrote:
Strictly speaking, it applies to dual booting any OS that, like Windows, improperly stores local time instead of UTC into the hardware clock. Generally, Linux systems store UTC unless told not to. I would expect Debian is using UTC.
I never cared for that in Debian. Upon your comment I checked and
Code:
cat /etc/adjtime
-0.015972 1470134881 0.000000
1470134881
local
So, on Gentoo the hwclock is set to UTC, in Debian to local. Probably not a good idea. I change it to UTC
Code:
datetimectl set-local-rtc 0
(systemd)

Lets see ....

EDIT: back on Gentoo, it booted without a problem. I shall wait a couple of hours, if it stays like that thread will be marked as solved. Than you Hu and audiodef for your support

EDIT 2: problem still gone. I mark it as solved. What a mess, never had anything like that in the past 100 years!
_________________
Sometimes frustrated Linux User
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Mon Aug 14, 2017 7:26 pm    Post subject: Reply with quote

Lokesh wrote:

EDIT 2: problem still gone. I mark it as solved. What a mess, never had anything like that in the past 100 years!


What kind of lifestyle do you follow? I want to do it too, so I can live that long!
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum