Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Cannot emerge virtualbox-modules after kernel upgr
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Nontenda
n00b
n00b


Joined: 14 Aug 2017
Posts: 3

PostPosted: Mon Aug 14, 2017 7:20 pm    Post subject: [Solved] Cannot emerge virtualbox-modules after kernel upgr Reply with quote

Hi there,

I just upgrade my kernel to 4.12.5, I copied my .config file and my system booted just fine.

However it failed at launching virtualbox module (ofc I didn't re-compile them).
So I ran a
Quote:
emerge --ask --oneshot @module-rebuild


Sadly it failed at emerging the package, the log file can be view here :

https://pastebin.com/z3iVqUWw

My kernel has the option of loading modules.

Can anybody help me on that ?
Thank's

EDIT : Thank's guys, problem solved by running :

Quote:
emerge --ask --autounmask-write =virtualbox-5.1.24


Last edited by Nontenda on Mon Aug 14, 2017 10:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Mon Aug 14, 2017 7:30 pm    Post subject: Reply with quote

What is the output of emerge -p --ask --oneshot @module-rebuild?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21773
Location: here

PostPosted: Mon Aug 14, 2017 7:32 pm    Post subject: Reply with quote

It's a know bug.
Unmask virtualbox >=5.1.24 to solve
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Nontenda
n00b
n00b


Joined: 14 Aug 2017
Posts: 3

PostPosted: Mon Aug 14, 2017 7:33 pm    Post subject: Reply with quote

I just ran : emerge --ask --autounmask-write =virtualbox-5.1.24

After a dispatch-conf, it's emerging the version 5.1.24 of virtualbox and virtualbox-modules.

Do I need to "remask" virtualbox > 5.1.24 after this bug is resolved ?

Thank's for your help.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Mon Aug 14, 2017 7:52 pm    Post subject: Reply with quote

No, you should never mask successfully installed versions.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Nontenda
n00b
n00b


Joined: 14 Aug 2017
Posts: 3

PostPosted: Mon Aug 14, 2017 7:56 pm    Post subject: Reply with quote

audiodef wrote:
No, you should never mask successfully installed versions.


Ok thank you :)
I'll wait for my emerge command to finish and will edit my post to add "Solved" ;)

Thank you very much.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21773
Location: here

PostPosted: Mon Aug 14, 2017 8:04 pm    Post subject: Reply with quote

Nontenda wrote:
Do I need to "remask" virtualbox > 5.1.24 after this bug is resolved ?

Bug is resolved in version 5.1.24 I don't think that there will be a backport to 5.0.x
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum