Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error emerge gnome-shell from gnome-next overlay
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
fleixi
n00b
n00b


Joined: 20 Aug 2017
Posts: 3

PostPosted: Sun Aug 20, 2017 12:06 pm    Post subject: Error emerge gnome-shell from gnome-next overlay Reply with quote

Im using the gnome-next overlay on an armv7 system and im not able to compile gnome-shell-9999-r1:

Code:
glib-1.0' '--extra-library=wayland-egl' '--extra-library=wayland-client' '--extra-library=Xtst' '--extra-library=Xi' '--extra-library=mutter-cogl-1' '--extra-library=gmodule-2.0' '-pthread' '--extra-library=gbm' '--extra-library=drm' '--extra-library=wayland-server' '--extra-library=EGL' '--extra-library=X11' '--extra-library=Xext' '--extra-library=Xdamage' '--extra-library=Xfixes' '--extra-library=Xcomposite' '--extra-library=Xrandr' '--extra-library=mutter-cogl-pango-1' '--extra-library=startup-notification-1' '--extra-library=girepository-1.0' '--extra-library=canberra' '--extra-library=canberra-gtk3' '--extra-library=polkit-agent-1' '--extra-library=polkit-gobject-1' '--extra-library=gcr-base-3' '--extra-library=gck-1' '--extra-library=p11-kit' '-L/lib' '--extra-library=systemd' '--extra-library=nm-glib' '--extra-library=nm-util' '--extra-library=dbus-glib-1' '--extra-library=dbus-1' '--extra-library=nm-gtk' '--extra-library=secret-1' '--extra-library=gstreamer-1.0' '--extra-library=gstbase-1.0' '--extra-library=mutter-1' '--extra-library=m' '--add-include-path=/usr/share/gir-1.0' '--add-include-path=/usr/lib/mutter' '--add-include-path=/var/tmp/portage/gnome-base/gnome-shell-9999-r1/work/gnome-shell-9999-build/subprojects/gvc' '--add-include-path=/var/tmp/portage/gnome-base/gnome-shell-9999-r1/work/gnome-shell-9999-build/src' '--add-include-path=/var/tmp/portage/gnome-base/gnome-shell-9999-r1/work/gnome-shell-9999-build/src/st' '--library' 'gnome-shell'
ERROR: Malformed include 'nclude'

ninja: build stopped: subcommand failed.
 * ERROR: gnome-base/gnome-shell-9999-r1::gnome-next failed (compile phase):
 *   ninja -v -j1 -l0 -C /var/tmp/portage/gnome-base/gnome-shell-9999-r1/work/gnome-shell-9999-build failed
 *
 * Call stack:
 *     ebuild.sh, line  115:  Called src_compile
 *   environment, line 5285:  Called meson_src_compile
 *   environment, line 3699:  Called eninja '-C' '/var/tmp/portage/gnome-base/gnome-shell-9999-r1/work/gnome-shell-9999-build'
 *   environment, line 1751:  Called die
 * The specific snippet of code:
 *       "$@" || die "${nonfatal_args[@]}" "${*} failed"
 *
 * If you need support, post the output of `emerge --info '=gnome-base/gnome-shell-9999-r1::gnome-next'`,
 * the complete build log and the output of `emerge -pqv '=gnome-base/gnome-shell-9999-r1::gnome-next'`.
 * The complete build log is located at '/var/tmp/portage/gnome-base/gnome-shell-9999-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/gnome-shell-9999-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/gnome-base/gnome-shell-9999-r1/work/gnome-shell-9999-build'
 * S: '/var/tmp/portage/gnome-base/gnome-shell-9999-r1/work/gnome-shell-9999'


i have tried to compile Version 3.25.90 as well but same error. Version 3.25.4-r2 is working but i need to update.

I have locked inside the work directory for "nclude" but there is none so i think its a "autogenerated" problem.

emerge --info '=gnome-base/gnome-shell-9999-r1::gnome-next'
https://pastebin.com/h21p5brE

emerge -pqv '=gnome-base/gnome-shell-9999-r1::gnome-next'
[ebuild U ] gnome-base/gnome-shell-9999-r1 [3.25.4-r2] USE="bluetooth ibus networkmanager -nsplugin (-openrc-force)" PYTHON_TARGETS="python3_4 -python3_5 -python3_6"


environment https://pastebin.com/DVNwEWyY

build.log https://pastebin.com/J3xG8Kh4
Back to top
View user's profile Send private message
russK
l33t
l33t


Joined: 27 Jun 2006
Posts: 626

PostPosted: Mon Aug 21, 2017 3:21 am    Post subject: Reply with quote

Inside the build.log, there are flags to g-ir-scanner like this:
Code:
 '-include' '/usr/include/mozjs-52/js/RequiredDefines.h'


I suspect that is throwing the error, there is no -include option to g-ir-scanner. There is --include and -i.

I have no idea how to fix. You are on the bleeding edge. :)

Regards
Back to top
View user's profile Send private message
fleixi
n00b
n00b


Joined: 20 Aug 2017
Posts: 3

PostPosted: Wed Aug 23, 2017 7:43 pm    Post subject: Reply with quote

I see, you right. Im not sure what part is generate the include commands and i dont find anything wrong in the code. Im not sure where to post a bugreport? Gentoo-gnometeam? Gnomebugtracker?
Back to top
View user's profile Send private message
russK
l33t
l33t


Joined: 27 Jun 2006
Posts: 626

PostPosted: Wed Aug 23, 2017 8:38 pm    Post subject: Reply with quote

Maybe browse the github references in the layman info:
Code:
# layman --info gnome-next
Back to top
View user's profile Send private message
fleixi
n00b
n00b


Joined: 20 Aug 2017
Posts: 3

PostPosted: Fri Aug 25, 2017 5:07 pm    Post subject: Reply with quote

Thanks the problem was an to old meson (i have had used an meson-9999 ebuild file)
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1731
Location: Here and Away Again

PostPosted: Sat Aug 26, 2017 12:45 am    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software since this is about something not in Portage at this time.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum