Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pip for python3.5/3.6?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ShanaXXII
Apprentice
Apprentice


Joined: 29 Jun 2014
Posts: 283
Location: Canada

PostPosted: Wed Aug 23, 2017 11:41 pm    Post subject: pip for python3.5/3.6? Reply with quote

How do I build pip with support for python3.5/3.6?

It says that pip supports python3.4/3.5/3.6. but I only have the options 2.7 and 3.4
Adding python_targets_python3_6 to package.use doesn't affect it. :/

Code:
~ $ equery uses dev-python/pip
 * Found these USE flags for dev-python/pip-9.0.1-r1:
 U I
 - - python_targets_python2_7 : Build with Python 2.7
 + + python_targets_python3_4 : Build with Python 3.4

~ $ eix dev-python/pip
[I] dev-python/pip
     Available versions:  7.1.2^t 9.0.1-r1^t ~9.0.1-r2^t {-vanilla PYTHON_TARGETS="pypy pypy3 python2_7 python3_4 python3_5 python3_6"}
     Installed versions:  9.0.1-r1^t(02:55:55 PM 08/23/2017)(PYTHON_TARGETS="python3_4 -pypy -python2_7 -python3_5 -python3_6")
     Homepage:            https://pip.pypa.io/ https://pypi.python.org/pypi/pip/ https://github.com/pypa/pip/
     Description:         Installs python packages -- replacement for easy_install
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14060

PostPosted: Thu Aug 24, 2017 1:20 am    Post subject: Reply with quote

At the time of this writing, python_targets_python3_5 and python_targets_python3_6 are masked for stable packages by /usr/portage/profiles/base/use.stable.mask. Why do you need pip enabled for these targets? If you were on unstable, it would already be unmasked for you. If you are not on unstable, it is unlikely that you need pip to support these, since the underlying Python packages are also unstable.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22160
Location: here

PostPosted: Thu Aug 24, 2017 5:50 am    Post subject: Reply with quote

If you want unmask this use flags, at your own risk, command is
Code:
# echo "dev-python/pip -python_targets_python3_5 -python_targets_python3_6" >> /etc/portage/profile/package.use.mask

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ShanaXXII
Apprentice
Apprentice


Joined: 29 Jun 2014
Posts: 283
Location: Canada

PostPosted: Thu Aug 24, 2017 6:40 pm    Post subject: Reply with quote

Hu wrote:
At the time of this writing, python_targets_python3_5 and python_targets_python3_6 are masked for stable packages by /usr/portage/profiles/base/use.stable.mask. Why do you need pip enabled for these targets? If you were on unstable, it would already be unmasked for you. If you are not on unstable, it is unlikely that you need pip to support these, since the underlying Python packages are also unstable.

I wanted python-3.5+ for using async syntax for making a discord bot :lol:

Anyways, thanks everyone. :)

Before posting this,
I had tried using the get_pip script provided by their website.
But it ended up breaking gentoo(Emerge was broken).
So I ended up unpacking stage3 onto my system to fix things.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14060

PostPosted: Fri Aug 25, 2017 2:08 am    Post subject: Reply with quote

The forums are littered with people whose systems were broken by use of pip. As best I can tell, pip cannot be trusted with root privileges under any circumstances.
Back to top
View user's profile Send private message
R0b0t1
Apprentice
Apprentice


Joined: 05 Jun 2008
Posts: 255

PostPosted: Tue Aug 29, 2017 4:28 am    Post subject: Reply with quote

I strongly recommend using virtualenv. I can report success with python 3.5 and the corresponding version of pip.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum