Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
plasma-desktop failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
nordicruler
n00b
n00b


Joined: 20 Dec 2004
Posts: 60

PostPosted: Thu Sep 21, 2017 11:16 am    Post subject: plasma-desktop failed Reply with quote

Hello. Im trying to install plasma 5.10.95 beta, qt 5.9.1. Only 5 packages left and plasma-desktop failed.
Im using gcc-7.2.0. Anyone knows what is wrong here?

Code:
[ 41%] Linking CXX shared module kcm_autostart.so
cd /var/temp/portage/kde-plasma/plasma-desktop-9999/work/plasma-desktop-9999_build/kcms/autostart && /usr/bin/cmake -E cmake_link_script CMakeFiles/kcm_autostart.dir/link.txt --verbose=1
/usr/bin/x86_64-pc-linux-gnu-g++ -fPIC -march=native -O2 -pipe -std=c++0x -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Wvla -Wdate-time -Wl,--no-undefined -Wl,--fatal-warnings -Wl,--enable-new-dtags -Wl,-O1 -Wl,--as-needed -shared  -o kcm_autostart.so CMakeFiles/kcm_autostart.dir/autostartitem.cpp.o CMakeFiles/kcm_autostart.dir/addscriptdialog.cpp.o CMakeFiles/kcm_autostart.dir/advanceddialog.cpp.o CMakeFiles/kcm_autostart.dir/autostart.cpp.o CMakeFiles/kcm_autostart.dir/kcm_autostart_autogen/mocs_compilation.cpp.o /usr/lib64/libKF5KCMUtils.so.5.39.0 /usr/lib64/libKF5KIOWidgets.so.5.39.0 /usr/lib64/libKF5KIOCore.so.5.39.0 /usr/lib64/libKF5Service.so.5.39.0 /usr/lib64/libKF5JobWidgets.so.5.39.0 /usr/lib64/libKF5Completion.so.5.39.0 /usr/lib64/libQt5Network.so.5.9.1 /usr/lib64/libKF5ConfigWidgets.so.5.39.0 /usr/lib64/libKF5Codecs.so.5.39.0 /usr/lib64/libKF5ConfigGui.so.5.39.0 /usr/lib64/libKF5ConfigCore.so.5.39.0 /usr/lib64/libQt5Xml.so.5.9.1 /usr/lib64/libKF5Auth.so.5.39.0 /usr/lib64/libKF5WidgetsAddons.so.5.39.0 /usr/lib64/libQt5Widgets.so.5.9.1 /usr/lib64/libQt5Gui.so.5.9.1 /usr/lib64/libKF5I18n.so.5.39.0 /usr/lib64/libKF5CoreAddons.so.5.39.0 /usr/lib64/libQt5Core.so.5.9.1
make[2]: Leaving directory '/var/temp/portage/kde-plasma/plasma-desktop-9999/work/plasma-desktop-9999_build'
[ 41%] Built target kcm_autostart
make[1]: Leaving directory '/var/temp/portage/kde-plasma/plasma-desktop-9999/work/plasma-desktop-9999_build'
make: *** [Makefile:130: all] Error 2
 * ERROR: kde-plasma/plasma-desktop-9999::kde failed (compile phase):
 *   emake failed
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 809

PostPosted: Thu Sep 21, 2017 11:22 am    Post subject: Reply with quote

Quote:
plasma-desktop-9999
is not plasma-desktop-5.10.95.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Thu Sep 21, 2017 11:38 am    Post subject: Reply with quote

No error message contained in that tiny snippet.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
nordicruler
n00b
n00b


Joined: 20 Dec 2004
Posts: 60

PostPosted: Thu Sep 21, 2017 11:39 am    Post subject: Reply with quote

Perfect Gentleman wrote:
Quote:
plasma-desktop-9999
is not plasma-desktop-5.10.95.


So what is it that im installing then? Im using emerge plasma-meta-5.10.95
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22153
Location: here

PostPosted: Thu Sep 21, 2017 11:58 am    Post subject: Reply with quote

nordicruler wrote:
So what is it that im installing then? Im using emerge plasma-meta-5.10.95

Version 9999 are live upstream code.
Probably you have some entry in package.accept_keywords (grep plasma-desktop /etc/portage/package.accept_keywords)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
nordicruler
n00b
n00b


Joined: 20 Dec 2004
Posts: 60

PostPosted: Thu Sep 21, 2017 12:04 pm    Post subject: Reply with quote

fedeliallalinea wrote:
nordicruler wrote:
So what is it that im installing then? Im using emerge plasma-meta-5.10.95

Version 9999 are live upstream code.
Probably you have some entry in package.accept_keywords (grep plasma-desktop /etc/portage/package.accept_keywords)


Yes i have, but how do i remove this 9999 version then and install 5.10.95?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22153
Location: here

PostPosted: Thu Sep 21, 2017 12:08 pm    Post subject: Reply with quote

nordicruler wrote:
Yes i have, but how do i remove this 9999 version then and install 5.10.95?

Post your package.accept_keywords, but why you want upstream testing version 5.10.95 instead of 5.10.5?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Thu Sep 21, 2017 12:54 pm    Post subject: Reply with quote

Don't let Portage autounmask stuff blindly. Use kde overlay provided package.unmask files.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 809

PostPosted: Thu Sep 21, 2017 1:07 pm    Post subject: Reply with quote

nordicruler wrote:
So what is it that im installing then? Im using emerge plasma-meta-5.10.95

i've installed plasma-5.10.95 without any issues
Back to top
View user's profile Send private message
nordicruler
n00b
n00b


Joined: 20 Dec 2004
Posts: 60

PostPosted: Fri Sep 22, 2017 12:24 pm    Post subject: Reply with quote

I changed the keywords to 5.10.95 and its working. It is now installed and working good.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22153
Location: here

PostPosted: Fri Sep 22, 2017 1:02 pm    Post subject: Reply with quote

nordicruler wrote:
I changed the keywords to 5.10.95 and its working. It is now installed and working good.

You can also remove kde overlay, kde in gentoo has a great support (thanks to developers asturm, kensington,...) and updates in official portage tree are immediate.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum