Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't emerge 'www-client/chromium-62.0.3202.18::net-kit'
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
maratbn
n00b
n00b


Joined: 04 Jan 2012
Posts: 12

PostPosted: Fri Sep 22, 2017 3:31 am    Post subject: Can't emerge 'www-client/chromium-62.0.3202.18::net-kit' Reply with quote

I'm getting a compilation error when trying to emerge 'www-client/chromium-62.0.3202.18::net-kit'.

Here's the compilation error:

Code:

FAILED: obj/services/device/generic_sensor/generic_sensor/platform_sensor_reader_linux.o
x86_64-pc-linux-gnu-g++ -MMD -MF obj/services/device/generic_sensor/generic_sensor/platform_sensor_reader_linux.o.d -DV8_DEPRECATION_WARNINGS -DUSE_UDEV -DUSE_AURA=1 -DUSE_PANGO=1 -DUSE_CAIRO=1 -DUSE_GLIB=1 -DUSE_NSS_CERTS=1 -DUSE_X11=1 -DNO_TCMALLOC -DDISABLE_NACL -DFULL_SAFE_BROWSING -DSAFE_BROWSING_CSD -DSAFE_BROWSING_DB_LOCAL -DCHROMIUM_BUILD -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -DNDEBUG -DNVALGRIND -DDYNAMIC_ANNOTATIONS_ENABLED=0 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_32 -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_26 -I../.. -Igen -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -fno-strict-aliasing --param=ssp-buffer-size=4 -fstack-protector -Wno-builtin-macro-redefined -D__DATE__= -D__TIME__= -D__TIMESTAMP__= -funwind-tables -fPIC -pipe -pthread -m64 -march=x86-64 -Wall -Wno-unused-local-typedefs -Wno-maybe-uninitialized -Wno-missing-field-initializers -Wno-unused-parameter -O2 -fno-ident -fdata-sections -ffunction-sections -fomit-frame-pointer -g0 -fvisibility=hidden -std=gnu++14 -Wno-narrowing -fno-rtti -fno-exceptions -fvisibility-inlines-hidden -march=ivybridge -O2 -pipe -fno-delete-null-pointer-checks -c ../../services/device/generic_sensor/platform_sensor_reader_linux.cc -o obj/services/device/generic_sensor/generic_sensor/platform_sensor_reader_linux.o
In file included from ../../base/timer/timer.h:67:0,
                 from ../../services/device/generic_sensor/platform_sensor_reader_linux.cc:13:
../../base/bind.h: In instantiation of ‘struct base::internal::AssertConstructible<1ul, device::SensorReading&, device::SensorReading, const device::SensorReading&, device::SensorReading>’:
../../base/bind.h:87:8:   required from ‘struct base::internal::AssertBindArgsValidity<std::integer_sequence<long unsigned int, 0ul, 1ul>, base::internal::TypeList<base::WeakPtr<device::PlatformSensorLinux>&, device::SensorReading&>, base::internal::TypeList<device::PlatformSensorLinux*, const device::SensorReading&>, base::internal::TypeList<device::PlatformSensorLinux*, device::SensorReading> >’
../../base/bind.h:233:36:   required from ‘base::RepeatingCallback<typename base::internal::BindTypeHelper<Functor, BoundArgs>::UnboundRunType> base::BindRepeating(Functor&&, Args&& ...) [with Functor = void (device::PlatformSensorLinux::*)(device::SensorReading); Args = {base::WeakPtr<device::PlatformSensorLinux>&, device::SensorReading&}; typename base::internal::BindTypeHelper<Functor, BoundArgs>::UnboundRunType = void()]’
../../base/bind.h:242:23:   required from ‘base::Callback<typename base::internal::BindTypeHelper<Functor, BoundArgs>::UnboundRunType> base::Bind(Functor&&, Args&& ...) [with Functor = void (device::PlatformSensorLinux::*)(device::SensorReading); Args = {base::WeakPtr<device::PlatformSensorLinux>&, device::SensorReading&}; base::Callback<typename base::internal::BindTypeHelper<Functor, BoundArgs>::UnboundRunType> = base::RepeatingCallback<void()>; typename base::internal::BindTypeHelper<Functor, BoundArgs>::UnboundRunType = void()]’
../../services/device/generic_sensor/platform_sensor_reader_linux.cc:126:48:   required from here
../../base/bind.h:59:3: error: static assertion failed: Bound argument |i| of type |Arg| cannot be forwarded as |Unwrapped| to the bound functor, which declares it as |Param|.
   static_assert(
   ^
../../base/bind.h:70:3: error: static assertion failed: Bound argument |i| of type |Arg| cannot be converted and bound as |Storage|.
   static_assert(arg_is_storable,


Also getting this regular error message from Portage:

Code:

* ERROR: www-client/chromium-62.0.3202.18::net-kit failed (compile phase):
 *   ninja -v -j8 -l0 -C out/Release chrome chromedriver chrome_sandbox failed
 *
 * Call stack:
 *     ebuild.sh, line  115:  Called src_compile
 *   environment, line 5253:  Called eninja '-C' 'out/Release' 'chrome' 'chromedriver' 'chrome_sandbox'
 *   environment, line 1801:  Called die
 * The specific snippet of code:
 *       "$@" || die "${nonfatal_args[@]}" "${*} failed"
 *
 * If you need support, post the output of `emerge --info '=www-client/chromium-62.0.3202.18::net-kit'`,
 * the complete build log and the output of `emerge -pqv '=www-client/chromium-62.0.3202.18::net-kit'`.
 * The complete build log is located at '/var/tmp/portage/www-client/chromium-62.0.3202.18/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/www-client/chromium-62.0.3202.18/temp/environment'.
 * Working directory: '/var/tmp/portage/www-client/chromium-62.0.3202.18/work/chromium-62.0.3202.18'
 * S: '/var/tmp/portage/www-client/chromium-62.0.3202.18/work/chromium-62.0.3202.18'


This looks to me like Chromium has some new feature that would allow websites to detect the ambient light level around the user and adjust UI shades and colors accordingly, but the associated code may not compile across some configurations. I do not believe there is a way to deactivate this feature with USE flags. Any suggestions?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22201
Location: here

PostPosted: Fri Sep 22, 2017 6:10 am    Post subject: Reply with quote

The chromiun that you're trying to compile comes from net-kit overlay, you tried the official ebuild from gentoo?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
maratbn
n00b
n00b


Joined: 04 Jan 2012
Posts: 12

PostPosted: Fri Sep 22, 2017 6:36 am    Post subject: I'm emerging it on Funtoo. Reply with quote

I'm running Funtoo and this is what's emerging by default for chromium.
Back to top
View user's profile Send private message
Juippisi
Developer
Developer


Joined: 30 Sep 2005
Posts: 362
Location: /home

PostPosted: Fri Sep 22, 2017 8:13 am    Post subject: Reply with quote

Well, you may have to go to

https://bugs.funtoo.org

for help. But if I remember, Funtoo has had problems compiling chromium before because of their outdated GCC. So thats something Id look into...
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1805
Location: Here and Away Again

PostPosted: Fri Sep 22, 2017 9:17 am    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software, since this is about an ebuild not in Portage (or/and not about Gentoo in general).
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 809

PostPosted: Fri Sep 22, 2017 10:03 am    Post subject: Re: I'm emerging it on Funtoo. Reply with quote

maratbn wrote:
I'm running Funtoo and this is what's emerging by default for chromium.

why are you asking in Gentoo's forum if Funtoo's forum exists ?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14071

PostPosted: Sat Sep 23, 2017 12:03 am    Post subject: Reply with quote

Funtoo users wander in from time to time, and sometimes we can even help them.

We can help them a bit more often if they're forthcoming with system details, like that they're using Funtoo and the output of emerge --info. ;)
Back to top
View user's profile Send private message
maratbn
n00b
n00b


Joined: 04 Jan 2012
Posts: 12

PostPosted: Sat Sep 23, 2017 3:56 am    Post subject: Reply with quote

Sorry folks, I thought this might be an appropriate place to post given that Funtoo is based off Gentoo, and did not realize the systems were that different. I re-filed this issue in a Funtoo forum. Didn't mean to bother you.

I'm aware that the output of emerge --info is expected when filing formal bug reports, but was concerned it would be too much to start with here. But I'm sure if you encourage pasting emerge --info in the posting instructions you'll get plenty of it going forward.

Appreciate your analysis of this issue and what the problem could be re GCC.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14071

PostPosted: Sat Sep 23, 2017 4:08 am    Post subject: Reply with quote

It's not much bother. Sometimes the systems are similar enough that a Gentoo-oriented answer will apply to a Funtoo system. Sometimes they aren't. Mixing in extra overlays makes the situation more complicated.

Generally, it's not a big deal to post Funtoo questions as long as they're clearly marked so that people know some standard assumptions may not apply.
Back to top
View user's profile Send private message
maratbn
n00b
n00b


Joined: 04 Jan 2012
Posts: 12

PostPosted: Sat Sep 23, 2017 4:21 am    Post subject: Reply with quote

Quote:
Generally, it's not a big deal to post Funtoo questions as long as they're clearly marked so that people know some standard assumptions may not apply.

OK thanks Hu, noted.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum