Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eigenes ebuild & pkgconfig
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sat Sep 23, 2017 8:47 am    Post subject: eigenes ebuild & pkgconfig Reply with quote

Hallo zusammen,

bei meinem lokalen lensfun-9999.ebuild habe ich wohl etwas vermasselt:

Code:
* QA Notice: command not found:
 *
 *      /tmp/portage/media-libs/lensfun-9999/temp/environment: line 774: get_libdir: command not found
 *      /tmp/portage/media-libs/lensfun-9999/temp/environment: line 775: cmake-utils_src_configure: command not found


Außerdem kann gimp-lensfun die lensfun.pc nicht finden und bricht mit einem Fehler ab:

Code:
>>> Compiling source in /tmp/portage/media-plugins/gimp-lensfun-0.2.4/work/GIMP-Lensfun-0.2.4 ...
make -j9
Package lensfun was not found in the pkg-config search path.
Perhaps you should add the directory containing `lensfun.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lensfun' found
x86_64-pc-linux-gnu-g++ -march=native -O2 -pipe -DDEBUG=0 -O3 -Wall -fopenmp -pthread -I/usr/include/gimp-2.0 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2  -c -o src/gimplensfun.o src/gimplensfun.cpp
Package lensfun was not found in the pkg-config search path.
Perhaps you should add the directory containing `lensfun.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lensfun' found
src/gimplensfun.cpp:30:29: fatal error: lensfun/lensfun.h: No such file or directory
compilation terminated.
make: *** [Makefile:51: src/gimplensfun.o] Error 1
 * ERROR: media-plugins/gimp-lensfun-0.2.4::gentoo failed (compile phase):
 *   emake failed


OT: Wie kann ich hier im Code-Block eigentlich die Fehlermeldung farbig hervorheben? Das Pulldonw "Schriftfarbe" fügt zwar Markierungen ein, funktioniert aber in der Vorschau nicht....???

Alle anderen *.pc scheinen in /usr /lib64/pkgconfig zu liegen. Werden diese Dateien von pkgconfig erzeugt? Muss ich das im ebuild irgendwie triggern? Hier ist mein kopiertes & angepasstes ebuild:

Code:
# Copyright 1999-2011 Gentoo Foundation                                                                                                                                                   
 2 # Distributed under the terms of the GNU General Public License v2
 3 # $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.5-r1.ebuild,v 1.8 2011/06/01 19:47:11 ranger Exp $
 4 
 5 EAPI=5
 6 
 7 PYTHON_COMPAT=( python3_{4,5,6} )
 8 
 9 DESCRIPTION="lensfun: A library for rectifying and simulating photographic lens distortions"
10 HOMEPAGE="http://lensfun.sourceforge.net/"
11 
12 if [[ ${PV} == "9999" ]]; then
13     EGIT_REPO_URI=${EGIT_REPO_URI:-"git://git.code.sf.net/p/lensfun/code"}
14     inherit git-r3
15 else
16     SRC_URI="https://sourceforge.net/projects/lensfun/files/${PV}/lensfun-${PV}.tar.gz"
17 fi
18   
19 LICENSE="LGPL-3"
20 SLOT="1"
21 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ~ppc64 ~sh ~sparc x86"
22 IUSE="debug doc cpu_flags_x86_sse cpu_flags_x86_sse2 test"
23   
24   
25   
26 RDEPEND="
27     >=dev-libs/glib-2.28
28     media-libs/libpng:0=
29     sys-libs/zlib:=
30     ${PYTHON_DEPS}"
31   
32 DEPEND="${RDEPEND}
33     doc? (
34         app-doc/doxygen
35         dev-python/docutils
36     )"
37   
38 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
39   
40 DOCS=( README.md docs/mounts.txt ChangeLog )
41   
42 pkg_setup () {
43     if [[ ${PV} != "9999" ]]; then
44         S="${WORKDIR}/lensfun-${PV}"


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
LuxJux
Guru
Guru


Joined: 01 Mar 2016
Posts: 300

PostPosted: Sat Sep 23, 2017 5:47 pm    Post subject: Reply with quote

Betrifft nur das OT
Nein, das geht leider in BB-Fenstern wie Code oder Quote nicht.
Auch kein fett, kursiv oder bunt.

Um andere User auf signifikante Textstellen hinzuweisen, wäre z.B eine Unterbrechung im Textfluß

Code:
>>> Compiling source in /tmp/portage/media-plugins/gimp-lensfun-0.2.4/work/GIMP-Lensfun-0.2.4 ...
make -j9
Package lensfun was not found in the pkg-config search path.
Perhaps you should add the directory containing `lensfun.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lensfun' found
x86_64-pc-linux-gnu-g++ -march=native -O2 -pipe -DDEBUG=0 -O3 -Wall -fopenmp -pthread -I/usr/include/gimp-2.0 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 ======-I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2  -c -o src/gimplensfun.o src/gimplensfun.cpp
Package lensfun was not found in the pkg-config search path.
Perhaps you should add the directory containing `lensfun.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lensfun' found
------ (oder besser damit?)
src/gimplensfun.cpp:30:29: fatal error: lensfun/lensfun.h: No such file or directory
compilation terminated.
make: *** [Makefile:51: src/gimplensfun.o] Error 1
 * ERROR: media-plugins/gimp-lensfun-0.2.4::gentoo failed (compile phase):
 *   emake failed


Edit: Die Unterbrechungen nachbearbeitet, und den Hinweis das (danachnachfolgede bitte prüfen) mit zugeben
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6281

PostPosted: Sun Sep 24, 2017 9:21 am    Post subject: Reply with quote

get_libdir gibt es erst in EAPI=6 (noch nicht in EAPI=5).
Alternativ gäbe es das auch in der eutils.eclass, aber warum nicht gleich die aktuelle EAPI nehmen?

Für cmake-utils_src_configure fehlt Dir vermutlich ein inherit einer geeigneten eclass (cmake-multilib, cmake-utils o.ä.).
Da ohne dieses Kommando vermutlich effektiv kein configure-Lauf erfolgt, wird Letzteres vermutlich auch erklären, wieso die Konfiguration nicht richtig erkannt wird.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Sep 24, 2017 12:26 pm    Post subject: Reply with quote

Nach Umstellung auf EAPI=6 bekomme ich das hier:

Code:
* QA Notice: command not found:
 *
 *      /tmp/portage/media-libs/lensfun-9999/temp/environment: line 929: cmake-utils_src_configure: command not found
ecompressdir: bzip2 -9 /usr/share/doc


Damit rückt der zweite Teil mit cmake-utils_src_configure in den Blickpunkt - muss ich erst googeln....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Sun Sep 24, 2017 1:09 pm    Post subject: Reply with quote

uhai wrote:
Nach Umstellung auf EAPI=6 bekomme ich das hier:

Code:
* QA Notice: command not found:
 *
 *      /tmp/portage/media-libs/lensfun-9999/temp/environment: line 929: cmake-utils_src_configure: command not found
ecompressdir: bzip2 -9 /usr/share/doc


Damit rückt der zweite Teil mit cmake-utils_src_configure in den Blickpunkt - muss ich erst googeln....

uhai

oder dir einfach andere ebuilds anschauen, welche pakete mit cmake bauen
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Sep 24, 2017 3:24 pm    Post subject: Reply with quote

mit abgekupfertem inherit kommt ein neuer Fehler:

Code:
* QA Notice: files installed in ${D}/${D}:
 *   /
 *   /usr
 *   /usr/lib64
 *   /usr/lib64/python3.4
 *   /usr/lib64/python3.4/site-packages
 *   /usr/lib64/python3.4/site-packages/lensfun-0.3.2-py3.4.egg-info
 *   /usr/lib64/python3.4/site-packages/lensfun
 *   /usr/lib64/python3.4/site-packages/lensfun/__init__.py
 * ERROR: media-libs/lensfun-9999::mein-repo failed:
 *   Aborting due to QA concerns: 8 files installed in /tmp/portage/media-libs/lensfun-9999/image/tmp/portage/media-libs/lensfun-9999/image/
 *
 * Call stack:
 *   misc-functions.sh, line 605:  Called install_qa_check
 *   misc-functions.sh, line 217:  Called source 'install_symlink_html_docs'
 *          05double-D, line  15:  Called DD_check
 *          05double-D, line  11:  Called die
 * The specific snippet of code:
 *              die "Aborting due to QA concerns: ${#files[@]} files installed in ${D%/}${D}"


Was ist QA?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6281

PostPosted: Sun Sep 24, 2017 8:43 pm    Post subject: Reply with quote

uhai wrote:
Was ist QA?

Quality Assurance. Standard-Checks, die prüfen, ob alles vernünftig zu sein scheint. In Dienem Fall ist das Problem, dass aus irgendwelchen Gründen Files im Directory $D/$D (oder $ED/$D) landen.

So etwas passiert typischerweise, wenn entweder das Build-Systems des Pakets einen Fehler hat, oder aber (wahrscheinlicher), indem irgendwie schon zum Configure-Zeitpunkt angegeben wird, dass das Paket mit dem Präfix $D (oder $ED) (anstalle des default-Präfixes /) installiert werden soll, und später in der Installations-Phase nochmals angegeben wird, dass der Präfix $D (oder $ED) benutzt werden soll: Bei autotools etwa
src_configure wrote:
./configure --prefix="$ED" ...
und
src_install wrote:
make DESTDIR="$ED" install

(in der Configure-Phase sollte nirgendwo ein $D oder $ED benutzt werden, sondern nur in der Install-Phase).
Mit cmake und python und den entsprechenden eclasses wird nochmals als schwieriger. Ich würde mir an Deiner Stelle mal typische Python-Pakete anschauen, wie die das mit den Python-eclasses lösen:
Wenn es ein reines Python-Projekt ist, wirst Du das mitgeliefert cmake-basiert Build-System vielleicht gar nicht benutzen müssen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum