Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] lightdm - loops
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 20 Mar 2017
Posts: 222

PostPosted: Sat Sep 30, 2017 12:37 pm    Post subject: [solved] lightdm - loops Reply with quote

I've installed Gentoo (and Funtoo aswell) a couple of times during the years, and i use to install it EFI-way GPT jada jada...
I usually end up with xfce and lightdm with the gtk-greeter. Nothing fancy or special, but on my 2 last installs i didn't manage lightdm to work properly.
The other day i belived it had to do with me using no-multilib profile and that i've installed xfce on that one, so i reinstalled the whole thing and went with the default profile. Got it all up and running, then changed to desktop profile, configured X and went on installing lightdm, lightdm-gtk-greeter, and edited the lighdm.conf file as i always do, uncommenting and enabling lightdm-gkt-greeter. Then added dbus and xdm to runlevel, no visible errors what so ever.
But, lightdm just loops.

$ nano .xsession-errors
/usr/lib64/X11/xdm/Xsession: line 71: exec: xsm: not found

I uninstalled lightdm, lightdm-gtk-greeter, deleted runlevel services and added exec startxfce4 to my xinitrc and xfce starts fine using startx, and that ok, but i'm a bit curious why i suddenly got some issues with my kind of default installation.

My hw:

~ $ inxi -Fz
System:    Host: hoth Kernel: 4.12.12-gentoo x86_64 bits: 64 Desktop: Xfce 4.12.3
           Distro: Gentoo Base System release 2.3
Machine:   Device: desktop System: ASUS product: All Series serial: N/A
           Mobo: ASUSTeK model: X99-DELUXE II v: Rev 1.xx serial: N/A
           UEFI: American Megatrends v: 1701 date: 03/31/2017
CPU:       Octa core Intel Core i7-6900K (-HT-MCP-) cache: 20480 KB
           clock speeds: max: 4200 MHz 1: 4199 MHz 2: 4199 MHz 3: 4199 MHz 4: 4200 MHz 5: 4195 MHz 6: 4200 MHz
           7: 4200 MHz 8: 4199 MHz 9: 4200 MHz 10: 4199 MHz 11: 4200 MHz 12: 4200 MHz 13: 4200 MHz 14: 4200 MHz
           15: 4199 MHz 16: 4200 MHz
Graphics:  Card: NVIDIA GP104 [GeForce GTX 1080]
           Display Server: X.Org 1.19.3 driver: nvidia Resolution: 3840x2160@60.00hz
           OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 version: 4.5.0 NVIDIA 384.90
Audio:     Card-1 Intel C610/X99 series HD Audio Controller driver: snd_hda_intel Sound: ALSA v: k4.12.12-gentoo
           Card-2 NVIDIA GP104 High Definition Audio Controller driver: snd_hda_intel
Network:   Card-1: Intel Ethernet Connection (2) I218-V driver: e1000e
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Intel I211 Gigabit Network Connection
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 4096.8GB (1.0% used)
           ID-1: /dev/nvme0n1 model: Samsung_SSD_960_PRO_1TB size: 1024.2GB
           ID-2: /dev/sda model: Samsung_SSD_850 size: 1024.2GB
           ID-3: /dev/sdb model: Samsung_SSD_850 size: 2048.4GB
Partition: ID-1: / size: 639G used: 6.8G (2%) fs: ext4 dev: /dev/nvme0n1p3
           ID-2: /boot size: 511M used: 35M (7%) fs: vfat dev: /dev/nvme0n1p1
           ID-3: /home size: 1.6T used: 658M (1%) fs: ext4 dev: /dev/sdb1
           ID-4: swap-1 size: 34.36GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 36.0C mobo: N/A gpu: 38C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 259 Uptime: 4:21 Memory: 1286.7/64342.1MB Client: Shell (bash) inxi: 2.3.40

E: Waaait a minute, my user suddenly wasn't in "video" group...

That's strange, i had to manually add my user to: audio, video again. Did this when creating the user.
Might it be that perhaps, that messed things up with lightdm?

E2: adding user to video group i think did the trick. I also installed xsm just in case, and didn't emerge gtk-greeter because i have gtk in my make.conf so it pulls in the greeter automagically.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum