Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
touchpad not working
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Mon Oct 16, 2017 1:21 pm    Post subject: touchpad not working Reply with quote

Hello,
My touchpad is not working.
I have synaptics in my "INPUT_DEVICES=" in "/etc/portage/make.conf"
And also the required kernel drivers build in.
i have this in my "/etc/X11/xorg.conf.d/50-synaptics.conf"
Code:
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "VertEdgeScroll" "on"
        Option      "CircularScrolling"         "on"
        Option      "VertScrollDelta"          "-111"
        Option      "HorizScrollDelta"         "-111"
        Option      "TapButton1"                    "1"
EndSection
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1520
Location: KUUSANKOSKI, Finland

PostPosted: Mon Oct 16, 2017 8:27 pm    Post subject: Reply with quote

Not all touchpads are synaptic ones.
Does it show as a synaptic touchpad in lspci or lsusb?
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Mon Oct 16, 2017 8:42 pm    Post subject: Reply with quote

I am sure my touchpad is synaptics cause i use synaptics in my arch linux install aswell.
Its not in "lspci" and when i do "lsusb" it sais command not found. I tried with sudo and as superuser.
I also made sure i have all the synaptics stuff in my kernel.
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1520
Location: KUUSANKOSKI, Finland

PostPosted: Mon Oct 16, 2017 10:48 pm    Post subject: Reply with quote

Ok.
Have you followed the instructions on the wiki?
I assume you have, since the similiarities in configs.

sys-apps/usbutils has lsusb -command.

What if you leave out the synaptics xorg config file out? Does it make any difference?
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Tue Oct 17, 2017 8:56 am    Post subject: Reply with quote

Zucca wrote:
Ok.
Have you followed the instructions on the wiki?
I assume you have, since the similiarities in configs.

sys-apps/usbutils has lsusb -command.

What if you leave out the synaptics xorg config file out? Does it make any difference?


Yeah i followed the instructions on the wiki.
It doesnt make a difference if i leave the config file out :(
This is my output of "lsusb" i will compare it to my arch install
Code:
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 8087:0a2b Intel Corp.
Bus 001 Device 003: ID 0b05:1837 ASUSTek Computer, Inc.
Bus 001 Device 002: ID 0bda:57f6 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

This is "lspci"
Code:
00:00.0 Host bridge: Intel Corporation Device 5910 (rev 05)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 05)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 05)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #0 (rev 31)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #1 (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1c.2 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #3 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #4 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Device a171 (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GP104M [GeForce GTX 1070 Mobile] (rev a1)
03:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
05:00.0 USB controller: ASMedia Technology Inc. ASM1142 USB 3.1 Host Controller
06:00.0 Non-Volatile memory controller: Intel Corporation Device f1a5 (rev 03)


This is the synaptics config i use with arch i will try if it work with gentoo aswell.

Code:
# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
   Option "TapButton1" "1"
        Option "TapButton2" "3"
        Option "TapButton3" "2"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
#       MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"
EndSection

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
EndSection
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Tue Oct 17, 2017 8:59 am    Post subject: Reply with quote

A thing i find strange is that the synaptics config is called "70-synaptics.conf" in archlinux and "50-synaptics.conf" in gentoo.
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Tue Oct 17, 2017 9:05 am    Post subject: Reply with quote

It doesnt make a difference if i use my arch config.
I also tried renaming "50-synaptics.conf" to "70-synaptics.conf"
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Tue Oct 17, 2017 9:10 am    Post subject: Reply with quote

This is the lsusb from arch where my touchpad is working:
Code:
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 8087:0a2b Intel Corp.
Bus 001 Device 004: ID 0b05:1837 ASUSTek Computer, Inc.
Bus 001 Device 002: ID 0bda:57f6 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


And this is the lspci:
Code:
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 05)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 05)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 05)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #0 (rev 31)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #1 (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1c.2 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #3 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #4 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GP104M [GeForce GTX 1070 Mobile] (rev a1)
03:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
05:00.0 USB controller: ASMedia Technology Inc. ASM1142 USB 3.1 Host Controller
06:00.0 Non-Volatile memory controller: Intel Corporation Device f1a5 (rev 03)
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1520
Location: KUUSANKOSKI, Finland

PostPosted: Tue Oct 17, 2017 10:06 am    Post subject: Reply with quote

Interesting...

Next thing I'd try is libinput instead of evdev+synaptics.

What's your laptop model btw?
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Tue Oct 17, 2017 10:33 am    Post subject: Reply with quote

I have a asus ROG GL502VSK
I will look into libinput tommorow when i have time.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43221
Location: 56N 3W

PostPosted: Tue Oct 17, 2017 5:41 pm    Post subject: Reply with quote

philipW,

Ubuntu suggests adding
Code:
i8042.kbdreset=1
to the kernel command line.
You can read about that option in /usr/src/linux/Documentation/admin-guide/kernel-parameters.txt
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Fri Oct 20, 2017 10:01 am    Post subject: Reply with quote

I added
Code:
i8042.kbdreset=1
to the kernel commandline but it doesnt do anythin :( but i have to mention that grub is installed on arch and not gentoo i dont know if that makes a difference.
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Fri Oct 20, 2017 10:54 am    Post subject: Reply with quote

Zucca wrote:
Interesting...

Next thing I'd try is libinput instead of evdev+synaptics.

What's your laptop model btw?


i followed the wiki page for lib input but when i try to do "sudo emerge --ask --changed-use --deep @world" i get a slot error.
Code:
Total: 36 packages (1 upgrade, 21 new, 14 reinstalls), Size of downloads: 794,547 KiB

 * Error: circular dependencies:

(dev-python/sphinx-1.6.3-r2:0/0::gentoo, ebuild scheduled for merge) depends on
 (dev-python/jinja-2.9.5:0/0::gentoo, ebuild scheduled for merge) (buildtime)
  (dev-python/sphinx-1.6.3-r2:0/0::gentoo, ebuild scheduled for merge) (buildtime)

It might be possible to break this cycle
by applying the following change:
- dev-python/jinja-2.9.5 (Change USE: -doc)

Note that this change can be reverted, once the package has been installed.

Note that the dependency graph contains a lot of cycles.
Several changes might be required to resolve all cycles.
Temporarily changing some use flag for all packages might be the better option.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2l:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.1:0=[bindist=] required by (net-misc/openssh-7.5_p1-r1:0/0::gentoo, ebuild scheduled for merge)
                                ^^^^^^^^                                                                                                                     

  (dev-libs/openssl-1.0.2k:0/0::gentoo, installed) pulled in by
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by (dev-python/cryptography-2.0.2:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                 
    >=dev-libs/openssl-1.0.2g:0=[-bindist] required by (net-libs/nodejs-6.9.4:0/0::gentoo, ebuild scheduled for merge)
                                 ^^^^^^^^                                                                                                                 


It might be possible to solve this slot collision
by applying all of the following changes:
   - net-misc/openssh-7.5_p1-r1 (Change USE: -bindist)
   - dev-libs/openssl-1.0.2l (Change USE: -bindist)

Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21791
Location: here

PostPosted: Fri Oct 20, 2017 11:14 am    Post subject: Reply with quote

As portage tell you, for circular dependencies problem, remove doc use flag to dev-python/jinja package (you can re-add it if you want when update is complete).
For bindist problem remove globally (in make.conf) this use flag.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Fri Oct 20, 2017 11:37 am    Post subject: Reply with quote

fedeliallalinea wrote:
As portage tell you, for circular dependencies problem, remove doc use flag to dev-python/jinja package (you can re-add it if you want when update is complete).
For bindist problem remove globally (in make.conf) this use flag.


I already removed the bindist flag.
Here is my make.conf
Code:
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

USE="xinerama vim-syntax acl suid xattr curl ffmpeg gstreamer pdf raw X bzip doc gif jpeg mp3 nls png static-libs tiff zlib alsa pulseaudio"
CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"

MAKEOPTS="-j5"

GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"

VIDEO_CARDS="nouveau nvidia"

INPUT_DEVICES="libinput mouse keyboard synaptics"
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Fri Oct 20, 2017 11:42 am    Post subject: Reply with quote

fedeliallalinea wrote:
I don't see -bindist in your USE variable


Oke this is gonna solve allot of issues for me cause i tought removing binddist from the use flags was the same.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21791
Location: here

PostPosted: Fri Oct 20, 2017 11:42 am    Post subject: Reply with quote

Ok then run
Code:
# emerge -UD --with-bdeps y @world --autounmask=n


EDIT:
philipW wrote:
fedeliallalinea wrote:
I don't see -bindist in your USE variable


Oke this is gonna solve allot of issues for me cause i tought removing binddist from the use flags was the same.

Sorry my fault, it's correct your method, I thought it was in a profile but it's only added in make.conf
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Fri Oct 20, 2017 2:03 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Ok then run
Code:
# emerge -UD --with-bdeps y @world --autounmask=n


EDIT:
philipW wrote:
fedeliallalinea wrote:
I don't see -bindist in your USE variable


Oke this is gonna solve allot of issues for me cause i tought removing binddist from the use flags was the same.

Sorry my fault, it's correct your method, I thought it was in a profile but it's only added in make.conf


:( To bad. A sudo emerge --ask --changed-use --deep @world could solve allot of issues for me.
I guess i will just reinstall gentoo and remove the bindist as soon as i can.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7094
Location: Saint Amant, Acadiana

PostPosted: Fri Oct 20, 2017 2:19 pm    Post subject: Reply with quote

Reinstall Gentoo to change a USE flag?! 8O
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Fri Oct 20, 2017 2:23 pm    Post subject: Reply with quote

Jaglover wrote:
Reinstall Gentoo to change a USE flag?! 8O

yeah i know its retarded but everything i try to fix comes down to the same slot issue.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21791
Location: here

PostPosted: Fri Oct 20, 2017 2:35 pm    Post subject: Reply with quote

philipW wrote:
yeah i know its retarded but everything i try to fix comes down to the same slot issue.

There is a high chance that you have same problem with a reinstall, bindist is legally needed for distribute stage3.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Fri Oct 20, 2017 4:28 pm    Post subject: Reply with quote

Yeah installing is probably a bad idea.
Could you guys help me breakdown what the slot problem is actually saying and how to troubleshoot/resolve such issues cause i tried reinstalling openssl and openssh but it doesnt seem to work.
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Fri Oct 20, 2017 4:57 pm    Post subject: Reply with quote

i resolved the circular dependencies issues by adding -doc to the pakages that where causing it
this is what i get if i do sudo emerge --ask --changed-use --deep @world
i tried uninstalling openssh i also tried masking it.
Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.1.0f:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2g:0=[-bindist] required by (net-libs/nodejs-6.9.4:0/0::gentoo, ebuild scheduled for merge)
                                 ^^^^^^^^                                                                                                                 
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by (dev-python/cryptography-2.0.2:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                 

  (dev-libs/openssl-1.0.2l:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-0.9.8:0/0= required by (dev-python/m2crypto-0.24.0:0/0::gentoo, installed)
                            ^^^^^                                                                                                   
    (and 3 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following packages are causing rebuilds:

  (x11-base/xorg-server-1.19.4:0/1.19.4::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-video-nouveau-1.0.15:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-mouse-1.9.2:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-synaptics-1.9.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-libinput-0.25.1:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, ebuild scheduled for merge)

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by net-misc/openssh-7.5_p1-r1::gentoo[ssl,-static]
# required by gnome-base/gvfs-1.30.4::gentoo
# required by xfce-base/thunar-1.6.12::gentoo[trash-panel-plugin,dbus]
# required by @selected
# required by @world (argument)
>=dev-libs/openssl-1.1.0f bindist

Would you like to add these changes to your config files? [Yes/No] no
Back to top
View user's profile Send private message
philipW
n00b
n00b


Joined: 06 Apr 2017
Posts: 43
Location: Netherlands

PostPosted: Fri Oct 20, 2017 5:12 pm    Post subject: Reply with quote

i am now trying to sudo USE="-bindist" emerge --ask openssh

but i get this error:
Code:
!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/net-misc/openssh-7.5_p1-r1/work/openssh-7.5p1/config.log
 * ERROR: net-misc/openssh-7.5_p1-r1::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *               ebuild.sh, line  115:  Called src_configure
 *             environment, line 3421:  Called econf '--with-ldflags=-Wl,-O1 -Wl,--as-needed' '--disable-strip' '--with-pid-dir=/run' '--sysconfdir=/etc/ssh' '--libexecdir=/usr/lib64/misc' '--datadir=/usr/share/openssh' '--with-privsep-path=/var/empty' '--with-privsep-user=sshd' '--without-audit' '--without-kerberos5' '--without-ldns' '--without-libedit' '--with-pam' '--with-pie' '--without-sctp' '--without-selinux' '--without-skey' '--without-ssh1' '--with-openssl' '--with-md5-passwords' '--with-ssl-engine'
 *        phase-helpers.sh, line  665:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=net-misc/openssh-7.5_p1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-misc/openssh-7.5_p1-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-misc/openssh-7.5_p1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/openssh-7.5_p1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-misc/openssh-7.5_p1-r1/work/openssh-7.5p1'
 * S: '/var/tmp/portage/net-misc/openssh-7.5_p1-r1/work/openssh-7.5p1'

>>> Failed to emerge net-misc/openssh-7.5_p1-r1, Log file:

>>>  '/var/tmp/portage/net-misc/openssh-7.5_p1-r1/temp/build.log'

 * Messages for package net-misc/openssh-7.5_p1-r1:

 * ERROR: net-misc/openssh-7.5_p1-r1::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *               ebuild.sh, line  115:  Called src_configure
 *             environment, line 3421:  Called econf '--with-ldflags=-Wl,-O1 -Wl,--as-needed' '--disable-strip' '--with-pid-dir=/run' '--sysconfdir=/etc/ssh' '--libexecdir=/usr/lib64/misc' '--datadir=/usr/share/openssh' '--with-privsep-path=/var/empty' '--with-privsep-user=sshd' '--without-audit' '--without-kerberos5' '--without-ldns' '--without-libedit' '--with-pam' '--with-pie' '--without-sctp' '--without-selinux' '--without-skey' '--without-ssh1' '--with-openssl' '--with-md5-passwords' '--with-ssl-engine'
 *        phase-helpers.sh, line  665:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=net-misc/openssh-7.5_p1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-misc/openssh-7.5_p1-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-misc/openssh-7.5_p1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/openssh-7.5_p1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-misc/openssh-7.5_p1-r1/work/openssh-7.5p1'
 * S: '/var/tmp/portage/net-misc/openssh-7.5_p1-r1/work/openssh-7.5p1'

This is the /var/tmp/portage/net-misc/openssh-7.5_p1-r1/work/openssh-7.5p1/config.log

this is the output of emerge --info '=net-misc/openssh-7.5_p1-r1::gentoo'
Code:
Portage 2.3.8 (python 3.4.5-final-0, default/linux/amd64/13.0/no-multilib, gcc-5.4.0, glibc-2.23-r4, 4.12.12-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.12.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-7700HQ_CPU_@_2.80GHz-with-gentoo-2.4.1
KiB Mem:    24593560 total,  22366280 free
KiB Swap:   16777212 total,  16777212 free
Timestamp of repository gentoo: Mon, 16 Oct 2017 07:30:01 +0000
Head commit of repository gentoo: 50134d6350a5992729942dc88416dd02d74eb643
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.1-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.28::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.15-r2::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa amd64 berkdb bzip bzip2 cli cracklib crypt curl cxx doc dri ffmpeg fortran gdbm gif gstreamer iconv ipv6 jpeg modules mp3 ncurses nls nptl openmp pam pcre pdf png pulseaudio raw readline seccomp session ssl static-libs suid tcpd tiff unicode vim-syntax xattr xinerama zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 700

PostPosted: Fri Oct 20, 2017 7:05 pm    Post subject: Reply with quote

Are SYNAPTIC modules build in your kernel ?
Code:
$ zcat /proc/config.gz | grep SYNAPT
CONFIG_MOUSE_PS2_SYNAPTICS=y
CONFIG_MOUSE_PS2_SYNAPTICS_SMBUS=y
CONFIG_MOUSE_SYNAPTICS_I2C=m
CONFIG_MOUSE_SYNAPTICS_USB=m


or as module.

and if they are , are they loaded ? ( as psmouse module)
_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum