Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to select CFQ scheduler
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
lutel
Tux's lil' helper
Tux's lil' helper


Joined: 19 Oct 2003
Posts: 93
Location: Pomroczna

PostPosted: Sat Oct 28, 2017 9:55 am    Post subject: Unable to select CFQ scheduler Reply with quote

Hi,

I just noticed on 4.13.10 vanilla, that I can't switch to CFQ scheduler. Am i missing something?

delta /etc # zcat /proc/config.gz | grep CFQ
CONFIG_IOSCHED_CFQ=y
CONFIG_DEFAULT_CFQ=y

delta /etc # dmesg | grep -i sched
[ 0.656257] io scheduler noop registered
[ 0.661806] io scheduler cfq registered (default)
[ 0.661927] io scheduler mq-deadline registered

delta /etc # cat /sys/block/sda/queue/scheduler
[mq-deadline] none

Do you have any idea what could be wrong?
Back to top
View user's profile Send private message
lutel
Tux's lil' helper
Tux's lil' helper


Joined: 19 Oct 2003
Posts: 93
Location: Pomroczna

PostPosted: Sat Oct 28, 2017 10:32 am    Post subject: Reply with quote

Found it, it was the MQ for SCSI that was enabled by default.
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 550
Location: USA

PostPosted: Tue Feb 05, 2019 3:23 pm    Post subject: Reply with quote

lutel wrote:
Found it, it was the MQ for SCSI that was enabled by default.

Yes. I need to disable CONFIG_SCSCI_MQ_DEFAULT to get cfq as well:
Code:
$ zcat /proc/config.gz|grep SCSI_MQ
# CONFIG_SCSI_MQ_DEFAULT is not set
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum