Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Installation Media Problems
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 13 Oct 2017
Posts: 117
Location: Delft, Netherlands

PostPosted: Thu Nov 02, 2017 11:44 am    Post subject: [SOLVED] Installation Media Problems Reply with quote

Solution: Don't be a dumbass like me. Read the wiki, read the handbook. Read that the minimal install media can only boot from a legacy boot enabled system not UEFI....

So I have been working with Gentoo** for a while and I want to use it on my main* laptop since kali linux gave up on that thanks to a kernel update... (Stupid mistake by me). So I do what I did when I started installing gentoo on the laptop** I am typing this from.
GentooBox ~ # fdisk -l /dev/sdb
Disk /dev/sdb: 14.5 GiB, 15597568000 bytes, 30464000 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x06e78a97

Device     Boot Start    End Sectors  Size Id Type
/dev/sdb1  *        0 552959  552960  270M 17 Hidden HPFS/NTFS

and then. I have both the livecd and the minimal install so i wanted to do the minimal because the livecd froze when I ran lspci -k. or at least the terminal in the livecd crashed.

GentooBox ~ # dd if=/home/poro/Downloads/install-amd64-minimal-20170907.iso of=/dev/sdb status=progress

when the process is done however I can't boot from it and it just bails on everything altogether. Gparted says "Invalid partition table - recursive partition on /dev/sdb." when I want to have a look at the usb. And obviously trying to boot* from it returns fruitless results. So as a controll test I try it with a different OS. In my case NixOS** and this one has no errors at all and just boots*. So what is happening? Why are the liveCD's from gentoo so broken that I can't dd** them? Also when i try rufus on my windows* it returns an error of the same kind. What is going on? I have found before that I should use the rescueCD but I mean what is the point of having all these downloads available if none of them work?

*Info on my main laptop: it has a GPT partition table with EFI enabled.
**Info on my gentoo working laptop: GPT table no EFI.

So apparently I can't write** the minimalinstall media to a usb. Also what bothers me is that rufus* used to be able to write both the minimal install and the liveCD to a usb but now it doesn't. I know this because I have gotten gentoo working on this** laptop thanks to that.

Both the NixOS bootable media as the Gentoo media show a MBR partition table in the disks app.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum