Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
amdgpu dc Kernel 4.15-rc hdmi 2.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 411

PostPosted: Sat Dec 09, 2017 10:53 am    Post subject: amdgpu dc Kernel 4.15-rc hdmi 2.0 Reply with quote

Hello,
anyone got amdgpu dc in kernel 4.15-rc working with hdmi ?
I can not get beyond 3480x2160x30Hz.

My hardware:
RX460 - 4GB
iiyama G-Master GB2888UHSU


I compiled all amdgpu parts into kernel and included all the firmware parts as well as installing amdgpu driver:

Code:
CONFIG_EXTRA_FIRMWARE="amdgpu/polaris11_ce.bin amdgpu/polaris11_mc.bin amdgpu/polaris11_me.bin amdgpu/polaris11_mec2.bin amdgpu/polaris11_mec.bin amdgpu/polaris11_pfp.bin amdgpu/polaris11_rlc.bin amdgpu/polaris11_sdma1.bin amdgpu/polaris11_sdma.bin amdgpu/polaris11_smc.bin amdgpu/polaris11_smc_sk.bin amdgpu/polaris11_uvd.bin amdgpu/polaris11_vce.bin amdgpu/polaris11_pfp_2.bin amdgpu/polaris11_me_2.bin amdgpu/polaris11_ce_2.bin amdgpu/polaris11_mec_2.bin amdgpu/polaris11_mec2_2.bin"

Code:
CONFIG_DRM_AMDGPU=y
CONFIG_DRM_AMDGPU_SI=y
CONFIG_DRM_AMDGPU_CIK=y
CONFIG_DRM_AMDGPU_USERPTR=y
CONFIG_DRM_AMDGPU_GART_DEBUGFS=y


Code:
cat /etc/portage/make.conf | grep VIDEO
VIDEO_CARDS="amdgpu radeonsi radeon"

Code:
*  x11-drivers/xf86-video-amdgpu
      Latest version available: 1.4.0
      Latest version installed: 1.4.0


Displayport is wroking fine.

To rule out any cabling/hardware issue I tested windows and got 3480x2160x60Hz over hdmi as well as with xbox one x.

Anyone any idea whats going on ?


P.S. Passing amdgpu.dc=1 as kernel parameter does not help as well.
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43210
Location: 56N 3W

PostPosted: Sat Dec 09, 2017 11:38 am    Post subject: Reply with quote

drizzt,

Not all HDMI ports are created equal. It appears that you have a mix of HDMI ver 1 and HDMI ver 2 ports on the display.
Only the port ...
Quote:
16 HDMI Connector (HDMI-1 4K 60p)
is HDMI ver 2.

HDMI ver 1 maxs out at 3480x2160x30Hz.

I have the same graphics card as you but I don't have a 4k display yet.

The DisplayPort Connector will be quite happy with 3480x2160x60Hz too.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 411

PostPosted: Sat Dec 09, 2017 1:38 pm    Post subject: Reply with quote

Neddy,
I only have 1xDP, 1xHDMI and 1xDVI on my graphics card and the exact configuration (cabling, ports, etc) works fine with windows.

Code:
xrandr
Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 16384 x 16384
DisplayPort-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 621mm x 341mm
   3840x2160     60.00*+  60.00    59.94 
   1920x2160     60.00 
   2560x1440     59.95 
   2048x1152     60.00 
   1920x1200     59.88 
   1920x1080     60.00    59.94 
   1600x1200     60.00 
   1680x1050     59.95 
   1600x900      60.00 
   1280x1024     60.02 
   1440x900      60.00 
   1280x800      59.81 
   1280x720      60.00    59.94 
   1024x768      60.00 
   800x600       60.32 
   720x480       60.00    59.94 
   640x480       60.00    59.94 
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)

Is the linux driver behaving different here ? Is there a way to verify that behaviour ?
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43210
Location: 56N 3W

PostPosted: Sat Dec 09, 2017 1:52 pm    Post subject: Reply with quote

drizzt,

The graphics card end is HDMI-2. That's OK.
Your display has a mix of HDM!-1 and HDMI-2. You must choose the HDMI-2 port that end too.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 411

PostPosted: Sat Dec 09, 2017 1:56 pm    Post subject: Reply with quote

As I said

Quote:
I only have 1xDP, 1xHDMI and 1xDVI on my graphics card and the exact configuration (cabling, ports, etc) works fine with windows.


I also plugged the pc end of the hdmi cable into xbox one x and this works fine too. Only my linux box does not want to show 60Hz over hdmi :?
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43210
Location: 56N 3W

PostPosted: Sat Dec 09, 2017 2:02 pm    Post subject: Reply with quote

drizzt,

Please test all the HDMI inputs on your display.

You will need to restart X each time.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 411

PostPosted: Sat Dec 09, 2017 3:43 pm    Post subject: Reply with quote

Neddy,
here are the results:
Monitor Input HDMI1: Linux (3840x2160@30Hz), Win (3840x2160@60Hz), Xbox One X (3840x2160@60Hz)
Monitor Input HDMI2: Linux (3840x2160@30Hz), Win (3840x2160@30Hz), Xbox One X (3840x2160@30Hz)
Monitor Input HDMI3: Linux (3840x2160@30Hz), Win (3840x2160@30Hz), Xbox One X (3840x2160@30Hz)
Monitor Input DisplayPort: Linux (3840x2160@60Hz), Win (3840x2160@60Hz), Xbox One X (n/a)

Nothing changed, HDMI 2.0 still not detected/working

P.S. Workstation was shutdown before each input change. Always the same cable was used except for DP of course.
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 411

PostPosted: Sat Dec 30, 2017 9:31 am    Post subject: Reply with quote

Opened a bug request with freedesktop: https://bugs.freedesktop.org/show_bug.cgi?id=104412#c5

Let's see what happens next...
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
sand1234
n00b
n00b


Joined: 14 Jan 2018
Posts: 4

PostPosted: Wed Jan 31, 2018 2:16 am    Post subject: Reply with quote

@drizzt I have the same graphic card and could not get sound via both Display Port and HDMI with kernel 4.14.15. Does it work for you?
Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 411

PostPosted: Wed Jan 31, 2018 6:20 pm    Post subject: Reply with quote

Well,,
you need kernel-4.15(not 4.14.15 !) for audio to work with these graphic cards. I did not test it extensively but since kernel 4.15-rc1 I have a hdmi audio device showing up in my mixer.
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 531
Location: Venice FL

PostPosted: Tue Feb 06, 2018 2:20 am    Post subject: Reply with quote

Its working for me on 4.15.1-gentoo with an MSI RX480.

Also needed to add to the kernel command line: amdgpu.dc=1

Code:
#  systool -vm amdgpu | grep dc
    dc                  = "1"


Code:
$  xrandr
Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 1872mm x 1053mm
   3840x2160     60.00*+  50.00    59.94    30.00    25.00    24.00    29.97    23.98 
   4096x2160     60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98 
   1920x1200     60.00 
   1920x1080     60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98 
   1600x1200     60.00 
   1680x1050     59.88 
   1600x900      60.00 
   1280x1024     75.02    60.02 
   1440x900      59.90 
   1366x768      59.79 
   1280x800      59.91 
   1152x864      75.00 
   1280x720      60.00    50.00    59.94 
   1024x768      75.03    70.07    60.00 
   832x624       74.55 
   800x600       72.19    75.00    60.32 
   720x576       50.00 
   720x480       60.00    59.94 
   640x480       75.00    72.81    66.67    60.00    59.94 
   720x400       70.08 
HDMI-A-1 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)


George
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum