Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] modprobe not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
weiypan_us
Tux's lil' helper
Tux's lil' helper


Joined: 25 Feb 2017
Posts: 86

PostPosted: Tue Dec 12, 2017 8:14 am    Post subject: [Solved] modprobe not working Reply with quote

Hi

I found my modprobe is broken. When I use it to load in a driver , it keep on giving me error looks like following

Code:
asus mouse # pwd
/lib/modules/4.12.12-gentoo/kernel/drivers/input/mouse
asus mouse # ls -l
total 40
-rw-r--r-- 1 root root 19648 Dec 11 15:33 appletouch.ko
-rw-r--r-- 1 root root 19632 Dec 11 15:33 bcm5974.ko
asus mouse # modprobe appletouch.ko
modprobe: FATAL: Module appletouch.ko not found in directory /lib/modules/4.12.12-gentoo

appreciate very much if someone can help me.

[Moderator edit: added [code] tags to preserve output layout. -Hu]


Last edited by weiypan_us on Tue Dec 12, 2017 7:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
fturco
l33t
l33t


Joined: 08 Dec 2010
Posts: 756
Location: Italy

PostPosted: Tue Dec 12, 2017 8:51 am    Post subject: Reply with quote

Try with:
Code:
# modprobe appletouch

Instead of:
Code:
# modprobe appletouch.ko
Back to top
View user's profile Send private message
weiypan_us
Tux's lil' helper
Tux's lil' helper


Joined: 25 Feb 2017
Posts: 86

PostPosted: Tue Dec 12, 2017 7:52 pm    Post subject: Reply with quote

fturco, thank you! It works.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum