Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge: wrong dependencies in keyword/use changes report
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
nick87720z
n00b
n00b


Joined: 22 Mar 2017
Posts: 31

PostPosted: Wed Dec 13, 2017 6:45 pm    Post subject: emerge: wrong dependencies in keyword/use changes report Reply with quote

Current situation
I'm updating system in preparations for finishing world rebuild (after previous one failed, pushing me back to usual update at some point).
Code:
# emerge -tavuDN world

It asks to unmask some packages due to dependencies, what reports, is wring in all places, even different between themselves.
The example, i catched there, is with media-sound/pulseeffects::jorgicio, whose installed version is 3.0.7, now it is 3.1.1.

All currently available ebuilds from 3.0.8 to 3.1.1 depend on >=media-libs/gstreamer-1.12.0:1.0.
However, proposed changes for packages.keywords comment this by following:
Code:
# required by media-plugins/gst-plugins-ximagesrc-1.10.5::gentoo
# required by @selected
# required by @world (argument)
=media-libs/gst-plugins-good-1.12.3 ~amd64


and full list of changes, printed after "Calculating dependencies... done!", has this:
Code:
[nomerge       ] media-plugins/gst-plugins-vpx-1.10.5:1.0::gentoo  ABI_X86="32 (64) (-x32)"
[ebuild     U ~]  media-libs/gst-plugins-good-1.12.3:1.0::gentoo [1.10.5:1.0::gentoo] USE="nls orc" ABI_X86="32 (64) (-x32)" 0 KiB


As for pulseeffects:
Code:
[nomerge       ] media-sound/pulseeffects-3.1.1::gentoo [3.0.7::jorgicio] PYTHON_TARGETS="python3_4 python3_5 -python3_6"
[ebuild   R   ~]  media-plugins/gst-plugins-ladspa-1.12.3:1.0::gentoo [1.12.3:1.0::jorgicio] ABI_X86="(64) -32% (-x32)"

Code:
[nomerge       ] media-sound/pulseeffects-3.1.1::gentoo [3.0.7::jorgicio] PYTHON_TARGETS="python3_4 python3_5 -python3_6"
[ebuild     U ~]  media-plugins/gst-plugins-pulse-1.12.3:1.0::gentoo [1.10.5:1.0::gentoo] ABI_X86="32 (64) (-x32)" 3406 KiB

but i did not yet notice these lines, as i looked them just now, since now i know about pulseeffects.
I figured it out only when ran this:
Code:
$ eix -c --installed --deps gst-plugins-good

where it was clearly visible due to its [U] status.
As for media-plugins/gst-plugins-ximagesrc... it is not even in emerge list, and its current version is already installed (i suppose, this is half-state after loosing emerge resume list on initial full world rebuild).

Begining
This problem first appeared on previous stable portage version, and after last portage update still appears (i don't risk to update such a vital package to any ~* version).
This time: i already made rebuild against latest toolchain, with full rebuild. Last full rebuild, however, failed, when i had nearly 800 pending packages from ~2500 total. Since portage removes resume list on first failed resuming attempt (thus i can't even edit it in order to fix, or just rerun with some --exclude or other skip options to get working), i simply made all possible updates, it still could find...
(with emerge -tavuDN world.... many packages, pulled in by --emptytree option, of course, were omited this time),
then made revdep-rebuild -- -av (which did not find anything), then emerged @preserved-rebuild and finally solved glsa-check warnings, were possible.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum