Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] kernel - make install problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
professor1234
n00b
n00b


Joined: 27 Mar 2005
Posts: 47
Location: Kraków, Poland

PostPosted: Thu Dec 14, 2017 6:07 pm    Post subject: [Solved] kernel - make install problem Reply with quote

Hi All,

I have a problem with make install command after kernel compilation.
The kernel complies itself correctly. However when I'm trying to run "make install" command I get following error:
Code:

sh ./arch/x86/boot/install.sh 4.12.12-gentoo arch/x86/boot/bzImage \
        System.map "/boot"
run-parts: executing /etc/kernel/postinst.d/zz-runlilo 4.12.12-gentoo /boot/vmlinuz-4.12.12-gentoo
Fatal: open /boot/bzImage: No such file or directory
run-parts: /etc/kernel/postinst.d/zz-runlilo exited with return code 1
make[1]: *** [arch/x86/boot/Makefile:191: install] Error 1
make: *** [arch/x86/Makefile:290: install] Error 2


Additionally the "find" gives following feedback:
Code:

xxxxxx /usr/src/linux # find -name bzImage
./arch/i386/boot/bzImage
./arch/x86/boot/bzImage


I was playing a lot with folder /boot by deleting partition creating it again. Maybe by mistake I've removed something what was not there... The ls from /usr/src/linux is:
Code:

Dorado /usr/src/linux # ls
arch     crypto         fs       Kconfig      mm               README    System.map  vmlinux.o
block    distro         include  kernel       modules.builtin  samples   tools
certs    Documentation  init     lib          modules.order    scripts   usr
COPYING  drivers        ipc      MAINTAINERS  Module.symvers   security  virt
CREDITS  firmware       Kbuild   Makefile     net              sound     vmlinux


BTW - the make install is copying the files into /boot but this creepy message make me crazy ;)

Any feedback appreciated.


Last edited by professor1234 on Fri Dec 15, 2017 7:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
superjaded
l33t
l33t


Joined: 05 Jul 2002
Posts: 761

PostPosted: Thu Dec 14, 2017 11:29 pm    Post subject: Reply with quote

What are the contents of /etc/kernel/postinst.d/zz-runlilo ?

Judging by the output, it's looking for /boot/bzImage and failing at that point. It makes sense that it wouldn't exist since make install copies the kernel with the version info intact.

I assume you are using sys-boot/lilo rather than grub?
Back to top
View user's profile Send private message
professor1234
n00b
n00b


Joined: 27 Mar 2005
Posts: 47
Location: Kraków, Poland

PostPosted: Fri Dec 15, 2017 6:59 pm    Post subject: Reply with quote

It looks that by mistake I've removed folder boot from kernel sources...
After creating it again in /usr/src/linux and /usr/src/linux/arch the issue disappeared.

Thank you for feedback and Regards.
Back to top
View user's profile Send private message
GrimBandito
n00b
n00b


Joined: 16 Dec 2017
Posts: 3

PostPosted: Sat Dec 16, 2017 6:18 am    Post subject: Reply with quote

Did you try reinstall the kernel sources to remedy this?

Normally I would perform:-
Code:
cd /usr/src/linux
make clean

if I wanted to cleanup the contents of the kernel source directory.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum