Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
USB3 Disk drive high-speed/super-speed weirdness
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 02 Jan 2005
Posts: 142
Location: Sydney Australia

PostPosted: Sat Dec 23, 2017 3:53 am    Post subject: USB3 Disk drive high-speed/super-speed weirdness Reply with quote

Hi All,

Can anyone shed any light on what I'm seeing with my USB-3 hard disks? As a Christmas holiday project I decided to try and get a USB Video Grabber going under Linux, so I started learning a bit about USB commands using Wireshark. But I got side-tracked when I noticed that my USB3 disk drives were only running at USB2 speed. So I started investigating, and re-compiled my kernel with USB debugging messages enabled, and the EHCI, UHCI and OHCI drivers disabled:

grep -i hci /usr/src/linux/.config
# CONFIG_USB_EHCI_HCD is not set
# CONFIG_USB_OHCI_HCD is not set
# CONFIG_USB_UHCI_HCD is not set

Booted with the re-compiled kernel - and it made no difference. /var/log/messages still told me that the two Volans VL-UE25 USB disks were recognised as high-speed not super-speed. So then I thought of the USB3 memory stick that I bought recently, to load up with MP3s for the car audio. Plugged that in and, bingo!, it's recognised as super-speed. So I plugged the USB3 disk enclosure back in, and it's recognised as super-speed too - WTH???

giga ~ # lsusb
Bus 001 Device 003: ID 04ca:0020 Lite-On Technology Corp.
Bus 002 Device 004: ID 174c:1153 ASMedia Technology Inc. ASM2115 SATA 6Gb/s bridge
Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 002: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 005: ID 0781:5583 SanDisk Corp. Ultra Fit
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Then I rebooted the old kernel, and tried the same thing - and both the memory stick and disk enclosure are now recognised as super-speed!!! WTH?? I thought Linux was supposed to be deterministic (unlike Windoze).

I'd like to show you an "lsusb" with the ASMedia enclosure on the USB2 bus (Bus 001, not Bus 002), but I can't! You'd think I'd be happy that everything was now working, but I'd really like to know what was wrong, in case it happens again.

I tried the kernel re-compilation because the only relevant thing I could find with Google was a similar case where someone re-compiled with USB debug messages on, and their USB3 disks sprang into life, and stayed working when he went back to the original kernel?? So if anyone could shed some light on what I'm seeing I'd appreciate it.

My kernel may be a bit old now - but I can't find anything with Google about any bug fixes for the driver.

giga ~ # uname -a
Linux giga 4.9.6-gentoo-r1 #3 SMP Sat Feb 25 13:40:39 AEDT 2017 x86_64 Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz GenuineIntel GNU/Linux

Compliments of the season to all, Rob.
Rob Diamond
Gentoo Hack, hack, hacker
Sydney, Australia
Back to top
View user's profile Send private message

Joined: 28 Jun 2004
Posts: 228
Location: Warsaw, Poland

PostPosted: Wed Dec 27, 2017 1:52 pm    Post subject: Reply with quote

Can you post output of lspci -k here?
Back to top
View user's profile Send private message
Ant P.

Joined: 18 Apr 2009
Posts: 6353

PostPosted: Thu Dec 28, 2017 7:38 pm    Post subject: Reply with quote

Linux is usually deterministic, but your cables may not be. USB3 has extra pins, if they don't all make perfect contact then it's going to fall back to USB2 mode.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum