Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] GRUB 2.02 won't start / boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Tue Dec 26, 2017 11:45 pm    Post subject: [solved] GRUB 2.02 won't start / boot Reply with quote

I got a small problem with grub 2.02 on my Lenovo ThinkPad T520 (UEFI BIOS Version 1.46) . I install it with this command:
Code:
# grub-install --modules="linux crypto search_fs_uuid luks lvm" --recheck /dev/sda
Installing for i386-pc platform.
Installation finished. No error reported.
# grub-mkconfig -o /boot/grub/grub.conf
Generating grub configuration file ...
found linux image: /boot/kernel-genkernel-x86_64-4.14.8-gentoo-r1-gladdle
found initrd image: /boot/initramfs-genkernel-x86_64-4.14.8-gentoo-r1-gladdle
done


Here are my options in the /etc/default/grub
Code:
GRUB_PRELOAD_MODULES=lvm
GRUB_ENABLE_CRYPTODISK=y
GRUB_DEVICE=/dev/ram0
GRUB_CMDLINE_LINUX="crypt_root=/dev/sda3 real_root=/dev/mapper/sda--encrypted--gentoo-root rootfstype=ext4 dolvm"


When i start the Notebook the boot-order is:
(1) DVD Drive
(2) USB
(3) Hard Drive
But when i start, there is only a black screen, then the boot- menu from the BIOS appears. What did i wrong?
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)


Last edited by Gladdle on Sat Dec 30, 2017 11:24 am; edited 1 time in total
Back to top
View user's profile Send private message
mimosinnet
l33t
l33t


Joined: 10 Aug 2006
Posts: 663
Location: Barcelona, Spain

PostPosted: Wed Dec 27, 2017 12:38 am    Post subject: Re: GRUB 2.02 won't start / boot Reply with quote

Gladdle wrote:
But when i start, there is only a black screen, then the boot- menu from the BIOS appears. What did i wrong?


Could this be related to your UEFI Bios??
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved.
Take care of the community answering unanswered posts.
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Sat Dec 30, 2017 11:24 am    Post subject: Reply with quote

The problem was, that i have to set up "UEFI only" in the BIOS and start with the "Gentoo Hybrid DVD", then it works. Thanks.
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum