Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[musl] app-emulation/spice error: C99 compiler
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
gengreen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2017
Posts: 84

PostPosted: Mon Jan 08, 2018 4:06 am    Post subject: [musl] app-emulation/spice error: C99 compiler Reply with quote

Hello,

I'm trying to emerge app-emulation/spice

The original error is as follow :

Code:

checking for celt051 >= 0.5.1.1... no
configure: error: Package requirements (celt051 >= 0.5.1.1) were not met


I could not emerge celt-0.5.1.3, ended with this error

https://paste.pound-python.org/show/6rbtALEEKW8O2zdCLzPH/

I could however emerge celt-0.11.1-r1

The app-emulation/spice ebuild (0.13.3-r1 / 0.13.3-r2 / ~0.13.90 and **9999) RDEPEND on media-libs/celt-0.5.1.3

I edited the ebuild to get ride of it :

https://paste.pound-python.org/show/sFZktxqA1KrL340tkb9p/

I replaced the original RDEPEND with this one >=media-libs/celt-0.11.1-r1:0[static-libs(+)?]

and add to src_prepare() the following

Code:

# Change the libs flag of celt
sed -i -e 's/celt051/celt0/' configure || die "Sed failed!"
sed -i -e 's/CELT051/CELT0/' configure || die "Sed failed!"
sed -i -e 's/0.5.1.1/0.11.1-r1/' configure || die "Sed failed!"


And ended with this error

https://paste.pound-python.org/show/nA1d6aOR4CClYp0zfxrJ/

I have no idea how to pass this error... I suppose it is related to libc / musl ?

Thanks
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13739

PostPosted: Mon Jan 08, 2018 4:42 am    Post subject: Reply with quote

Those sed statements could all be done in one pass, rather than three separate rewrites. If this is an autotools package (and it probably is), it is traditional to edit the autotools input and regenerate, rather than editing the generated configure script.

For your immediate problem:
https://paste.pound-python.org/show/nA1d6aOR4CClYp0zfxrJ/:
!!! Please attach the following file when seeking support:
!!! /tmp/portage/app-emulation/spice-9999/work/spice-9999/config.log
This file will tell us how the test was performed, which may tell us why it failed. Also, since this is a live ebuild, it is possible that the package was simply broken at the moment you tried to use it. Do you need to use the live ebuild?
Back to top
View user's profile Send private message
gengreen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2017
Posts: 84

PostPosted: Mon Jan 08, 2018 4:55 am    Post subject: Reply with quote

You are right about the sed, this is a little dirty

Regarding the editing of the ebuild I have to read more since I just started to read about the building of ebuild / pkg ~2hours ago, I'm just starting

for the live ebuild, I do not have the need, I tried all the ebuild and ended with the git one

Here the last unstable log : (0.13.90)

https://paste.pound-python.org/show/h8g1V8kJ0DqFklmAZtmL/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum