Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Update python 2.7.5 to 2.7.14 causing conflict?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
kenmux
n00b
n00b


Joined: 13 Apr 2014
Posts: 59

PostPosted: Thu Jan 25, 2018 11:55 am    Post subject: Update python 2.7.5 to 2.7.14 causing conflict? Reply with quote

Hello all,

Today I finished a fresh install.

After setting the use flags, I just use:
Code:

emerge --ask -uD --newuse @world


It complains a dependency conflict as:

Code:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-lang/python:2.7

    (dev-lang/python-2.7.14-r1:2.7/2.7::gentoo, ebuild scheduled for merge) conflicts with
                >=dev-lang/python-2.7.5-r2:2.7[ssl(+)] required by (sys-apps/portage-2.3.19-r1:0/0::gentoo, installed)

                >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by (dev-python/setuptools-36.7.2:0/0::gentoo, installed)

Nothing to merge; quitting.


My python list as follows:
Code:

    [1]    python3.6
    [2]    python2.7
    [3]    python3.5


I tried to set the default python, but not worked:
Code:

eselect python set python 3.6


So, what should I do?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21779
Location: here

PostPosted: Thu Jan 25, 2018 4:58 pm    Post subject: Reply with quote

You tried with --backtrack=50?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Fri Jan 26, 2018 12:24 am    Post subject: Reply with quote

agree with what portage is telling you, or battle against it if you don't like it, but either way, fix that.
which mean USE="xml ssl" emerge -1 python:2.7
Back to top
View user's profile Send private message
kenmux
n00b
n00b


Joined: 13 Apr 2014
Posts: 59

PostPosted: Fri Jan 26, 2018 5:58 am    Post subject: Reply with quote

krinn wrote:
agree with what portage is telling you, or battle against it if you don't like it, but either way, fix that.

No. I'd NEVER want to be against it, just want it to work perfectly...

krinn wrote:
which mean USE="xml ssl" emerge -1 python:2.7

I add a file for use flags (containing "xml ssl") of python in the package.use/, emerge again, then all's okay.

By the way, what's the meaning of "emerge -1"? I tried, and it seemed okay to emerge...
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21779
Location: here

PostPosted: Fri Jan 26, 2018 6:42 am    Post subject: Reply with quote

kenmux wrote:
By the way, what's the meaning of "emerge -1"? I tried, and it seemed okay to emerge...

man emerge wrote:
--oneshot (-1)
Emerge as normal, but do not add the packages to the world file for later updating.

WARNING: This option should only be used for packages that are reachable from the @world package set (those that would not be removed by --depclean),
since dependencies of unreachable packages are allowed to be broken when satisfying dependencies of other packages. Broken dependencies of this sort
will invalidate assumptions that make it possible for --deep to be disabled by default.

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Fri Jan 26, 2018 12:15 pm    Post subject: Reply with quote

kenmux wrote:
No. I'd NEVER want to be against it, just want it to work perfectly...

I didn't say that like it would be "bad" to be against what portage is telling you, but agreeing with portage make the solve easy: you do like portage ask.
If you don't agree, in your example, say you really don't like "xml", then you will have to find who force "xml" to disable it (if it's doable).
So while there's nothing "wrong" to be against what portage say, going against it would mean a different handling as you would need to figure out USE="-xml ssl" impact on your system and see if its doable ; with mean blockers, more message... a little fight and an answer which cannot be as easy as "run that command and you'll be good to go".

And if you want the deep answer: you should look at what portage is asking, in your example you see:
Code:
>=dev-lang/python-2.7.5-r2:2.7[ssl(+)] required by (sys-apps/portage-2.3.19-r1:0/0::gentoo, installed)

Which mean :
* we want a python version higher or equal than 2.7.5-r2 in the 2.7 slot
* we need that python build with ssl
* it really must be build with ssl ; that's the + meaning behind ssl, the ssl(+) part : if portage is asking a flag it may use, it would say "ssl" but by saying "ssl(+)" it tells you, i need this flag, and i couldn't do it without it. While with "ssl" it would mean "i need it, but you may disable something on me that would allow me to live without it and stop asking for it"
* all this to make sys-apps/portage happy with the use flags it currently have set (so the ones you have set while you built it)

Which suggest: while you are not really yet able to say if it could be doable to have portage with python-2.7 build with -ssl, as ssl is force (the +), you are more close to be in a case when it's just undoable to use a python with "-ssl" set with portage. And fighting against that use flag should lead to a lost fight, so it doesn't seem worth the efforts, and anyway the answer will be hard (you have to dig out why portage must use ssl with python, could portage work without it, and if a use flag in portage enable it ; could you disable it so portage stop forcing that on python...)

It's the same for xml that is also force, which mean, the easiest answer is USE="ssl xml"...
Sorry if my short previous answer might have lead you to think it was "wrong" or "bad" to battle against an use flag, it's something legit to do, not always doable, but certainly not something "bad" to do.
Back to top
View user's profile Send private message
kenmux
n00b
n00b


Joined: 13 Apr 2014
Posts: 59

PostPosted: Mon Jan 29, 2018 2:48 am    Post subject: Reply with quote

Hello krinn,

Thanks for your great reply. I agree with you.
I thought this problem came from USE="-* ..." (no "xml" or "ssl" included) in my make.conf.

@fedeliallalinea, thanks for your answer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum