Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ext4 flashdrives not recognized
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
mjbjr
Apprentice
Apprentice


Joined: 02 Mar 2003
Posts: 240

PostPosted: Mon Feb 05, 2018 6:35 am    Post subject: ext4 flashdrives not recognized Reply with quote

I don't use flashdrives all that much, but recently...

At some point in the last couple of months my gentoo system has lost the ability
to manually mount flashdrives that I have reconfigured to use ext4. When I plug
them into a USB port they light up for a second, neither dmesg, nor /var/log/messages
has any report of them being connected, and 'ls -l /dev/sd*' doesn't show them.

ext4 flashdrives that are connected at boot are recognized and I can work with them.
If I unmount them I am unable to remount them.

Flashdrives that are fresh from the store and formatted for Windows use are
recognized without problems when plugged in.

All the harddrives on the system are ext4 and get mounted at boot without problem.
I can also unmount them and remount them without problem.

I have a hard drive in the system that has an older bootable gentoo configuration,
and when I boot to it that system sees the ext4 flashdrives when I plug them in,
and I can work with them.

I have been diff'ing the new .config against the .config on the working older system,
but I haven't noticed where I've gone wrong (presumably with the kernel config).

Any ideas?

Thank you.
.









https://forums.gentoo.org/viewtopic-t-1076152.html
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7285
Location: almost Mile High in the USA

PostPosted: Mon Feb 05, 2018 6:38 pm    Post subject: Reply with quote

USB media should still trigger a message in dmesg when plugging it in. If it does not, and other devices still do, then perhaps that media is no longer compatible with the machine you're trying to get it to work upon... otherwise something doesn't quite make sense in the description you provide or perhaps some of the observations made are no longer true today...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum