Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't install Plymouth [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
malcolmmaya
n00b
n00b


Joined: 30 Oct 2017
Posts: 39

PostPosted: Thu Feb 01, 2018 6:25 pm    Post subject: Can't install Plymouth [SOLVED] Reply with quote

Hello all,

I'm trying to get PLymouth to work with no luck. I'm following the tutorial here but everytime I reboot I have no PLymouth :(. The only thing I didn't do is the KMS for Intel cards because I cannot find :

Code:

<*>   Intel 8xx/9xx/G3x/G4x/HD Graphics
         [*]     Enable modesetting on intel by default


But I have
Code:
Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)  --->
enabled.

If I'm trying plymouth in a terminal using

Code:

# plymouthd
#plymouth --show-splash


It works....

My genkernel.conf as the lines

Code:

# Enable splashutils in early space (initrd). Default is "no".
#SPLASH="yes"

# Use this splash theme. If commented out - the "default" name theme is used.
# Also, SPLASH="yes" needs to be enabled for this one to one work.
# This supersedes the "SPLASH_THEME" option of /etc/conf.d/splash (in early space).
#SPLASH_THEME="gentoo"

# Installs, or not, plymouth into the initramfs. If "splash" will be
# passed at boot, plymouth will be activated.
PLYMOUTH="yes"

# Embeds the given plymouth theme into the initramfs.
PLYMOUTH_THEME="fade-in"


and I've run
Code:
grub-mkconfig -o /boot/grub/grub.cfg
after doing
Code:
genkernel initramfs


I don't know what I am missing here :(.

EDIT ok some more info :

I've tried adding `i915.modeset=1` as a kernel argument in `/etc/default/grub` but that did not help. When looking at the log file with `journalctl -b --no-pager | grep -i modesetting` nothing is printed which lead me to think that the KMS is not loaded anyway :(. I have an intel Graphic HD 5500...

Also
Code:

cat /sys/module/i915/parameters/modeset

return -1, so KMS module

But it returns 1 if I have `i915.modeset=1` in the kernel arguments, Still no plymouth...


SOLUTION:

OK this is silly. It had a delay of 5sec before showing the splash. I added ShowDelay=0 in /etc/plymouth/plymouth.conf and it worked... I still have `i915.modeset=1` as kernel argument mind you :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum