Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Issue with amdgpu powerplay
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
The_Document
Apprentice
Apprentice


Joined: 03 Feb 2018
Posts: 272

PostPosted: Thu Feb 08, 2018 1:16 am    Post subject: [Solved] Issue with amdgpu powerplay Reply with quote

Dmesg is spamming issues about amdgpu powerplay here is relavent portion from dmesg:
https://paste.pound-python.org/show/UVQbD1PHqR0ZgKh5N6QK/
Whole dmesg:
https://paste.pound-python.org/show/UDruu4qh2umJ6JkqwZ4r/
Kernel-config
https://paste.pound-python.org/show/O137tEncyq3h9X4oqaJu/
make.conf:
http://dpaste.com/1RZ6VPN


Last edited by The_Document on Sun Feb 11, 2018 3:09 am; edited 1 time in total
Back to top
View user's profile Send private message
PrSo
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jun 2017
Posts: 128

PostPosted: Thu Feb 08, 2018 1:25 am    Post subject: Reply with quote

Sure, but please could you tell us what is yours hardware, and see if amd people are working on the solution:
https://cgit.freedesktop.org/~agd5f/linux/log/?h=drm-next-4.17-wip&qt=grep&q=powerplay.
Back to top
View user's profile Send private message
The_Document
Apprentice
Apprentice


Joined: 03 Feb 2018
Posts: 272

PostPosted: Thu Feb 08, 2018 4:57 am    Post subject: Reply with quote

PrSo wrote:
Sure, but please could you tell us what is yours hardware, and see if amd people are working on the solution:
https://cgit.freedesktop.org/~agd5f/linux/log/?h=drm-next-4.17-wip&qt=grep&q=powerplay.


Including lspci -vv:
https://paste.pound-python.org/show/R7tIzjgjTO6OIORbrTKP/

Perhaps I need a newer kernel? I booted to ubuntus livecd and amdgpu powerplay initialized just fine but it did print min_core_set_clock not set also.
Back to top
View user's profile Send private message
PrSo
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jun 2017
Posts: 128

PostPosted: Thu Feb 08, 2018 8:50 am    Post subject: Reply with quote

The_Document wrote:

Perhaps I need a newer kernel? I booted to ubuntus livecd and amdgpu powerplay initialized just fine but it did print min_core_set_clock not set also.


Since you are using 4.9.76 (as from dmesg) I suppose so.

Not all futures are backported to earlier kernels, most of them are bugfixes.
If you cant/wont to change anything in your setup you could first try a SysRescueCD just to be sure. (I think there is 4.14 as for now).
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43178
Location: 56N 3W

PostPosted: Thu Feb 08, 2018 11:50 am    Post subject: Reply with quote

The_Document,

Try the 4.15 kernel. There is a new amdgpu driver there.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
The_Document
Apprentice
Apprentice


Joined: 03 Feb 2018
Posts: 272

PostPosted: Sun Feb 11, 2018 3:09 am    Post subject: Reply with quote

NeddySeagoon wrote:
The_Document,

Try the 4.15 kernel. There is a new amdgpu driver there.


I added gentoo-sources to package.accept_keywords rebuilt and much less spam about amdgpu powerplay, issue resolved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum