Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Intel Microcode & Luks. Is it loaded?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ayeyes
Tux's lil' helper
Tux's lil' helper


Joined: 03 Dec 2017
Posts: 104

PostPosted: Thu Feb 15, 2018 12:00 pm    Post subject: [SOLVED] Intel Microcode & Luks. Is it loaded? Reply with quote

Hi,

Using label in grub.cfg didn't work, so I I'm using crypt_root=/dev/sda2.

dmesg | grep microcode

Code:
[    1.064884] microcode: sig=0x906eb, pf=0x2, revision=0x7c
[    1.064955] microcode: Microcode Update Driver: v2.2.


grep microcode /proc/cpuinfo

Code:
microcode   : 0x7c
microcode   : 0x7c
microcode   : 0x7c
microcode   : 0x7c


Is it ok?


Last edited by ayeyes on Thu Feb 15, 2018 4:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2971
Location: Germany

PostPosted: Thu Feb 15, 2018 1:18 pm    Post subject: Reply with quote

early microcode loading should have a message at the very top, even before linux kernel reports version number information

Code:

$ dmesg | head
[    0.000000] microcode: microcode updated early to revision ...
[    0.000000] Linux version 4.15.2 ...
Back to top
View user's profile Send private message
ayeyes
Tux's lil' helper
Tux's lil' helper


Joined: 03 Dec 2017
Posts: 104

PostPosted: Thu Feb 15, 2018 1:24 pm    Post subject: Reply with quote

Thank you! So it needs 'label' in grub.cfg then I guess.
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2971
Location: Germany

PostPosted: Thu Feb 15, 2018 2:05 pm    Post subject: Reply with quote

microcode and luks and labels are mostly unrelated things, not sure why you are throwing them together

microcode has to be embedded in kernel or piggybacked into initramfs

should be explained in the wiki
Back to top
View user's profile Send private message
ayeyes
Tux's lil' helper
Tux's lil' helper


Joined: 03 Dec 2017
Posts: 104

PostPosted: Thu Feb 15, 2018 2:19 pm    Post subject: Reply with quote

I transferred my install to an unencrypted disk and booted with
Code:
root=LABEL=BTROOT
but got the same output.

I have
Code:

initrd="early_ucode.cpio ${rel_dirname}/${i}"
      break
    else
      initrd="early_ucode.cpio"
    fi

in /etc/grub.d/10_linux.

My grub.cfg

Code:
initrd  /early_ucode.cpio /initramfs-genkernel-x86_64-4.14.11-gentoo-r2


Running the 4.14.11-gentoo-r2 patched kernel.

---

Fixed it by following the Microcode Wiki for adding the /lib/firmware/intel-ucode drivers to the kernel.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum