Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gajim-omemo forces downgrade of dev-libs/protobuf
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
reedts
n00b
n00b


Joined: 16 Feb 2018
Posts: 10

PostPosted: Sun Feb 25, 2018 11:17 am    Post subject: gajim-omemo forces downgrade of dev-libs/protobuf Reply with quote

Hello fellow Gentooers,

I'm currently facing a problem when doing a world upgrade: gajim-omemo from the flow overlay forces a downgrade of dev-libs/protobuf from 3.1.0 to 2.6.1-r3. The exact command and output are:
Code:

emerge -avutDN @world                                                                                                                                                                                                                                                                                   :(

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] media-video/vlc-2.2.8-r1:0/5-8::gentoo  USE="X alsa avcodec avformat bluray dbus dvbpsi dvd encode ffmpeg fontconfig gcrypt gstreamer jpeg libnotify libsamplerate matroska mp3 mpeg mtp ncurses ogg opengl png swscale truetype twolame udev vdpau vorbis x264 xcb -a52 -aalib (-altivec) -atmo (-audioqueue) -bidi -cdda -cddb -chromaprint -dc1394 -debug (-directx) -dts -dvb (-dxva2) -faad -fdk -flac -fluidsynth -gme -gnome -gnutls -growl -httpd -ieee1394 -jack -kate -libass -libav -libcaca -libtar -libtiger -linsys -lirc -live -lua (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) -modplug -musepack (-neon) -omxil -opencv -optimisememory -opus -postproc -projectm -pulseaudio -qt5 -rdp -rtsp -run-as-root -samba -schroedinger -sdl -sdl-image -sftp -shout -sid -skins -speex -svg -taglib {-test} -theora -tremor -upnp -v4l -vaapi -vcdx -vlm -vnc -vpx -wma-fixed -x265 -xml -xv -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse"
[ebuild     U  ]  media-sound/twolame-0.3.13-r2::gentoo [0.3.13-r1::gentoo] USE="-static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[nomerge       ] net-im/gajim-0.16.9::gentoo  USE="X crypt dbus gnome-keyring libnotify networkmanager nls srv -gnome -idle -jingle -spell {-test} -xhtml -zeroconf" PYTHON_TARGETS="python2_7"
[ebuild     U ~]  dev-python/python-gnupg-0.4.1::gentoo [0.4.0::gentoo] PYTHON_TARGETS="python2_7 python3_5 -pypy -python3_4" 44 KiB
[nomerge       ] net-misc/nextcloud-client-2.3.3::gentoo  USE="sftp -doc -dolphin -nautilus -samba -shibboleth {-test}"
[ebuild     U  ]  dev-libs/qtkeychain-0.8.0:0/1::gentoo [0.7.0:0/1::gentoo] USE="gnome-keyring%*" 34 KiB
[nomerge       ] net-im/gajim-omemo-1.2.7::flow
[nomerge       ]  dev-python/python-axolotl-0.1.35::flow  PYTHON_TARGETS="python2_7"
[ebuild     UD ]   dev-libs/protobuf-2.6.1-r3:0/9::gentoo [3.1.0:0/11::gentoo] USE="python zlib -emacs -examples -java -source% -static-libs -vim-syntax (-test%)" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 (-python3_4%) (-python3_5%*)" 1,975 KiB
[nomerge       ] sys-apps/iproute2-4.14.1-r2::gentoo  USE="berkdb iptables ipv6 -atm -minimal (-selinux)"
[ebuild     U  ]  net-firewall/iptables-1.6.1-r3:0/12::gentoo [1.6.1-r2:0/12::gentoo] USE="ipv6 -conntrack -netlink -nftables -pcap -static-libs" 0 KiB
[ebuild  NS   ~] sys-kernel/gentoo-sources-4.15.5:4.15.5::gentoo [4.15.4:4.15.4::gentoo] USE="-build -experimental -symlink" 196 KiB
[ebuild     U  ] media-video/mplayer-1.3.0-r4::gentoo [1.3.0-r3::gentoo] USE="X alsa cdio dvd dvdnav enca encode iconv ipv6 jpeg libass mp3 network opengl osdmenu oss png shm truetype unicode vdpau vorbis x264 xinerama xscreensaver xv -a52 -aalib (-altivec) (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -doc -dts -dv -dvb -faac -faad -fbcon -ftp -ggi -gif -gsm -jack -joystick -ladspa -libcaca -libmpeg2 -lirc -live -lzo -mad -md5sum -mng -nas -nut -openal -pnm -pulseaudio -pvr -radio -rar -rtc -rtmp -samba -sdl (-selinux) -speex -tga -theora -toolame -tremor -twolame -v4l -vcd (-vidix) -xvid -xvmc -yuv4mpeg -zoran (-directfb%)" CPU_FLAGS_X86="mmx mmxext sse sse2 ssse3 -3dnow -3dnowext" VIDEO_CARDS="-mga (-tdfx)" 0 KiB
[ebuild     U  ]  media-libs/libdvdnav-6.0.0::gentoo [5.0.3::gentoo] USE="-static-libs" ABI_X86="(64) -32 (-x32)" 361 KiB
[ebuild     U  ]   media-libs/libdvdread-6.0.0::gentoo [5.0.3::gentoo] USE="css -static-libs" ABI_X86="(64) -32 (-x32)" 386 KiB
[nomerge       ] sci-calculators/speedcrunch-0.12.0::gentoo  USE="-doc" L10N="-ar -ca -cs -da -de -el -en-GB -en-US -es-AR -es-ES -et -eu -fi -fr -he -hu -id -it -ja -ko -lt -lv -nb -nl -pl -pt-BR -pt-PT -ro -ru -sk -sv -tr -uz -vi -zh-CN"
[ebuild     U  ]  dev-qt/qtcore-5.7.1-r4:5/5.7::gentoo [5.7.1-r3:5/5.7::gentoo] USE="-debug -icu -systemd {-test}" 0 KiB
[nomerge       ] sys-apps/pciutils-3.4.1::gentoo  USE="kmod udev zlib -dns -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ]  sys-apps/hwids-20171003::gentoo [20170328::gentoo] USE="net pci udev usb" 2,965 KiB
[nomerge       ] dev-libs/protobuf-2.6.1-r3:0/9::gentoo [3.1.0:0/11::gentoo] USE="python zlib -emacs -examples -java -source% -static-libs -vim-syntax (-test%)" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 (-python3_4%) (-python3_5%*)"
[ebuild  N     ]  dev-python/google-apputils-0.4.2-r2::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7" 80 KiB
[ebuild  N     ]   dev-python/python-gflags-3.1.1::gentoo  PYTHON_TARGETS="python2_7 (-pypy)" 52 KiB
[ebuild  N     ]   dev-python/namespace-google-1::gentoo  PYTHON_TARGETS="python2_7 python3_5 (-pypy) -python3_4 -python3_6" 0 KiB
[ebuild  N     ]   dev-python/python-dateutil-2.6.1::gentoo  PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6" 236 KiB
[nomerge       ] mail-client/claws-mail-3.15.0-r2::gentoo  USE="archive dbus gdata gnutls imap ipv6 libcanberra libindicate libnotify networkmanager nls notification pdf pgp smime xface -bogofilter -calendar -clamav -debug -doc (-gtk3) -ldap -nntp -pda -perl -python -rss -session -sieve -spam-report -spamassassin -spell -startup-notification -svg -valgrind" PYTHON_TARGETS="python2_7"
[nomerge       ]  dev-libs/libindicate-12.10.1-r2:3::gentoo  USE="gtk introspection"
[nomerge       ]   app-text/gnome-doc-utils-0.20.10-r1::gentoo  PYTHON_TARGETS="python2_7"
[ebuild     U  ]    app-text/scrollkeeper-dtd-1.0-r1:1.0::gentoo [1.0:1.0::gentoo] 0 KiB
[nomerge       ] media-video/vlc-2.2.8-r1:0/5-8::gentoo  USE="X alsa avcodec avformat bluray dbus dvbpsi dvd encode ffmpeg fontconfig gcrypt gstreamer jpeg libnotify libsamplerate matroska mp3 mpeg mtp ncurses ogg opengl png swscale truetype twolame udev vdpau vorbis x264 xcb -a52 -aalib (-altivec) -atmo (-audioqueue) -bidi -cdda -cddb -chromaprint -dc1394 -debug (-directx) -dts -dvb (-dxva2) -faad -fdk -flac -fluidsynth -gme -gnome -gnutls -growl -httpd -ieee1394 -jack -kate -libass -libav -libcaca -libtar -libtiger -linsys -lirc -live -lua (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) -modplug -musepack (-neon) -omxil -opencv -optimisememory -opus -postproc -projectm -pulseaudio -qt5 -rdp -rtsp -run-as-root -samba -schroedinger -sdl -sdl-image -sftp -shout -sid -skins -speex -svg -taglib {-test} -theora -tremor -upnp -v4l -vaapi -vcdx -vlm -vnc -vpx -wma-fixed -x265 -xml -xv -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse"
[ebuild     U  ]  media-libs/libdvbpsi-1.3.1:0/10::gentoo [1.3.0-r1:0/10::gentoo] USE="-doc -static-libs" 469 KiB
[ebuild     U  ]  media-libs/libogg-1.3.3::gentoo [1.3.2::gentoo] USE="-static-libs" ABI_X86="(64) -32 (-x32)" 408 KiB

Total: 18 packages (12 upgrades, 1 downgrade, 4 new, 1 in new slot), Size of downloads: 7,201 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/protobuf:0

  (dev-libs/protobuf-3.1.0:0/11::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-libs/protobuf-3.5.1.1 required by (dev-python/protobuf-python-3.5.1.1:0/15::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^^^


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/python-axolotl-0.1.35::flow
# required by net-im/gajim-omemo-1.2.7::flow
# required by @selected
# required by @world (argument)
=dev-libs/protobuf-2.6.1-r3 python


So as I see it, dev-python/python-axolotl is responsible for that downgrade although the ebuild clearly states:
Code:

DEPEND=">=dev-libs/protobuf-2.6[python]
      dev-python/pycrypto
      dev-python/python-axolotl-curve25519"


And I cannot find anything in the other ebuilds as well.

Maybe some of you have an idea what is causing the downgrade and how to fix it? Downgrading protobuf is not that easy for me, as I use it in various projects myself.

Thanks in advance!

reedts
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5879

PostPosted: Sun Feb 25, 2018 6:03 pm    Post subject: Reply with quote

What happens if you fix the USE flag error?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22191
Location: here

PostPosted: Mon Feb 26, 2018 6:55 am    Post subject: Reply with quote

From what I see protobuf have split in a separated package (dev-python/protobuf-python) the python bindings.
Probably you should change dev-python/python-axolotl ebuild and see if with protobuf-3 working
Code:
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=(python2_7)

inherit distutils-r1

DESCRIPTION="python implementation of axolotl encryption"
HOMEPAGE="https://github.com/tgalal/python-axolotl"
SRC_URI="https://github.com/tgalal/${PN}/archive/${PV}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

DEPEND=">=dev-libs/protobuf-3.1.0
        dev-python/protobuf-python
        dev-python/pycrypto
        dev-python/python-axolotl-curve25519"
RDEPEND="${DEPEND}"

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
reedts
n00b
n00b


Joined: 16 Feb 2018
Posts: 10

PostPosted: Mon Feb 26, 2018 1:20 pm    Post subject: Reply with quote

Ant P. wrote:
What happens if you fix the USE flag error?

Except the error message getting away, nothing changes.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5879

PostPosted: Mon Feb 26, 2018 7:07 pm    Post subject: Reply with quote

Try adding the unwanted versions of protobuf to package.mask. It should then either work or give a reason why it's trying to downgrade.
Back to top
View user's profile Send private message
reedts
n00b
n00b


Joined: 16 Feb 2018
Posts: 10

PostPosted: Tue Feb 27, 2018 10:01 am    Post subject: Reply with quote

Ant P. wrote:
Try adding the unwanted versions of protobuf to package.mask. It should then either work or give a reason why it's trying to downgrade.

I tried that. This is the output I'm getting now:

Code:

emerge -avutDU gajim-omemo

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] net-im/gajim-omemo-1.2.7::flow
[nomerge       ]  dev-python/python-axolotl-0.1.35::flow  PYTHON_TARGETS="python2_7"
[ebuild     U ~]   dev-libs/protobuf-3.3.0:0/13::gentoo [3.1.0:0/11::gentoo] USE="python zlib -emacs -examples -java -static-libs {-test} (-vim-syntax%)" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6%" 4,235 KiB
[ebuild   R    ] sys-devel/llvm-5.0.1:5::gentoo  USE="doc gold libffi ncurses -debug -libedit {-test}" ABI_X86="(64) -32 (-x32)" KERNEL="(linux%*) (-Darwin)" LLVM_TARGETS="AArch64 AMDGPU ARM BPF NVPTX (X86) -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" 0 KiB
[ebuild     U  ] www-client/links-2.14-r1:2::gentoo [2.14:2::gentoo] USE="X bzip2 ipv6 jpeg libressl ssl unicode zlib -fbcon -gpm -libevent -livecd -lzma (-suid) (-svga) -tiff (-directfb%)" 0 KiB
[nomerge       ] x11-misc/pcmanfm-1.2.5::gentoo  USE="-debug"
[nomerge       ]  x11-libs/libfm-1.2.5:0/4.5.0::gentoo  USE="automount gtk udisks -debug -doc -examples -exif -vala"
[nomerge       ]   gnome-base/gvfs-1.32.1-r1::gentoo  USE="gnome-keyring gtk http mtp nfs policykit samba udev udisks -afp -archive -bluray -cdda -elogind -fuse -gnome-online-accounts -google -gphoto2 -ios -systemd {-test} -zeroconf"
[nomerge       ]    dev-libs/libusb-1.0.21:1::gentoo  USE="udev -debug -doc -examples -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[nomerge       ]     virtual/libudev-232:0/1::gentoo  USE="-static-libs -systemd" ABI_X86="(64) -32 (-x32)"
[nomerge       ]      sys-fs/eudev-3.2.5::gentoo  USE="hwdb kmod -introspection -rule-generator (-selinux) -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ]       sys-apps/hwids-20171003::gentoo [20170328::gentoo] USE="net pci udev usb" 2,965 KiB
[ebuild     U  ] dev-python/protobuf-python-3.5.1.1:0/15::gentoo [3.1.0:0/11::gentoo] PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6%" 4,478 KiB
[ebuild     U  ]  dev-libs/protobuf-3.5.1.1:0/15::gentoo [3.1.0:0/11::gentoo] USE="zlib -emacs -examples -static-libs {-test} (-java%) (-python%*) (-vim-syntax%)" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="(-python2_7%*) (-python3_4%) (-python3_5%*)" 0 KiB
[ebuild  N     ]  dev-python/namespace-google-1::gentoo  PYTHON_TARGETS="python2_7 python3_5 (-pypy) -python3_4 -python3_6" 0 KiB

Total: 7 packages (5 upgrades, 1 new, 1 reinstall), Size of downloads: 11,677 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/protobuf:0

  (dev-libs/protobuf-3.3.0:0/13::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/protobuf-2.6[python] required by (dev-python/python-axolotl-0.1.35:0/0::flow, installed)
                            ^^^^^^                                                                                                         

  (dev-libs/protobuf-3.5.1.1:0/15::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-libs/protobuf-3.5.1.1 required by (dev-python/protobuf-python-3.5.1.1:0/15::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^^^                                                                                                                                                 


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-python/python-axolotl-0.1.35::flow
# required by net-im/gajim-omemo-1.2.7::flow
# required by @selected
# required by @world (argument)
=dev-libs/protobuf-3.3.0 ~amd64


What I understand from it is, that as it now wants me to unmask protobuf-3.3.0 which is the last protobuf release that provides the USE flag "python" which is requested by dev-python/python-axolotl. I dont't understand however why it won't keep protobuf-3.1.0 (which I have currently installed) as it also brings the "python" USE flag and is not masked. I still see no reason to up-/downgrade from the perspective of gajim-omemo...
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22191
Location: here

PostPosted: Tue Feb 27, 2018 10:40 am    Post subject: Reply with quote

Why not changing dependencies ebuild for dev-python/python-axolotl package?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
reedts
n00b
n00b


Joined: 16 Feb 2018
Posts: 10

PostPosted: Tue Feb 27, 2018 11:23 am    Post subject: Reply with quote

fedeliallalinea wrote:
Why not changing dependencies ebuild for dev-python/python-axolotl package?

Sorry, I forgot to respond to your answer.

I'm in contact with the maintainer of the flow overlay that provides the packages gajim-omemo, python-axolotl, etc. While your suggestion worked (basically removing the "python" USE flag from the protobuf package and adding dev-python/protobuf), we are also interested in why the downgrade happens here. Because the behaviour I would expect is, that the python-axolotl package keeps protobuf-3.1.0 as it is the last version that is not masked and provides the "python" USE flag. I think that is still an open question that should be dealt with, before a change in the overlay becomes effective.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22191
Location: here

PostPosted: Tue Feb 27, 2018 1:07 pm    Post subject: Reply with quote

reedts wrote:
we are also interested in why the downgrade happens here.

I don't know but in my system this does not happen
Code:
$ emerge -1 python-axolotl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-python/pycrypto-2.6.1-r2::gentoo  USE="gmp -doc {-test}" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 436 KiB
[ebuild  N     ] dev-python/namespace-google-1::gentoo  PYTHON_TARGETS="python2_7 python3_5 (-pypy) -python3_4 -python3_6" 0 KiB
[ebuild  N     ] dev-python/protobuf-python-3.5.1.1:0/15::gentoo  PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 0 KiB
[ebuild     UD ] dev-libs/protobuf-3.1.0:0/11::gentoo [3.5.1.1:0/15::gentoo] USE="python%* zlib -emacs -examples -java% -static-libs {-test} -vim-syntax%" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7%* python3_5%* -python3_4%" 0 KiB
[ebuild  N    ~] dev-python/python-axolotl-0.1.35::my_overlay  PYTHON_TARGETS="python2_7" 0 KiB

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
reedts
n00b
n00b


Joined: 16 Feb 2018
Posts: 10

PostPosted: Tue Feb 27, 2018 1:20 pm    Post subject: Reply with quote

fedeliallalinea wrote:
reedts wrote:
we are also interested in why the downgrade happens here.

I don't know but in my system this does not happen
Code:
$ emerge -1 python-axolotl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-python/pycrypto-2.6.1-r2::gentoo  USE="gmp -doc {-test}" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 436 KiB
[ebuild  N     ] dev-python/namespace-google-1::gentoo  PYTHON_TARGETS="python2_7 python3_5 (-pypy) -python3_4 -python3_6" 0 KiB
[ebuild  N     ] dev-python/protobuf-python-3.5.1.1:0/15::gentoo  PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 0 KiB
[ebuild     UD ] dev-libs/protobuf-3.1.0:0/11::gentoo [3.5.1.1:0/15::gentoo] USE="python%* zlib -emacs -examples -java% -static-libs {-test} -vim-syntax%" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7%* python3_5%* -python3_4%" 0 KiB
[ebuild  N    ~] dev-python/python-axolotl-0.1.35::my_overlay  PYTHON_TARGETS="python2_7" 0 KiB

Hmm. Could using Gentoo Hardened be the cause?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22191
Location: here

PostPosted: Tue Feb 27, 2018 1:54 pm    Post subject: Reply with quote

reedts wrote:
Hmm. Could using Gentoo Hardened be the cause?

I doubt, try to force also dev-python/protobuf-python to 3.1.0 version
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
reedts
n00b
n00b


Joined: 16 Feb 2018
Posts: 10

PostPosted: Tue Feb 27, 2018 3:34 pm    Post subject: Reply with quote

fedeliallalinea wrote:
I doubt, try to force also dev-python/protobuf-python to 3.1.0 version

Masking later dev-python/protobuf-python versions (so forcing emerge to use dev-libs/protobuf-3.1.0 and dev-python/protobuf-python-3.1.0) generates the following output:
Code:

emerge -avutDU gajim-omemo                           

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] sys-devel/llvm-5.0.1:5::gentoo  USE="doc gold libffi ncurses -debug -libedit {-test}" ABI_X86="(64) -32 (-x32)" KERNEL="(linux%*) (-Darwin)" LLVM_TARGETS="AArch64 AMDGPU ARM BPF NVPTX (X86) -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" 0 KiB
[ebuild     U  ] www-client/links-2.14-r1:2::gentoo [2.14:2::gentoo] USE="X bzip2 ipv6 jpeg libressl ssl unicode zlib -fbcon -gpm -libevent -livecd -lzma (-suid) (-svga) -tiff (-directfb%)" 0 KiB
[nomerge       ] x11-base/xorg-server-1.19.5:0/1.19.5::gentoo  USE="glamor ipv6 libressl suid udev wayland xorg -debug -dmx -doc -kdrive -minimal (-selinux) -static-libs -systemd -tslib -unwind -xcsecurity -xephyr -xnest -xvfb"
[nomerge       ]  x11-libs/libpciaccess-0.13.4::gentoo  USE="zlib -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ]   sys-apps/hwids-20171003::gentoo [20170328::gentoo] USE="net pci udev usb" 2,965 KiB

Total: 3 packages (2 upgrades, 1 reinstall), Size of downloads: 2,965 KiB


So gajim-omemo and all it's dependencies disappeared from the merges.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum