Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
failed to mount /boot - Required root=/dev/$ROOT
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
jonathonp
n00b
n00b


Joined: 28 Feb 2018
Posts: 8

PostPosted: Wed Feb 28, 2018 11:30 am    Post subject: failed to mount /boot - Required root=/dev/$ROOT Reply with quote

I have been unable to identify the problem so far.

My fstab is ok, /boot partition is /dev/sda1 and / is /dev/sda3

Both were mounted during initial installation.

Code:
genkernel all
gave the following error:

Code:
* Kernel compiled successfully!
*
* Required Kernel Parameters:
*     root=/dev/$ROOT
*
*     Where $ROOT is the device node for your root partition as the
*     one specified in /etc/fstab
*
* If you require Genkernel's hardware detection features; you MUST
* tell your bootloader to use the provided INITRAMFS file.

* WARNING... WARNING... WARNING...
* Additional kernel cmdline arguments that *may* be required to boot properly...
* With support for several ext* filesystems available, it may be needed to
* add "rootfstype=ext3" or "rootfstype=ext4" to the list of boot parameters.grub-mkconfigroot


Grub boot error at boot:
Code:

failed to mount /boot
See systemctl status boot.mount for details


Code:
systemctl status boot.mount
boot.mount - /boot
loaded: (Result: exit-code) since ...
Where: /boot
What: /dev/sda1
Docs: man: fstab(5)
           man: systemd-fstab-generator(8)
Process: 2876 ExecMount=/bin/mount /dev/sda1 /boot -t ext4 -o default,noatime>

Mounting /boot
boot.mount: Mount process exited, code=ex>
boot.mount: Failed with result 'exit-code>
Failed to mount /boot


I ended up booting the Gentoo installation media and mounted /boot and /.

Code:
genkernel all
gave the same error as above.

I added
Code:
rootfstype=ext4
to
Code:
 vim /etc/default/grub
and updated grub
Code:
grub-mkconfig -o /boot/grub/grub.cfg
.

Any help would be appreciated.
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 814

PostPosted: Thu Mar 01, 2018 11:45 am    Post subject: Reply with quote

when you boot and the grub-menu is shown, edit the boot-commandline (i think by pressing "e" oder F10). Then check the parameter after "root" - it should be your root-device e.g. /dev/sda3.
try until you find the right one, then change grub.cfg accordingly.
GOOD LUCK!
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 141

PostPosted: Thu Mar 01, 2018 1:26 pm    Post subject: Reply with quote

For my understanding you need to do what the error-message says, add the root parameter to the kernel parameters.
I would try this:

Add to /etc/default/grub:
Code:

GRUB_CMDLINE_LINUX_DEFAULT='root=/dev/sda3'


Even better would be you add the parameter as UUID. Use 'blkid' to find the UUID for /dev/sda3. Then add this to /etc/default/grub:
Code:

GRUB_CMDLINE_LINUX_DEFAULT='root=UUID=xxxxxxxxxxx-xxxxxxx-xxxxx'


At last update grub.cfg with
Code:

grub-mkconfig -o /boot/grub/grub.cfg
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum