Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
QCA9377 not coming up with ath10k
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
vikas.vijayan
n00b
n00b


Joined: 28 Feb 2018
Posts: 1

PostPosted: Wed Feb 28, 2018 1:50 pm    Post subject: QCA9377 not coming up with ath10k Reply with quote

Device Model : Linksys WUSB6100M |
Kernel : 4.14.0-rc5-wt-ath+, 4.2 |
Backports version : 4.14-rc4, 4.14-rc5
[/b]

Kernel Source : https://github.com/erstrom/linux-ath

Am trying to bringup the above specified USB card with ath10k driver. After reading the FW files am getting the following logs.

Code:
[ 6218.904243] usb 2-1.4: new high-speed USB device number 14 using ehci-pci
[ 6219.014440] usb 2-1.4: New USB device found, idVendor=13b1, idProduct=0042
[ 6219.014446] usb 2-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 6219.014450] usb 2-1.4: Product: USBWLAN
[ 6219.014454] usb 2-1.4: Manufacturer: Qualcomm Atheros
[ 6219.014457] usb 2-1.4: SerialNumber: 12345678
[ 6219.015314] usb 2-1.4: WARNING: ath10k USB support is incomplete, don't expect anything to work!
[ 6219.015672] usb 2-1.4: Direct firmware load for ath10k/pre-cal-usb-2-1.4.bin failed with error -2
[ 6219.015695] usb 2-1.4: Direct firmware load for ath10k/cal-usb-2-1.4.bin failed with error -2
[ 6219.016134] usb 2-1.4: qca9377 hw1.1 target 0x05020001 chip_id 0x00000000 sub 0000:0000
[ 6219.016138] usb 2-1.4: kconfig debug 1 debugfs 1 tracing 0 dfs 0 testmode 0
[ 6219.017441] usb 2-1.4: firmware ver WLAN.TF.1.0-00002-QCATFSWPZ-5 api 6 features ignore-otp crc32 c3e0d04f
[ 6219.055734] usb 2-1.4: board_file api 1 bmi_id N/A crc32 544289f7
[ 6221.308242] usb 2-1.4: Service connect timeout
[ 6221.308252] usb 2-1.4: Invalid resp message ID 0x1
[ 6221.308257] usb 2-1.4: failed to connect htt (-71)
[ 6221.412265] usb 2-1.4: could not init core (-71)
[ 6221.412358] usb 2-1.4: could not probe fw (-71)

If anyone experienced and fixed this issue please share the details.

Else if anyone aware of the driver and kernel version please suggest that.

Thanks ,
Vikas

Mod edit: [code] tags added for clarity. — JRG
Back to top
View user's profile Send private message
bec
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 218
Location: Cali - Colombia

PostPosted: Tue Mar 27, 2018 2:35 pm    Post subject: Reply with quote

Vikas,

I have the following in my box /usr/src/linux/.config :

CONFIG_EXTRA_FIRMWARE="i915/bxt_dmc_ver1_07.bin ath10k/QCA9377/hw1.0/firmware-5.bin ath10k/QCA9377/hw1.0/board.bin "

With the linux-firmware package installed.

And I am using the internal ath10k ethernet card, I don't think it us connected through USB though
_________________
abe
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7328
Location: Saint Amant, Acadiana

PostPosted: Tue Mar 27, 2018 2:49 pm    Post subject: Reply with quote

First, the driver for 13b1:0042 was added to vanilla kernel https://cateee.net/lkddb/web-lkddb/ATH10K_USB.html
Second, error -2 you are getting means "not found".
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum