Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo LiveDVD hanging on hwsetup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Hironatashima
Apprentice
Apprentice


Joined: 28 Apr 2005
Posts: 212

PostPosted: Wed Feb 28, 2018 2:52 pm    Post subject: Gentoo LiveDVD hanging on hwsetup Reply with quote

Forgive me if this topic has been covered. I've not quite found anything quite like this issue yet. It's been a VERY long time since I've worked in a Gentoo or other Linux environment in any capacity.

So long story short, working on getting Linux+ certified, and decided to run a LiveDVD environment on my MSI MS-1795 laptop. it's a Core i7 so I dl'd the amd64 LiveDVD format. burned it to DVD for now, though I intend to push it over to a USB drive later.

The issue comes in when I boot the liveDVD. it starts decompiling and running it's checks, but as soon as it gets to hwsetup, it simply hangs.

a few theories, really only one: Did I try to run the wrong build on my laptop? I was pretty sure the arch-type that I needed was amd64.

or is there possibly something wrong? Some research that i did says try to boot with nodetect option, however, being rusty, I really don't remember how to make that happen.

Thanks in advance.
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5004
Location: Dark side of the mood

PostPosted: Tue Apr 03, 2018 3:49 pm    Post subject: Reply with quote

I might be as rusty as you are, running Gentoo Live with options other than the defaults... You might want to try boot options nolapic or noapic. as far as I remember hardware detection issues in the good ol' days would be fixed with those options.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
bammbamm808
Guru
Guru


Joined: 08 Dec 2002
Posts: 487
Location: Hawaii

PostPosted: Tue Apr 03, 2018 3:57 pm    Post subject: Reply with quote

Nvidia gpu? Try passing "nomodeset" to the kernel before booting.
_________________
Asrock X470 Taichi
Ryzen 2700x
32Gb Samsung B-die (16GB dual rank x2) DDR4
Geforce GTX 1060 6GB
Samsung Evo 840 500Gb +Seagate 1TB HDD
Etc....
Back to top
View user's profile Send private message
djentoo
n00b
n00b


Joined: 17 Oct 2017
Posts: 37

PostPosted: Thu Apr 05, 2018 9:44 pm    Post subject: Reply with quote

Stupid question: Did you ensure that the Secureboot and UEFI stuff in BIOS is set accordingly for a Linux install?

What boot image are you using? Try using SystemRescueCD. I tried the minimal install and liveDVD and had problems with both on separate machines. I just installed Gentoo on an i7 laptop today. AMD64 is the correct version.
Back to top
View user's profile Send private message
Hironatashima
Apprentice
Apprentice


Joined: 28 Apr 2005
Posts: 212

PostPosted: Sat Apr 07, 2018 2:59 pm    Post subject: Reply with quote

Give me some time, I'll take a look at that later, I've been moving lately, so it's taken a back seat.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum