Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problems with CPU overclocking
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
berardel
n00b
n00b


Joined: 03 Mar 2018
Posts: 34
Location: United States

PostPosted: Sat Mar 03, 2018 12:21 am    Post subject: problems with CPU overclocking Reply with quote

so i have an i7 7700k processor and the default clock speed is 4.2 GHz, however in BIOS settings i have it overclocked to 4.5.
on gentoo every place i check says that my processor clock speed is 4.2 GHz even though it should be at 4.5. on other distros such as debian it works just fine however.
does someone know what i can do to fix this issue?
Back to top
View user's profile Send private message
steve_v
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2004
Posts: 146
Location: New Zealand

PostPosted: Sat Mar 03, 2018 6:59 am    Post subject: Reply with quote

FWIW, I had to recompile the kernel with the intel p-state driver enabled to get turbo working here.
Back to top
View user's profile Send private message
kajzer
Guru
Guru


Joined: 27 Nov 2014
Posts: 489

PostPosted: Sat Mar 03, 2018 11:07 am    Post subject: Re: problems with CPU overclocking Reply with quote

berardel wrote:
so i have an i7 7700k processor and the default clock speed is 4.2 GHz, however in BIOS settings i have it overclocked to 4.5.
on gentoo every place i check says that my processor clock speed is 4.2 GHz even though it should be at 4.5. on other distros such as debian it works just fine however.
does someone know what i can do to fix this issue?


In my case only this gave me the correct speed :

Code:
dmidecode --type Processor


maybe there are some other ways but I'm not aware of them.
Back to top
View user's profile Send private message
berardel
n00b
n00b


Joined: 03 Mar 2018
Posts: 34
Location: United States

PostPosted: Sat Mar 03, 2018 11:11 pm    Post subject: Reply with quote

steve_v wrote:
FWIW, I had to recompile the kernel with the intel p-state driver enabled to get turbo working here.

could you tell me where the option to enable this in the kernel config is please?
Back to top
View user's profile Send private message
steve_v
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2004
Posts: 146
Location: New Zealand

PostPosted: Sun Mar 04, 2018 12:31 am    Post subject: Reply with quote

berardel wrote:
could you tell me where the option to enable this in the kernel config is please?

Code:
  │ Symbol: X86_INTEL_PSTATE [=y]                                                                                                                                    │ 
  │ Type  : boolean                                                                                                                                                  │ 
  │ Prompt: Intel P state control                                                                                                                                    │ 
  │   Location:                                                                                                                                                      │ 
  │     -> Power management and ACPI options                                                                                                                         │ 
  │       -> CPU Frequency scaling                                                                                                                                   │ 
  │ (1)     -> CPU Frequency scaling (CPU_FREQ [=y])                                                                                                                 │ 
  │   Defined at drivers/cpufreq/Kconfig.x86:5                                                                                                                       │ 
  │   Depends on: CPU_FREQ [=y] && X86 [=y]                                                                                                                          │ 
  │   Selects: ACPI_PROCESSOR [=y]

You can use "/" in menuconfig to search for such things.
Back to top
View user's profile Send private message
berardel
n00b
n00b


Joined: 03 Mar 2018
Posts: 34
Location: United States

PostPosted: Sun Mar 25, 2018 4:39 am    Post subject: Reply with quote

ok i fixed it
in this image, i had to turn off the first highlighted option and turn on the second highlighted option
https://i.imgur.com/JPqhohZ.png
i have a i7 7700k by the way
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum