Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
trouble compiling kernel on new install (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
djdunn
l33t
l33t


Joined: 26 Dec 2004
Posts: 780
Location: Arrakis

PostPosted: Sun Mar 04, 2018 5:43 am    Post subject: trouble compiling kernel on new install (solved) Reply with quote

this one has me stuck... so here i am.
i installed amd64 as handbook says, then i upgraded everything to ~amd64, then i switched gcc to 6.4, then i try to compile a kernel and i get this
Code:
scripts/kconfig/conf  --silentoldconfig Kconfig
  CHK     include/config/kernel.release
Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong available but compiler is broken
make: *** [Makefile:1102: prepare-compiler-check] Error 1
make: *** Waiting for unfinished jobs....

_________________
A process cannot be understood by stopping it. Understanding must move with the flow of the process, must join it and flow with it.

-The First Law of Mentat


Last edited by djdunn on Mon Mar 05, 2018 12:51 am; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Sun Mar 04, 2018 2:47 pm    Post subject: Reply with quote

Can you compile anything else? Does emerge still work?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22199
Location: here

PostPosted: Sun Mar 04, 2018 2:58 pm    Post subject: Reply with quote

You can post gcc-config -l and emerge -pvq gcc of gcc current enabled
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7554
Location: Goose Creek SC

PostPosted: Sun Mar 04, 2018 3:17 pm    Post subject: Reply with quote

audiodef asks great question.

https://packages.gentoo.org/packages/sys-devel/gcc suggests gcc-6.4.0 is no longer in the testing branch and that gcc-4.5.4 is listed as the most recent stable. I am on gcc-7.3.0 which compiles stackprotector_strong with no problem. Warning: when I went to 7.3.0 from 7.2.0-r1 I had manually make some symlinks which should have been made during the ebuild install.

Did you closely follow:
https://wiki.gentoo.org/wiki/Upgrading_from_gcc-4.x_to_gcc-5.x
and/or
https://wiki.gentoo.org/wiki/Upgrading_GCC/en
during the gcc upgrade?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
djdunn
l33t
l33t


Joined: 26 Dec 2004
Posts: 780
Location: Arrakis

PostPosted: Mon Mar 05, 2018 12:50 am    Post subject: Reply with quote

thanks for the answers guys, turned out being a corrupted Makefile in my sourcecode.
_________________
A process cannot be understood by stopping it. Understanding must move with the flow of the process, must join it and flow with it.

-The First Law of Mentat
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum