Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
new install; boot hangs at "mounting /dev/shm"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
pigeoncapo
n00b
n00b


Joined: 03 Mar 2018
Posts: 3
Location: Hempstead, New York, USA

PostPosted: Sun Mar 04, 2018 3:22 pm    Post subject: new install; boot hangs at "mounting /dev/shm" Reply with quote

Hi. I just finished my first install of Gentoo, and the boot seems to go fine until it suddenly hangs at mounting /dev/shm. I'd appreciate help, thanks. -John
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7090
Location: Saint Amant, Acadiana

PostPosted: Sun Mar 04, 2018 3:31 pm    Post subject: Reply with quote

What profile are you using, how did you build your kernel.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
pigeoncapo
n00b
n00b


Joined: 03 Mar 2018
Posts: 3
Location: Hempstead, New York, USA

PostPosted: Sun Mar 04, 2018 3:36 pm    Post subject: Reply with quote

Jaglover wrote:
What profile are you using, how did you build your kernel.


profile: default/linux/amd64/17.0

I used genkernel.

Is /dev/shm supposed to be explicitly specified in /etc/fstab? If so, how should it be formatted?
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7090
Location: Saint Amant, Acadiana

PostPosted: Sun Mar 04, 2018 11:25 pm    Post subject: Reply with quote

No need to put it in fstab. I really do not know what is stopping your boot. Never happened to me. But I never used genkernel, either. Perhaps you could get a boot log, enable it in rc.conf.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Proctologist
n00b
n00b


Joined: 11 Mar 2006
Posts: 10

PostPosted: Mon Mar 05, 2018 11:17 am    Post subject: Reply with quote

did you use gentoo minimal boot image or ubuntu (or something like it) to install gentoo? iirc they setup /dev/shm differently and that can lead to errors if not addressed.

https://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Base#Mounting_the_necessary_filesystems
Back to top
View user's profile Send private message
pigeoncapo
n00b
n00b


Joined: 03 Mar 2018
Posts: 3
Location: Hempstead, New York, USA

PostPosted: Mon Mar 05, 2018 3:24 pm    Post subject: Reply with quote

Proctologist wrote:
did you use gentoo minimal boot image or ubuntu (or something like it) to install gentoo? iirc they setup /dev/shm differently and that can lead to errors if not addressed.

https://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Base#Mounting_the_necessary_filesystems


I used SystemRescueCD. But I bit the bullet and installed using a manual kernel menuconfig and that seemed to do the trick...now to get my wifi working...

Thanks for your replies. - John
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum