Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bootctl install failed (macbook 5.2) [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
psicopompo
n00b
n00b


Joined: 11 Mar 2018
Posts: 4

PostPosted: Sun Mar 11, 2018 4:06 pm    Post subject: Bootctl install failed (macbook 5.2) [Solved] Reply with quote

Hello, i had a little trouble finishing the installation of gentoo in the macbook (old 2009 5.2 version with core2duo). I follow the amd64 handbooks without troubles until the last step, set the bootloader. I'm migrated from arch linux to gentoo, in my past arch linux installation i found that you can install systemd easily along with the native bootloader from mac (how is said in these article). But in gentoo, i always have the same error with command bootctl:

Code:
livecd / # bootctl --path=/boot/ install
Failed to open "/usr/lib/systemd/boot/efi": No such file or directory


I looked manually for the dir, but is not exist (as the message said).
I tried to bypass the error:

  • Reinstall systemd
  • Change the profile to systemd (note: in the beginning i created an hybrid profile to mix /desktop + /systemd)
  • Wipe everything an start again two times.


I really don't know what could be wrong. Looking in internet i found these message from debian group, but still not idea why in gentoo is missing the file.

Please, help me (yes i begin to be really desperate).


Last edited by psicopompo on Tue Mar 13, 2018 9:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
psicopompo
n00b
n00b


Joined: 11 Mar 2018
Posts: 4

PostPosted: Tue Mar 13, 2018 9:09 am    Post subject: Me again Reply with quote

Okey, after two days trying to solve the problem, i came out with an idea. I told myself "a package amd64 is a package fro amd64 in any distribution" so i copied the files from a arch linux cd and put in the route /usr/lib/systemd/boot/efi... Yes it work, but now i encounter a different error: the systemd doesn't found the vmlinuz an the initrd.

I don't know why this happen, but i do not investigate the error yet.
Back to top
View user's profile Send private message
psicopompo
n00b
n00b


Joined: 11 Mar 2018
Posts: 4

PostPosted: Tue Mar 13, 2018 7:50 pm    Post subject: Me again v2 Reply with quote

Okey, i don't know why, but BOOTX64.efi or systemd-bootx64.efi fail every time. I installed efibootmgr and check the entries in the EFIvars, i found three "arch god system" and one "linux boot system", i wipe everyone and create one by:

Code:
# efibootmgr -c -d /dev/sda1


And problem solved, Gentoo install finished.

I know that I'm gonna sound stupid but I'm really proud of get the solution.
Back to top
View user's profile Send private message
HungGarTiger
Apprentice
Apprentice


Joined: 04 Feb 2014
Posts: 155
Location: /nz/auckland

PostPosted: Tue Mar 13, 2018 9:06 pm    Post subject: Re: Me again v2 Reply with quote

psicopompo wrote:
Okey, i don't know why, but BOOTX64.efi or systemd-bootx64.efi fail every time. I installed efibootmgr and check the entries in the EFIvars, i found three "arch god system" and one "linux boot system", i wipe everyone and create one by:

Code:
# efibootmgr -c -d /dev/sda1


And problem solved, Gentoo install finished.

I know that I'm gonna sound stupid but I'm really proud of get the solution.


Good on ya for solving the problem. Please remember to mark the thread as [Solved], this can be done by editing the subject in your original post.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum