Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SOLVEDNo internet after configuring kernel through genkernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
micaldas
n00b
n00b


Joined: 12 Mar 2018
Posts: 37

PostPosted: Mon Mar 26, 2018 9:43 pm    Post subject: SOLVEDNo internet after configuring kernel through genkernel Reply with quote

Hi,
I am installing gentoo amd64 no multilib in a Virtualbox vm.
I just finished configuring the kernel with Genkernel, as it is explained in the handbook.
When I tried to install firmware through the given command in the book: emerge --ask sys-kernel/linux-firmware; I got the following error message:

Resolving distfiles.gentoo ... failed: Temporary failure in name resolution
unable to resolve host address "distfiles.gentoo.org"

I pinged 8.8.8.8 and it was ok, I then pinged google.com and got : "Temporary failure in name resolution".

The contents of /etc/reslv.conf is:

domain lan
nameserver 192.168.1.254

What may be the problem?

Thanks for all the help


Last edited by micaldas on Wed Mar 28, 2018 8:48 am; edited 1 time in total
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7079

PostPosted: Tue Mar 27, 2018 1:06 am    Post subject: Reply with quote

the nameserver is the dns IP to contact to get resolution of a name.
so the logical answer to your question: your nameserver 192.168.1.254 is not providing dns.

just change it with some known working dns to test
nameserver=8.8.8.8 (google dns, also in 4.4.4.4)
nameserver=208.69.38.205 (opendns)

Before you ask, i'm pretty sure it's your router IP, as many router end up .254 or .1, well, no idea, but your router doesn't provide them (dns disable or wrongly set in the router?)
Back to top
View user's profile Send private message
micaldas
n00b
n00b


Joined: 12 Mar 2018
Posts: 37

PostPosted: Tue Mar 27, 2018 8:46 am    Post subject: Reply with quote

Hi Krinn

I tried what you said, changing to the google dns', but got the same results.
I am using a vpn, Expressvpn, who says that "ExpressVPN runs its own DNS on every VPN server." Can this be linked to my problem?

Thanks for the help.
Back to top
View user's profile Send private message
micaldas
n00b
n00b


Joined: 12 Mar 2018
Posts: 37

PostPosted: Wed Mar 28, 2018 8:47 am    Post subject: Reply with quote

In the end I just reinstalled gentoo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum