Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing Gentoo on Dell Precision 5820
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
RunGentooRun
n00b
n00b


Joined: 11 Apr 2018
Posts: 2

PostPosted: Wed Apr 11, 2018 9:15 am    Post subject: Installing Gentoo on Dell Precision 5820 Reply with quote

Hi,

I am desperately trying to install Gentoo on my Dell machine. After properly configuring the kernel most things (nvme, power management) seem to work now -- unfortunately not all.
Basically there are two issues:

1. I have to use the nvidia proprietary drivers. But when I use them and try to "systemctl start sddm" or "startx", the X server cannot come up.
2. When I try to "lspci", I only get the rather strange reply "lspci: Cannot open /sys/bus/pci/devices/0000:01:00.0/resource: No such file or directory". (However this is only the fact when using the sysfs method of lspci) (But the GPU does not show up at all)

I think there might be some problem with the PCI subsystem. Previously, I already got several "power management faults" during pcihp before disabling it.

Here are my logs and config files. If you require anything else, please request it.

Thanks in advance,
RunGentooRun

"Attachments"
boot.log
dmesg
journalctr
kernel_config
lshw
lspci -A intel-conf1
lspci -A linux-proc
sddm cut of repeating pattern
Xorg.0.log after startx
xorg.conf
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 400
Location: France

PostPosted: Thu Apr 12, 2018 11:45 am    Post subject: Reply with quote

Hello.

Could not tell for sure, but I guess you should enable this option in kenel config: # CONFIG_SYSFS_DEPRECATED is not set

++
Gi)
Back to top
View user's profile Send private message
RunGentooRun
n00b
n00b


Joined: 11 Apr 2018
Posts: 2

PostPosted: Thu Apr 12, 2018 2:09 pm    Post subject: Reply with quote

Hey guitou,

thank you for your reply.
A colleague of mine solved the issue. Actually it was a problem of libpciaccess+pciutils+nvidia.
It turned out that the nvidia-drivers ebuild calls lspci and expects a proper reply while not checking the return value of the process.
Since lspci failed on my system, no useful information was passed during the build. This probably led to corrupted nvidia driver.
Unfortunately, there seems to be a regression in the 'stable' x11-libs/libpciaccess-0.13.4 and/or sys-apps/pciutils-3.4.1. While the gentoo livestick of 2016 or something works. A new setup, however, does not due to the mentioned ebuilds. Perhaps there is a problem with the pci-subsystem of the Xeon Skylake-E platform.

In short: The solution was to unmask and add ~amd64 to accepted_keywords for both:

nano /etc/portage/package.unmask/libpciaccess_pciutils
Code:

=x11-libs/libpciaccess-0.14
=sys-apps/pciutils-3.5.6


nano /etc/portage/package.accepted_keywords/libpciaccess_pciutils
Code:

=x11-libs/libpciaccess-0.14 ~amd64
=sys-apps/pciutils-3.5.6 ~amd64


Code:

emerge -av libpciaccess pciutils


done.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13845

PostPosted: Fri Apr 13, 2018 1:15 am    Post subject: Reply with quote

Generally, deprecated options should be left disabled. They are deprecated for good reason.

OP: it is good that you solved it. As I read your post, you identified specific changes to various ebuilds that could prevent anyone else from encountering the same problems. Is that correct? I see no call to lspci directly in the nvidia-drivers ebuild. I did not check if it is called from nVidia upstream's build script invoked by the ebuild. Assuming that lspci returns a detectable failure, the program which calls it ought to be patched to recognize that failure and abort accordingly. If newer versions of those tools are required for the nVidia ebuild to work, then its dependencies should be adjusted so that Portage enforces the presence of those newer versions.
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 400
Location: France

PostPosted: Fri Apr 13, 2018 12:01 pm    Post subject: Reply with quote

Hello.

Glad you managed to find out and fix your issue, and sorry for the inappropriate suggestion (for my defense, I remember having to enable it quite a while ago, after installing system: was already marked as deprecated, but some programs kept requiring it anyway, that's why I thought about it).

++
Gi)
Back to top
View user's profile Send private message
OldTango
l33t
l33t


Joined: 21 Feb 2004
Posts: 603

PostPosted: Sat Apr 14, 2018 6:39 pm    Post subject: Reply with quote

I'm not convinced your solution was the correct one, however

RunGentooRun wrote:
Perhaps there is a problem with the pci-subsystem of the Xeon Skylake-E platform.

It's very possible that your system requires some functionality present in the newer packages that is absent in the current stable ones.

Looking at your logs it appears that your card is present:
Code:
lspci -A linux-proc
65:00.0 VGA compatible controller: NVIDIA Corporation GP107GL [Quadro P600] (rev a1)
65:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)

and the nvidia-module is being loaded:
Code:
dmesg
NVRM: loading NVIDIA UNIX x86_64 Kernel Module  390.42  Sat Mar  3 04:10:22 PST 2018 (using threaded interrupts)

however, the X-Server is unable to detect it:
Code:
Xorg.0.log
66.455] (II) no primary bus or device found


RunGentooRun wrote:
I have to use the nvidia proprietary drivers. But when I use them and try to "systemctl start sddm" or "startx", the X server cannot come up.
The term "the X server cannot come up" doesn't provide much information to go on. So I am assuming that when you issued the "startx" command the X-Server attempted to start but returned you to the console with an error like
Code:
Fatal server error: no screens found
This is usually (but not always) caused by a configuration error.


Your xorg.conf file contains:
Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:65:00.0"
#    BusID "0000:65:00.0"
    Option "AllowEmptyInitialConfiguration"
EndSection


The use of a BusID is only required in multi-head configurations, or when using a secondary graphics card in a single-head configuration, otherwise it is optional and best if just left out of the config. Also I believe that the format of your BusID is incorrect and if you need to use one it should be
Code:
BusID          "PCI:65:0:0"

and not:
Code:
BusID          "PCI:65:00.0"


All I've ever needed in the device section when using the nvidia proprietary drivers is
Code:
Section "Device"
   Identifier   "Devive0"
   Driver      "nvidia"
   VendorName   "NVIDIA Corporation"
   BoardName   "GeForce GTX 980"
EndSection


With this simple setup when I run startx the X-Server detects my device at:
Code:
[3536988.921] (--) PCI:*(0:1:0:0) 10de:13c0:3842:2983 rev 161, Mem @ 0xfd000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072


My current install versions are:
Code:
[ebuild   R    ] x11-libs/libpciaccess-0.13.4::gentoo  USE="zlib -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] sys-apps/pciutils-3.4.1::gentoo  USE="kmod udev zlib -dns -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] x11-drivers/nvidia-drivers-390.42:0/390::gentoo  USE="X acpi driver kms multilib tools -compat -gtk3 -pax_kernel -static-libs -uvm -wayland" ABI_X86="32 (64) (-x32)" 0 KiB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum