Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Upgrade for Gentoo Base System release 2.3/kernel 4.4.9
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
yhlin00001
n00b
n00b


Joined: 17 Apr 2018
Posts: 4
Location: Taipei

PostPosted: Thu Apr 19, 2018 2:46 am    Post subject: Upgrade for Gentoo Base System release 2.3/kernel 4.4.9 Reply with quote

Hi all,
As subject. I need your help. Thanks in advance.

I have followed https://wiki.gentoo.org/wiki/Upgrading_Gentoo#Upgrading_from_older_systems

#mv /usr/portage /usr/portage.latest
#tar xjpf portage-latest.tar.bz2 -C /usr
#emerge -u portage

but I got the following message.

[ebuild N ] app-portage/elt-patches-20170815
[ebuild r U ] sys-libs/zlib-1.2.11-r1 [1.2.11]
[ebuild U ] sys-devel/automake-1.15.1-r2 [1.15] USE="{-test%}"
[ebuild NS ] dev-lang/python-3.5.5 [2.7.12, 3.4.5] USE="gdbm ipv6 ncurses readline ssl (threads) xml -build -examples -hardened -libressl -sqlite {-test} -tk -wininst"
[ebuild N ] dev-python/pyblake2-1.1.0 PYTHON_TARGETS="python2_7 python3_5 (-pypy) -python3_4 -python3_6"
[ebuild U ] sys-apps/portage-2.3.24-r1 [2.3.3] USE="native-extensions* -gentoo-dev% (-rsync-verify)" PYTHON_TARGETS="python3_5* -python3_4* -python3_6%"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/zlib:0

(sys-libs/zlib-1.2.11-r1:0/1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(sys-libs/zlib-1.2.11:0/0::gentoo, installed) pulled in by
sys-libs/zlib:0/0= required by (media-libs/openjpeg-2.1.1_p20160922:2/7::gentoo, installed)
^^^^^
(and 10 more with the same problem)

sys-apps/portage:0

(sys-apps/portage-2.3.24-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
sys-apps/portage (Argument)

(sys-apps/portage-2.3.3:0/0::gentoo, installed) pulled in by
sys-apps/portage[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (app-portage/gentoolkit-0.3.2-r1:0/0::gentoo, installed)


NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- sys-libs/glibc-2.22-r4::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.
# (updated 27 Dec 2017 with gcc < 5.4)

- sys-devel/gcc-4.9.4::gentoo (masked by: package.mask)
- sys-devel/binutils-2.25.1-r1::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
bammbamm808
Guru
Guru


Joined: 08 Dec 2002
Posts: 487
Location: Hawaii

PostPosted: Thu Apr 19, 2018 3:14 am    Post subject: Reply with quote

Save yourself and everyone else a lot of time and aggrivation: Fresh install.
_________________
Asrock X470 Taichi
Ryzen 2700x
32Gb Samsung B-die (16GB dual rank x2) DDR4
Geforce GTX 1060 6GB
Samsung Evo 840 500Gb +Seagate 1TB HDD
Etc....
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21754
Location: here

PostPosted: Thu Apr 19, 2018 6:10 am    Post subject: Reply with quote

First try to update use flag changes
Code:
# emerge -UD @world

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum