Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
is there any configuration for USER_NS?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
fcolecumberri
n00b
n00b


Joined: 28 Apr 2018
Posts: 1

PostPosted: Sat Apr 28, 2018 5:05 am    Post subject: is there any configuration for USER_NS? Reply with quote

Hi,
Several days ago, I enable the USER_NS (user namespaces) in my kernel .conf (4.9.76-gentoo-r1) in order to use brave browser, but since I did that I got some problems.

First, if I want to mount my Ubuntu partition from the graphicl interface (I'm using Mate Environment with caja as the file manager) the system ask me about the root password (my root user doesn't have a password so I need to use sudo mount) and according to the USER_NS documentation I have read one of the big advantage of having USER_NS is that unprivileged users may mount partitions in a safe space so I think something there just is just miss configured.

The second problem I found is that brave browser which is using this feature tend to jam a little in certain situations, this doesn't happen if I use the --no-sandbox (which avoids using USER_NS) flag, but the point of using USER_NS is to avoid security issues.

since both problems seems to be related to a bad configuration I was wondering if there is any configuration I am not doing.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum