Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ETPS/2 Elantech Touchpad not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
feiticeir0
Apprentice
Apprentice


Joined: 13 Jul 2005
Posts: 281
Location: Castelo Branco, Portugal

PostPosted: Fri May 04, 2018 10:29 am    Post subject: ETPS/2 Elantech Touchpad not working Reply with quote

Hi !

I've search and search here on the foruns, but no solution worked for me...
I have a Fujitsu Lifebook E448 laptop, with a Elantech Touchpad and I'm struggling to get it to work...

Everything is recognized, but the touchpad just don't work...

Here's some specs:

Code:

dmesg | grep input
[    0.225049] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0
[    0.225648] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input1
[    0.275976] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input2
[    0.310120] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input3
[    1.966413] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio2/input/input9
[    2.743005] input: Fujitsu FUJ02E3 as /devices/LNXSYSTM:00/LNXSYBUS:00/FUJ02E3:00/input/input12
[    2.986034] input: FJ Camera as /devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.0/input/input13
[    3.130859] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    4.148362] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input14
[    4.148442] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input15
[    4.148548] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input16


Code:

darkrider ~ # xinput list
⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                   id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Fujitsu FUJ02E3                            id=6   [slave  keyboard (3)]
    ↳ Video Bus                                  id=7   [slave  keyboard (3)]
    ↳ Power Button                               id=8   [slave  keyboard (3)]
    ↳ FJ Camera                                  id=9   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard               id=10   [slave  keyboard (3)]


Code:

darkrider ~ # udevadm info -q all /dev/input/mouse0
P: /devices/platform/i8042/serio2/input/input9/mouse0
N: input/mouse0
E: DEVNAME=/dev/input/mouse0
E: DEVPATH=/devices/platform/i8042/serio2/input/input9/mouse0
E: ID_BUS=i8042
E: ID_INPUT=1
E: ID_INPUT_TOUCHPAD=1
E: MAJOR=13
E: MINOR=32
E: SUBSYSTEM=input
E: USEC_INITIALIZED=2745875


Xfce does recognize the touchpad, but not working...

https://imgur.com/d2ctbQa

Here's my 50-synaptics.conf:
Code:

Section "InputClass"
        Identifier "touchpad"
        Driver "synaptics"
        MatchIsTouchpad "on"
   MatchDevicePath "/dev/input/event*"
        Option "VertEdgeScroll" "on"
        Option      "CircularScrolling"         "on"
        Option      "VertScrollDelta"          "-111"
        Option      "HorizScrollDelta"         "-111"
        Option      "TapButton1"                    "1"
EndSection


I've already played with the kernel options i8042.reset and i8042.nomux=1 and i8042.nopnp and nothing... :(
_________________
Do It With Rhythm
Back to top
View user's profile Send private message
feiticeir0
Apprentice
Apprentice


Joined: 13 Jul 2005
Posts: 281
Location: Castelo Branco, Portugal

PostPosted: Thu May 10, 2018 8:16 am    Post subject: Reply with quote

I'm now having a funny behaviour...

Inserting the kernel parameters - i8042.nomux=1 in the boot, I'm still not able to work with the touchpad when first boot... But if the computer goes to suspend and when I awake him from the suspend mode, the touchpad works... :?: :?: :?: :?: :?:

I don't see anything in the logs....
_________________
Do It With Rhythm
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum