Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] GPT BIOS unclear partitioning instructions
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Dylanus
n00b
n00b


Joined: 02 Jun 2018
Posts: 40

PostPosted: Sat Jun 02, 2018 3:08 am    Post subject: [SOLVED] GPT BIOS unclear partitioning instructions Reply with quote

Hi all,

I'm new to Gentoo and I'm attempting to install it in a VM to get the hang of it. I've already deleted the image three times and started it again, as I am having difficulty getting certain things right.
In particular, I'm not sure how to prepare the disk for GRUB correctly.
I have been following the handbook instructions on installation and I have stuck with their defaults. I am doing this in KVM. I have allocated 4 CPU cores and 2GB of RAM. KVM only allows BIOS, not UEFI, possibly because the laptop I'm running this on does not support UEFI.
When I get to the partitioning section of the handbook, there is a section on the flags for the boot partition that I find confusing. I have partition 1, 2MB, named grub with bios_grub flag turned on. Then I have partition 2, 128MB, named boot. This is the instruction the handbook gives for using GPT with BIOS, which I am doing because using MBR is outdated and does not appear to offer any advantages.
The handbook then states the following:

Quote:
When using the UEFI interface to boot the system (instead of BIOS), mark the boot partition as the EFI System Partition. Parted does this automatically when the boot option is set on the partition:
Code:
(parted)set 2 boot on


So, since I am not using UEFI, do I not set boot on? Do I do nothing? I have been using
Code:
fdisk -l /dev/sda
to check the types. If I do not run the last command, the type of /dev/sda2 is Linux Filesystem. If I do run it, then it becomes EFI Filesystem. I don't want an EFI Filesystem, so that makes me think I should leave it alone, however, the handbook goes on to state that on a UEFI installation, the boot and esp flags will show up on the boot partition. Does that mean that this command should be run anyway, but the esp flag will not show up on a BIOS system? But I do get esp showing up by default. Is something incorrectly detecting that this is a UEFI system?
This is all on https://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Disks.
I have not been able to find clarification of this matter on the forum or elsewhere. I hope my question is clear. If someone could just advise me on how I am supposed to configure this partition for GPT/BIOS, that would be really helpful. Please let me know if you need further clarification.
Thanks


Last edited by Dylanus on Sat Jun 02, 2018 6:19 am; edited 1 time in total
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7090
Location: Saint Amant, Acadiana

PostPosted: Sat Jun 02, 2018 3:39 am    Post subject: Reply with quote

Boot partition is optional with BIOS boot. You can set the boot flag even if you use GPT (with protective MBR), it is an attribute of partition, not filesystem. It is not needed for Linux, but some BIOS variants are looking for it.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Dylanus
n00b
n00b


Joined: 02 Jun 2018
Posts: 40

PostPosted: Sat Jun 02, 2018 4:15 am    Post subject: Reply with quote

Ok thanks.
So I'm now trying the following:
partition 1, 2MB, named grub, bios_grub flag set on.
partition 2, 512MB, swap.
partition 3, remaining disk, rootfs.

At the stage when the handbook tells me to mount the boot partition at /boot, do I ignore that step? After that I'm assuming things will work just like they do in Arch. I run
Code:
grub-install /dev/sda
and it figures out the rest.
Back to top
View user's profile Send private message
Dylanus
n00b
n00b


Joined: 02 Jun 2018
Posts: 40

PostPosted: Sat Jun 02, 2018 6:18 am    Post subject: Reply with quote

I successfully booted Gentoo! I have no internet, and there is no ethernet device, so clearly I missed a driver when I was compiling, and I will probably have to start all over again, but at least I figured out grub. Small things! Thanks for your help.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13842

PostPosted: Sat Jun 02, 2018 3:41 pm    Post subject: Reply with quote

You do not need to start over. You can boot the LiveCD, mount and chroot into your installed system, and take corrective actions (e.g. adding the missed kernel driver) without discarding all your work to date.

If you want help solving your network problem, boot the live environment, install app-text/wgetpaste, and use it to upload the output of lspci (if the card is not connected via USB), lsusb (if the card is connected over USB), or both if you do not know. Also, use wgetpaste to upload your kernel configuration so we can see what you enabled already.
Back to top
View user's profile Send private message
Dylanus
n00b
n00b


Joined: 02 Jun 2018
Posts: 40

PostPosted: Sun Jun 03, 2018 4:28 am    Post subject: Reply with quote

That sounds like it would have been much easier. I did it all over from scratch last night. At least it helped me get more familiar with configuration.
It's all working now. There is one weird issue though, where the machine doesn't shut down. It just returns to the login screen. I can force it off from virt-manager, and it still boots up again without a problem, but it seems like a bit of an odd issue. I couldn't see any information about it online. Am I missing a shutdown driver? The command `shutdown now` works, it just doesn't turn it off.
What could that be related to?
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1655
Location: United Kingdom

PostPosted: Sun Jun 03, 2018 5:09 am    Post subject: Reply with quote

What desktop environment are you using?

The command 'shutdown now' will not power off your machine. You need to use the command 'shutdown -h now' to do that. The command 'man shutdown' will tell you the options.

[snip]
-r Reboot after shutdown.

-h Equivalent to -P, unless -H is specified.

-P Action is to power-off the machine.
[/snip]
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Dylanus
n00b
n00b


Joined: 02 Jun 2018
Posts: 40

PostPosted: Sun Jun 03, 2018 5:34 am    Post subject: Reply with quote

I don't have a desktop environment. I haven't installed one at this stage.
The -h option worked perfectly. I don't normally have to use it on other distros like Arch. Is that because they have that option set by default?
Thanks everyone for your help. It seems like everything is working perfectly now. I'm looking forward to exploring.
Back to top
View user's profile Send private message
P.Kosunen
Guru
Guru


Joined: 21 Nov 2005
Posts: 309
Location: Finland

PostPosted: Sun Jun 03, 2018 12:59 pm    Post subject: Reply with quote

You could just say "poweroff" instead.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum