Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dantrell's GNOME Without Systemd Project (Part 2)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 11, 12, 13, 14, 15, 16  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
simonvanderveldt
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2016
Posts: 105

PostPosted: Sat Jan 05, 2019 11:33 am    Post subject: Reply with quote

Just tried webkit-gtk 2.22.4 but for that I get a bunch of different errors:

Code:
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp: In member function 'bool WebCore::MediaPlayerPrivateGStreamerBase::ensureGstGLContext()':
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:545:46: error: 'class WebCore::PlatformDisplay' has no member named 'sharingGLContext'
     GLContext* webkitContext = sharedDisplay.sharingGLContext();
                                              ^~~~~~~~~~~~~~~~
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:557:62: error: 'class WebCore::GLContext' has no member named 'platformContext'; did you mean '_vptr.GLContext'?
     PlatformGraphicsContext3D contextHandle = webkitContext->platformContext();
                                                              ^~~~~~~~~~~~~~~
                                                              _vptr.GLContext
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:562:134: error: 'glAPI' was not declared in this scope
         m_glContext = adoptGRef(gst_gl_context_new_wrapped(m_glDisplay.get(), reinterpret_cast<guintptr>(contextHandle), glPlatform, glAPI));
                                                                                                                                      ^~~~~
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:562:134: note: suggested alternative: 'GLAPI'
         m_glContext = adoptGRef(gst_gl_context_new_wrapped(m_glDisplay.get(), reinterpret_cast<guintptr>(contextHandle), glPlatform, glAPI));
                                                                                                                                      ^~~~~
                                                                                                                                      GLAPI
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:564:124: error: 'glAPI' was not declared in this scope
         m_glContext = gst_gl_context_new_wrapped(m_glDisplay.get(), reinterpret_cast<guintptr>(contextHandle), glPlatform, glAPI);
                                                                                                                            ^~~~~
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:564:124: note: suggested alternative: 'GLAPI'
         m_glContext = gst_gl_context_new_wrapped(m_glDisplay.get(), reinterpret_cast<guintptr>(contextHandle), glPlatform, glAPI);
                                                                                                                            ^~~~~
                                                                                                                            GLAPI
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp: In member function 'void WebCore::MediaPlayerPrivateGStreamerBase::flushCurrentBuffer()':
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:930:12: error: 'TextureMapperPlatformLayerProxy' has not been declared
         [](TextureMapperPlatformLayerProxy& proxy)
            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp: In lambda function:
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:932:37: error: request for member 'lock' in 'proxy', which is of non-class type 'int'
             LockHolder locker(proxy.lock());
                                     ^~~~
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:934:23: error: request for member 'isActive' in 'proxy', which is of non-class type 'int'
             if (proxy.isActive())
                       ^~~~~~~~
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:935:23: error: request for member 'dropCurrentBufferWhilePreservingTexture' in 'proxy', which is of non-class type 'int'
                 proxy.dropCurrentBufferWhilePreservingTexture();
                       ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp: In member function 'void WebCore::MediaPlayerPrivateGStreamerBase::flushCurrentBuffer()':
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:941:21: error: 'm_platformLayerProxy' was not declared in this scope
     proxyOperation(*m_platformLayerProxy);
                     ^~~~~~~~~~~~~~~~~~~~
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:941:21: note: suggested alternative: 'platformLayer'
     proxyOperation(*m_platformLayerProxy);
                     ^~~~~~~~~~~~~~~~~~~~
                     platformLayer
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp: In member function 'virtual bool WebCore::MediaPlayerPrivateGStreamerBase::copyVideoTextureToPlatformTexture(WebCore::GraphicsContext3D*, Platform3DObject, GC3Denum, GC3Dint, GC3Denum, GC3Denum, GC3Denum, bool, bool)':
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:990:21: error: 'GstVideoFrameHolder' was not declared in this scope
     std::unique_ptr<GstVideoFrameHolder> frameHolder = std::make_unique<GstVideoFrameHolder>(m_sample.get(), texMapFlagFromOrientation(m_videoSourceOrientation), true);
                     ^~~~~~~~~~~~~~~~~~~
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:990:21: note: suggested alternative: 'GstVideoFrameFlags'
     std::unique_ptr<GstVideoFrameHolder> frameHolder = std::make_unique<GstVideoFrameHolder>(m_sample.get(), texMapFlagFromOrientation(m_videoSourceOrientation), true);
                     ^~~~~~~~~~~~~~~~~~~
                     GstVideoFrameFlags
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:990:40: error: template argument 1 is invalid
     std::unique_ptr<GstVideoFrameHolder> frameHolder = std::make_unique<GstVideoFrameHolder>(m_sample.get(), texMapFlagFromOrientation(m_videoSourceOrientation), true);
                                        ^
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:990:40: error: template argument 2 is invalid
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:990:110: error: 'texMapFlagFromOrientation' was not declared in this scope
     std::unique_ptr<GstVideoFrameHolder> frameHolder = std::make_unique<GstVideoFrameHolder>(m_sample.get(), texMapFlagFromOrientation(m_videoSourceOrientation), true);
                                                                                                              ^~~~~~~~~~~~~~~~~~~~~~~~~
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:990:110: note: suggested alternative: 'DefaultImageOrientation'
     std::unique_ptr<GstVideoFrameHolder> frameHolder = std::make_unique<GstVideoFrameHolder>(m_sample.get(), texMapFlagFromOrientation(m_videoSourceOrientation), true);
                                                                                                              ^~~~~~~~~~~~~~~~~~~~~~~~~
                                                                                                              DefaultImageOrientation
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:992:33: error: base operand of '->' is not a pointer
     auto textureID = frameHolder->textureID();
                                 ^~
/var/tmp/portage/net-libs/webkit-gtk-2.22.4/work/webkitgtk-2.22.4/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:996:28: error: base operand of '->' is not a pointer
     auto size = frameHolder->size();
                            ^~

Does this sound familiar to anyone?
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 122
Location: Italy

PostPosted: Sun Jan 06, 2019 5:20 pm    Post subject: Reply with quote

simonvanderveldt wrote:
Does this sound familiar to anyone?

The GStreamer part on 2.22.4 sounds familiar to this. However I found nothing searching for your 2.22.5 error message, nor did I have any problem when I compiled it last month. Since the damned dev-libs/icu is triggering webkit-gtk rebuild, I'll let you know if something weird shows up. My USE flags are way different though:
Code:
shiba ~ $ echo $(equery -q uses webkit-gtk)
+X -coverage -doc +egl +geolocation -gles2 +gnome-keyring +gstreamer +introspection +jit +libnotify -nsplugin +opengl +spell -test -wayland +webgl
Back to top
View user's profile Send private message
simonvanderveldt
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2016
Posts: 105

PostPosted: Mon Jan 07, 2019 9:21 am    Post subject: Reply with quote

Shibotto wrote:
simonvanderveldt wrote:
Does this sound familiar to anyone?

The GStreamer part on 2.22.4 sounds familiar to this. However I found nothing searching for your 2.22.5 error message, nor did I have any problem when I compiled it last month. Since the damned dev-libs/icu is triggering webkit-gtk rebuild, I'll let you know if something weird shows up. My USE flags are way different though:
Code:
shiba ~ $ echo $(equery -q uses webkit-gtk)
+X -coverage -doc +egl +geolocation -gles2 +gnome-keyring +gstreamer +introspection +jit +libnotify -nsplugin +opengl +spell -test -wayland +webgl

Thanks for that bug link/the info! I figured I'd just try 2.22.4 with +opengl and it compiled fine that way. Then also tried 2.22.5 with the same USE flags and that compiled fine as well. Not perfect but at least it's working again, so thanks!
I'll comment on that bug as well to confirm it.
Back to top
View user's profile Send private message
Spargeltarzan
Apprentice
Apprentice


Joined: 23 Jul 2017
Posts: 293

PostPosted: Tue Jan 08, 2019 7:40 pm    Post subject: Reply with quote

saboya wrote:


I had this issue before, and had it again with my most recent install. My guess is that the issue is pam_gnome_keyring.so is loaded twice by pam if you use GDM, because it's present in /etc/pam.d/system-login and /etc/pam.d/gdm-password. Removing this line

Code:
session                optional        pam_gnome_keyring.so auto_start


from /etc/pam.d/system-login fixed the issue for me.


Many thanks, this fixed the issue for me. I tried different Login Managers before, so it might not have todo with GDM necesserily.
_________________
___________________
Regards

Spargeltarzan

Notebook: Lenovo YOGA 900-13ISK: Gentoo stable amd64, GNOME systemd, KVM/QEMU
Desktop-PC: Intel Core i7-4770K, 8GB Ram, AMD Radeon R9 280X, ZFS Storage, GNOME openrc, Dantrell, Xen
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Sat Jan 12, 2019 3:39 pm    Post subject: Reply with quote

Since an update yesterday gnome-color-manager-3.30.0-r1 won't build with following error:
https://pastebin.com/wTCu6qgF
Looks like it has something to do with media-gfx/exiv2-0.27.0-r1, *edit* with media-gfx/exiv2-0.26_p20180811-r3 it builds fine.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Sat Jan 12, 2019 7:40 pm    Post subject: Reply with quote

Shibotto wrote:
The GStreamer part on 2.22.4 sounds familiar to this.

simonvanderveldt wrote:
Thanks for that bug link/the info! I figured I'd just try 2.22.4 with +opengl and it compiled fine that way. Then also tried 2.22.5 with the same USE flags and that compiled fine as well. Not perfect but at least it's working again, so thanks!

Per the resolution of Gentoo bug #666806 and my own assessment of the issue, the opengl USE flag for net-libs/webkit-gtk is now force-enabled.

P.S. I actually made this change a couple days ago but forgot to comment about it. :o

Child_of_Sun_24 wrote:
Since an update yesterday gnome-color-manager-3.30.0-r1 won't build with following error [...]

Excuse the delay but since even GNOME 3.14 was affected I had to do some additional testing across the board.

Sync up and you should be good to go.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Sun Jan 13, 2019 9:43 am    Post subject: Reply with quote

dantrell wrote:
Child_of_Sun_24 wrote:
Since an update yesterday gnome-color-manager-3.30.0-r1 won't build with following error [...]

Excuse the delay but since even GNOME 3.14 was affected I had to do some additional testing across the board.

Sync up and you should be good to go.


Thank you, now it works fine :-)
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 445
Location: Brazil

PostPosted: Sun Jan 13, 2019 1:37 pm    Post subject: Reply with quote

Had a little error with poppler / inkscape today:

Code:
app-text/poppler:0

  (app-text/poppler-0.68.0:0/79::dantrell-gnome, ebuild scheduled for merge) conflicts with
    <app-text/poppler-0.66.0:= required by (media-gfx/inkscape-0.92.3-r3:0/0::dantrell-gnome, ebuild scheduled for merge)
    ^                 ^^^^^^
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7108
Location: Austria

PostPosted: Sun Jan 13, 2019 1:39 pm    Post subject: Reply with quote

inkscape from tree is fit for poppler-0.72.0...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Sun Jan 13, 2019 3:15 pm    Post subject: Reply with quote

saboya wrote:
Had a little error with poppler / inkscape today [...]

I forgot to stabilize inkscape after I stabilized poppler.

Sync up and you should be good to go.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Thu Feb 07, 2019 8:22 am    Post subject: Reply with quote

Hello :-)

With gtk+-3.24.5 there is a compile error:
Code:
../gdk/.libs/libgdk-3.so: error: undefined reference to 'fribidi_get_bidi_type'
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:3547: gtk-encode-symbolic-svg] Fehler 1
make[3]: *** Es wird auf noch nicht beendete Prozesse gewartet....


I hope this helps, thanks.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Thu Feb 07, 2019 5:17 pm    Post subject: Reply with quote

Child_of_Sun_24 wrote:
With gtk+-3.24.5 there is a compile error [...]

It looks like I missed a dependency.

Please confirm by oneshotting FriBidi:

Code:
emerge --ask --oneshot dev-libs/fribidi

and then updating @world.

Edit: Actually, a closer looked showed that FriBidi is already pulled in by Pango.

I haven't been able to reproduce your build failure but maybe FriBidi just needs to be rebuilt?
_________________
Dantrell B.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Fri Feb 08, 2019 9:26 am    Post subject: Reply with quote

Rebuilding fribidi doesn't help, i am rebuilding librsvg now to see if this helps.

You can't see on my post that the compile error is in the abi_x86_32 part of the build process.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 445
Location: Brazil

PostPosted: Fri Feb 08, 2019 12:14 pm    Post subject: Reply with quote

Had an issue with meson being masked:

Code:
!!! The following update has been skipped due to unsatisfied dependencies:

media-libs/gexiv2:0

  selected: (media-libs/gexiv2-0.10.8:0/0::gentoo, installed)
  skipped: (media-libs/gexiv2-0.10.10-r1:0/0::gentoo, ebuild scheduled for merge) (see unsatisfied dependency below)

!!! All ebuilds that could satisfy ">=dev-util/meson-0.48.2" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-util/meson-9999::gentoo (masked by: package.mask, missing keyword)
- dev-util/meson-0.49.2::dantrell-gnome (masked by: missing keyword)
- dev-util/meson-0.49.2::gentoo (masked by: package.mask, ~amd64 keyword)
- dev-util/meson-0.49.1::dantrell-gnome (masked by: missing keyword)
- dev-util/meson-0.49.1::gentoo (masked by: package.mask, ~amd64 keyword)
- dev-util/meson-0.49.0::gentoo (masked by: package.mask, ~amd64 keyword)
/var/lib/layman/dantrell-gnome/profiles/targets/desktop/gnome/package.mask:
# Regression in meson_options.txt default values
#
# Ref. https://bugs.freedesktop.org/show_bug.cgi?id=103162

- dev-util/meson-0.48.2::gentoo (masked by: package.mask)
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Fri Feb 08, 2019 9:30 pm    Post subject: Reply with quote

Child_of_Sun_24 wrote:
You can't see on my post that the compile error is in the abi_x86_32 part of the build process.

Well this is a pretty important tidbit. Without it I would have just been wasting my time diagnosing the issue since I don't have a suitable setup for testing abi_x86_32 so in the future please just share the full build log starting from the emerge command.

That said, I think the issue is resolved so sync up and give it a go.

saboya wrote:
Had an issue with meson being masked: [...]

Sync up and you should be good to go.

P.S. As best as I can tell, nothing on my end or Gentoo's explicitly requests >=dev-util/meson-0.48.2 so it's not immediately obvious why the 0.47.z series doesn't satisfy the prerequisites.
_________________
Dantrell B.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7108
Location: Austria

PostPosted: Fri Feb 08, 2019 10:03 pm    Post subject: Reply with quote

dantrell wrote:
P.S. As best as I can tell, nothing on my end or Gentoo's explicitly requests >=dev-util/meson-0.48.2 so it's not immediately obvious why the 0.47.z series doesn't satisfy the prerequisites.

Code:
$ grep dev-util/meson eclass/meson.eclass
MESON_DEPEND=">=dev-util/meson-0.48.2

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Fri Feb 08, 2019 10:31 pm    Post subject: Reply with quote

asturm wrote:
dantrell wrote:
P.S. As best as I can tell, nothing on my end or Gentoo's explicitly requests >=dev-util/meson-0.48.2 so it's not immediately obvious why the 0.47.z series doesn't satisfy the prerequisites.

Code:
$ grep dev-util/meson eclass/meson.eclass
MESON_DEPEND=">=dev-util/meson-0.48.2

Thanks for the heads up.

This change was made fairly recently and I was checking against an outdated repository.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Sat Feb 09, 2019 11:37 am    Post subject: Reply with quote

dantrell wrote:
Well this is a pretty important tidbit. Without it I would have just been wasting my time diagnosing the issue since I don't have a suitable setup for testing abi_x86_32 so in the future please just share the full build log starting from the emerge command.

That said, I think the issue is resolved so sync up and give it a go.


Sorry for that, i noticed it short before my second post, next time i will be more accurate. Now it works :-)
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Tue Feb 12, 2019 10:43 am    Post subject: Reply with quote

When building gnome-recipes-2.0.2 i get the following error:

Code:
 * Package:    gnome-extra/gnome-recipes-2.0.2
 * Repository: dantrell-gnome
 * USE:        abi_x86_64 amd64 archive elibc_glibc kernel_linux sound spell userland_GNU
 * FEATURES:   network-sandbox preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking gnome-recipes-2.0.2.tar.xz to /var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/work
>>> Source unpacked in /var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/work
>>> Preparing source in /var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/work/gnome-recipes-2.0.2 ...
Klone nach 'libgd' ...
fatal: unable to access 'https://gitlab.gnome.org/GNOME/libgd/': Couldn't connect to server
 * Disabling deprecation warnings ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/work/gnome-recipes-2.0.2 ...
meson --buildtype plain --libdir lib64 --localstatedir /var/lib --prefix /usr --sysconfdir /etc --wrap-mode nodownload -D enable-autoar=yes -D enable-gspell=yes -D enable-canberra=yes /var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/work/gnome-recipes-2.0.2 /var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/work/gnome-recipes-2.0.2-build
The Meson build system
Version: 0.49.2
Source dir: /var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/work/gnome-recipes-2.0.2
Build dir: /var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/work/gnome-recipes-2.0.2-build
Build type: native build
WARNING: Unknown options: "enable-autoar, enable-canberra, enable-gspell"
Project name: gnome-recipes
Project version: 2.0.2
Appending CFLAGS from environment: '-march=znver1 -O2 -pipe -fomit-frame-pointer'
Appending LDFLAGS from environment: '-march=znver1 -O2 -pipe -fomit-frame-pointer -Wl,-O1 -Wl,--as-needed'
Native C compiler: x86_64-pc-linux-gnu-gcc (gcc 8.2.0 "x86_64-pc-linux-gnu-gcc (Gentoo 8.2.0-r6 p1.7) 8.2.0")
Build machine cpu family: x86_64
Build machine cpu: x86_64
WARNING: Project targetting '>=0.36.0' but tried to use feature introduced in '0.38.0': default_options arg in subproject

meson.build:13:0: ERROR:  Failed to initialize 'subprojects/libgd':
Subproject directory not found and libgd.wrap file not found

A full log can be found at /var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/work/gnome-recipes-2.0.2-build/meson-logs/meson-log.txt
 * ERROR: gnome-extra/gnome-recipes-2.0.2::dantrell-gnome failed (configure phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  124:  Called src_configure
 *   environment, line 3679:  Called meson_src_configure
 *   environment, line 2557:  Called die
 * The specific snippet of code:
 *       tc-env_build "$@" || die
 *
 * If you need support, post the output of `emerge --info '=gnome-extra/gnome-recipes-2.0.2::dantrell-gnome'`,
 * the complete build log and the output of `emerge -pqv '=gnome-extra/gnome-recipes-2.0.2::dantrell-gnome'`.
 * The complete build log is located at '/var/log/portage/gnome-extra:gnome-recipes-2.0.2:20190212-102219.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/temp/environment'.
 * Working directory: '/var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/work/gnome-recipes-2.0.2'
 * S: '/var/tmp/portage/gnome-extra/gnome-recipes-2.0.2/work/gnome-recipes-2.0.2'
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Tue Feb 12, 2019 10:47 am    Post subject: Reply with quote

When building libgnome-keyring-3.12.0-r1 i get the following error:
https://pastebin.com/2U23gmFb
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22160
Location: here

PostPosted: Tue Feb 12, 2019 10:50 am    Post subject: Reply with quote

Child_of_Sun_24 wrote:
When building libgnome-keyring-3.12.0-r1 i get the following error:
https://pastebin.com/2U23gmFb

https://bugs.archlinux.org/task/60489
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Wed Feb 13, 2019 7:41 am    Post subject: Reply with quote

Child_of_Sun_24 wrote:
When building gnome-recipes-2.0.2 i get the following error: [...]

Child_of_Sun_24 wrote:
When building libgnome-keyring-3.12.0-r1 i get the following error: [...]

I was able to reproduce and correct these errors.

Sync up and you should be good to go.

fedeliallalinea wrote:
https://bugs.archlinux.org/task/60489

P.S. For the record, disabling the vala USE flag would have been a valid workaround here since the problem was with Vala. More specifically, however, the problem was with Vala 0.42 so a maximum Vala API version just needed to be defined.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Wed Feb 13, 2019 9:13 am    Post subject: Reply with quote

dantrell wrote:
Child_of_Sun_24 wrote:
When building gnome-recipes-2.0.2 i get the following error: [...]

Child_of_Sun_24 wrote:
When building libgnome-keyring-3.12.0-r1 i get the following error: [...]

I was able to reproduce and correct these errors.

Sync up and you should be good to go.


Yes, thanks, everything is working fine now :-)
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 122
Location: Italy

PostPosted: Wed Feb 13, 2019 5:28 pm    Post subject: Reply with quote

Something I just noticed: since the default behaviour is to generate thumbnails inside a sandbox, I believe both nautilus and gnome-desktop should depend on bubblewrap when vanilla-thumbnailer is in use.

Also gnome-desktop can be removed from nautilus dependencies, since the thumbnailer got copy-pasted into nautilus itself.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Fri Feb 15, 2019 6:34 am    Post subject: Reply with quote

Shibotto wrote:
Something I just noticed: since the default behaviour is to generate thumbnails inside a sandbox, I believe both nautilus and gnome-desktop should depend on bubblewrap when vanilla-thumbnailer is in use.

Also gnome-desktop can be removed from nautilus dependencies, since the thumbnailer got copy-pasted into nautilus itself.

Done. :wink:
_________________
Dantrell B.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 11, 12, 13, 14, 15, 16  Next
Page 12 of 16

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum