Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wrong systemtime in DATE, HWCLOCK is OK !
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
wirkzeit
n00b
n00b


Joined: 29 Mar 2015
Posts: 9

PostPosted: Thu Jun 14, 2018 2:47 pm    Post subject: Wrong systemtime in DATE, HWCLOCK is OK ! Reply with quote

Hello, sorry for my english ;-)...

I test 3 days with a crazy problem...

I work on console with a Gentoo stage3 archive. All OK, but ...

when i start the system and make a date on console, the time is correct, the same in hwclock.
After 1 Minute, date have a time difference in the past (~10 seconds)
After 3 Minutes 1 have ~1 minute difference to hwclock
After 4 hours, i have a difference from 1/2 hour ...

When the system comes up, the Softwareclock is to slow ...
crazy to slow :-)

I have NO /etc/adjust file !!!

I have study the ArchWiki and Gentoo RTC FAQ .. no change .. date is to slow ...

I install the system via chroot.

Any idea ?

Thank you Gentoo-Gods from west germany

Thorsten
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7134
Location: almost Mile High in the USA

PostPosted: Thu Jun 14, 2018 4:26 pm    Post subject: Reply with quote

This is a kernel timekeeping issue, instead of a RTC issue. Likely the kernel picked a clock source that is unstable.

What do the kernel setting files

Code:
# cat /sys/devices/system/clocksource/clocksource0/current_clocksource
tsc
# cat /sys/devices/system/clocksource/clocksource0/available_clocksource
tsc hpet acpi_pm

contain?

You may try the other ones in "available_clocksource" by

Code:
# echo acpi_pm > /sys/devices/system/clocksource/clocksource0/current_clocksource


to see if it works any better. If you don't see any other options, you may need to edit your kernel options to enable them...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
wirkzeit
n00b
n00b


Joined: 29 Mar 2015
Posts: 9

PostPosted: Fri Jun 15, 2018 4:32 pm    Post subject: Solved APIC was the problem Reply with quote

Thank you for you response ...
With your help, i find the right path after 4 days working on this problem ...

It is a problem with my Gigabyte Board an the AMD Phenom II Prozessor ... (i think)

When i give the Boot Parameter disableapic in grub. The clock is right !!!
Same with: no_timer_check

APICs

apic Use IO-APIC. Default

noapic Don't use the IO-APIC.

disableapic Don't use the local APIC

nolapic Don't use the local APIC (alias for i386 compatibility)

pirq=... See Documentation/x86/i386/IO-APIC.txt

noapictimer Don't set up the APIC timer

no_timer_check Don't check the IO-APIC timer. This can work around
problems with incorrect timer initialization on some boards.
apicpmtimer
Do APIC timer calibration using the pmtimer. Implies
apicmaintimer. Useful when your PIT timer is totally
broken.

I found this on Kernel.org for AMD CPUs...

Thank you for your help and greetings to you!

Thorsten
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum