Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Black screen after GRUB
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
austinramsay
n00b
n00b


Joined: 25 Oct 2010
Posts: 38

PostPosted: Sun Jun 24, 2018 6:46 pm    Post subject: Black screen after GRUB Reply with quote

Just finished my Gentoo install. Successfully boots to GRUB:2, but once the kernel begins to load I just get a black screen and am unable to see anything.

System background:
Dell XPS 9370
Using UEFI
Intel I7-8550U
Followed Handbook for Systemd, X, Gnome, and Intel graphics


There were a few things I did not see that matched my system that the handbook said was necessary such as enabling framebuffer console support in the kernel.

I know that the X server shouldnt be causing this issue..but im referencing this guide because i changed my kernel options accordingly since I've installed X, Gnome, and followed the Intel graphics guide.
From the Xorg Gentoo guide:
Quote:

Kernel modesetting

Modern open source video drivers rely on kernel mode setting (KMS). KMS provides an improved graphical boot with less flickering, faster user switching, a built-in framebuffer console, seamless switching from the console to Xorg, and other features.
Important
KMS conflicts with legacy framebuffer drivers, which must remain disabled in the kernel configuration.

First prepare the kernel for KMS. This step regardless of which Xorg video driver will be used:
KERNEL Disable legacy framebuffer support and enable basic console FB support

Device Drivers --->
Graphics support --->
Frame Buffer Devices --->
<*> Support for frame buffer devices --->
## (Disable all drivers, including VGA, Intel, nVidia, and ATI, except EFI-based Framebuffer Support, only if you are using UEFI)

## (Further down, enable basic console support. KMS uses this.)
Console display driver support ---> (NOT SEEING THIS OPTION)
<*> Framebuffer Console Support (NOT SEEING THIS OPTION)


Next configure the kernel to use the proper KMS driver for the video card. Intel, nVidia, and AMD/ATI are the most common cards, so follow code listing for each card below.

For Intel cards see the kernel section of the Intel article.


EFI based framebuffer support IS enabled.
It has been stated in a few different places that CONFIG_FRAMEBUFFER_CONSOLE must be set to Y. However, using / in the menuconfig leads me to enable the "Console display driver support -> <*> Framebuffer console support" option that I do not have in my menuconfig?

In the Intel graphics guide "Troubleshooting" section:
Quote:

Black screen

According to this Debian wiki, CONFIG_FRAMEBUFFER_CONSOLE must be set to y (aka built-in to the kernel). Otherwise, it is possible to always have a black screen unless nomodeset is passed to the kernel, thus disabling kernel mode setting (KMS). acpi_osi="Linux" can be passed to the kernel command line to try to solve this kind of issue. This is usually done through the bootloader.
Kernel with version 4.2 or newer is needed with some 8th generation chipsets[7].


This also seems weird because "nomodeset" did not seem to do anything for me unless I didn't do this correctly somehow (I'm confident I did, not really too technical)
At the GRUB menu, I used 'e' to edit the boot command and appended "nomodeset" after my "init=/lib/systemd/systemd", then used CTRL+X to boot with no success/change.
I also tried removing the necessary systemd command from my grub line just for testing purposes but that changed nothing.



For reference, this is the only thing I've manually done to GRUB according to the Systemd guide:
Quote:

FILE /etc/default/grub Configure GRUB2 for systemd

# Append parameters to the linux kernel command line
GRUB_CMDLINE_LINUX="init=/lib/systemd/systemd"



What is the next step here exactly to find out what is happening? Are there any logs I can view after mounting my root filesystem on the live cd to help point me in the right direction?
Back to top
View user's profile Send private message
OldTango
l33t
l33t


Joined: 21 Feb 2004
Posts: 625

PostPosted: Sun Jun 24, 2018 8:08 pm    Post subject: Re: Black screen after GRUB Reply with quote

austinramsay wrote:
Just finished my Gentoo install. Successfully boots to GRUB:2, but once the kernel begins to load I just get a black screen and am unable to see anything.

System background:
Dell XPS 9370
Using UEFI
Intel I7-8550U

Followed Handbook for Systemd, X, Gnome, and Intel graphics
Device Drivers --->
Graphics support --->
Frame Buffer Devices --->
<*> Support for frame buffer devices --->
## (Disable all drivers, including VGA, Intel, nVidia, and ATI, except EFI-based Framebuffer Support, only if you are using UEFI)

## (Further down, enable basic console support. KMS uses this.)
Console display driver support ---> (NOT SEEING THIS OPTION)
<*> Framebuffer Console Support (NOT SEEING THIS OPTION)


What is the next step here exactly to find out what is happening? Are there any logs I can view after mounting my root filesystem on the live cd to help point me in the right direction?

A black screen after "Loading Kernel" is usually caused by missing kernel options.

In your menuconfig Navigate to
Device Drivers --->
Graphics support --->where near the bottom you should find "Console display driver support --->" Once you highlight this option press, enter to get to the sub menu where you will find <*> Framebuffer Console Support along with some other options.
Here is that section in my kernel config.
Code:

# Console display driver support
#
CONFIG_VGA_CONSOLE=y
CONFIG_VGACON_SOFT_SCROLLBACK=y
CONFIG_VGACON_SOFT_SCROLLBACK_SIZE=256
# CONFIG_VGACON_SOFT_SCROLLBACK_PERSISTENT_ENABLE_BY_DEFAULT is not set
CONFIG_DUMMY_CONSOLE=y
CONFIG_DUMMY_CONSOLE_COLUMNS=80
CONFIG_DUMMY_CONSOLE_ROWS=25
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY=y
# CONFIG_FRAMEBUFFER_CONSOLE_ROTATION is not set


You may need additional options selected for your particular hardware, however I'm not sure I can help much in that area.
Back to top
View user's profile Send private message
austinramsay
n00b
n00b


Joined: 25 Oct 2010
Posts: 38

PostPosted: Sun Jun 24, 2018 9:54 pm    Post subject: Re: Black screen after GRUB Reply with quote

OldTango wrote:
austinramsay wrote:
Just finished my Gentoo install. Successfully boots to GRUB:2, but once the kernel begins to load I just get a black screen and am unable to see anything.

System background:
Dell XPS 9370
Using UEFI
Intel I7-8550U

Followed Handbook for Systemd, X, Gnome, and Intel graphics
Device Drivers --->
Graphics support --->
Frame Buffer Devices --->
<*> Support for frame buffer devices --->
## (Disable all drivers, including VGA, Intel, nVidia, and ATI, except EFI-based Framebuffer Support, only if you are using UEFI)

## (Further down, enable basic console support. KMS uses this.)
Console display driver support ---> (NOT SEEING THIS OPTION)
<*> Framebuffer Console Support (NOT SEEING THIS OPTION)


What is the next step here exactly to find out what is happening? Are there any logs I can view after mounting my root filesystem on the live cd to help point me in the right direction?

A black screen after "Loading Kernel" is usually caused by missing kernel options.

In your menuconfig Navigate to
Device Drivers --->
Graphics support --->where near the bottom you should find "Console display driver support --->" Once you highlight this option press, enter to get to the sub menu where you will find <*> Framebuffer Console Support along with some other options.
Here is that section in my kernel config.
Code:

# Console display driver support
#
CONFIG_VGA_CONSOLE=y
CONFIG_VGACON_SOFT_SCROLLBACK=y
CONFIG_VGACON_SOFT_SCROLLBACK_SIZE=256
# CONFIG_VGACON_SOFT_SCROLLBACK_PERSISTENT_ENABLE_BY_DEFAULT is not set
CONFIG_DUMMY_CONSOLE=y
CONFIG_DUMMY_CONSOLE_COLUMNS=80
CONFIG_DUMMY_CONSOLE_ROWS=25
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY=y
# CONFIG_FRAMEBUFFER_CONSOLE_ROTATION is not set


You may need additional options selected for your particular hardware, however I'm not sure I can help much in that area.


Well this is precisely the problem I'm having..this section in menuconfig does not exist. I do not have a "Console display driver support" section under "Graphics drivers".. can I just go into the ./config file and edit this variable manually then or why am I not seeing this?

Picture of my "Graphics Support" in Menuconfig
https://imgur.com/a/vz5UsH7

If a different method of posting an external link is preferred please let me know so you guys can take a look. Thanks for the reply
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44169
Location: 56N 3W

PostPosted: Sun Jun 24, 2018 10:07 pm    Post subject: Reply with quote

austinramsay,

Never ever use ${EDITOR} on the kernel .config. You will most likely generate an illegal .config that will give you a broken kernel with hard to diagnose problems.

Proceed as follows. In menuconfig press / to get into the search.
Searching for Console (case does not matter) may show the option you need. If its not shown, then something it depends on is off, so the menu system has hidden the option.

Press 'z' to toggle the display of hidden options and search again. It will be listed but still unselectable.
Go to the option and read the help. Note the Depends on: boolean expression. That needs to evaluate to true before the option can be selected.

For links, make friends with wgetpaste.
You could use it to put your .config file onto a pastebin, so helpers can read it or drop it into a kernel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
OldTango
l33t
l33t


Joined: 21 Feb 2004
Posts: 625

PostPosted: Sun Jun 24, 2018 10:33 pm    Post subject: Reply with quote

What Neddy says: Never edit a kernel config manually with an editor !!!!

Also what kernel sources and version are you working with?

Things can get moved around between different version releases. Have a look at the sub menu under "Frame Buffer Devices --->" What your looking for may be listed there.

Again to repeat what Neddy has said. Disabling some kernel options can cause other options to be hidden.
Back to top
View user's profile Send private message
austinramsay
n00b
n00b


Joined: 25 Oct 2010
Posts: 38

PostPosted: Sun Jun 24, 2018 11:19 pm    Post subject: Reply with quote

NeddySeagoon wrote:
austinramsay,

Never ever use ${EDITOR} on the kernel .config. You will most likely generate an illegal .config that will give you a broken kernel with hard to diagnose problems.

Proceed as follows. In menuconfig press / to get into the search.
Searching for Console (case does not matter) may show the option you need. If its not shown, then something it depends on is off, so the menu system has hidden the option.

Press 'z' to toggle the display of hidden options and search again. It will be listed but still unselectable.
Go to the option and read the help. Note the Depends on: boolean expression. That needs to evaluate to true before the option can be selected.

For links, make friends with wgetpaste.
You could use it to put your .config file onto a pastebin, so helpers can read it or drop it into a kernel.


This is exactly what I needed to hear! I found the problem and posted the solution below. And okay I figured it would not be wise to edit manually, however I was so confused on how else to change it that I thought that might be how it's done.

----------------------------------------------------------------------------------------------------------------
For others referencing this post in the future this was my solution:
The console framebuffer depended on HAS_IOMEM (which was already set to =Y) and VT (Virtual Terminal) which was set to =N
I located Virtual Terminal by searching "VT" through the "/" option, and following the tree in the resulting window.
After building the virtual terminal into the kernel, "Console Display Driver Support ->" was then accessible through the "Graphics Support" menu.
I then followed the handbook and enabled "Framebuffer console support" as needed.
Did "make && make modules_install" , "make install" and then updated grub2 with "grub-mkconfig -o /boot/grub/grub.cfg"
Rebooted.
----------------------------------------------------------------------------------------------------------------

Thanks for the help Neddy. Have a bit more experience on navigating menuconfig now which I will definitely need in the future.

But the fun never end, this has now led me to find more issues occuring during boot. My XPS has a 4k display, and it seems like the console is set to 4k which makes the text extremely small and hard to work with (but at least its there now!)..

Looked like boot was going well for a while until I eventually ran into "Timed out waiting for device dev-nvme0n1p2.device" after a 1 minute and 30 second timer attempting to do something... (nvme0n1p2 is my /boot partition)
This was followed by a couple "Depend" errors along with the same message for my swap partition: "Timed out waiting for device dev-nvme0n1p3.device"

I'll do some research and create a new thread if I need to since this thread's specific issue has been solved. Thank you guys.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44169
Location: 56N 3W

PostPosted: Sun Jun 24, 2018 11:28 pm    Post subject: Reply with quote

austinramsay,

Press the digit beside the listing in the search results.
It takes you there.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
russK
l33t
l33t


Joined: 27 Jun 2006
Posts: 634

PostPosted: Mon Jun 25, 2018 12:06 am    Post subject: Reply with quote

NeddySeagoon wrote:
Press the digit beside the listing in the search results.
It takes you there.


I use search all the time but did not know pressing the number would take you there. Another amazing obscure tip from the legendary NeddySeagoon. Awesome.
Back to top
View user's profile Send private message
austinramsay
n00b
n00b


Joined: 25 Oct 2010
Posts: 38

PostPosted: Mon Jun 25, 2018 12:10 am    Post subject: Reply with quote

NeddySeagoon wrote:
austinramsay,

Press the digit beside the listing in the search results.
It takes you there.


Wow couldn't really make it easier for ya i guess! Thanks! I have started a new thread about new issue.. Thanks again!

[Moderator note: made the text new thread a link to the new thread, so that interested readers can easily find it. -Hu]
Back to top
View user's profile Send private message
tryn
Guru
Guru


Joined: 21 Dec 2002
Posts: 320
Location: 39.885° N. -88.913° W.

PostPosted: Mon Jun 25, 2018 2:41 am    Post subject: Reply with quote

I agree with russK I think that NeddySeagoon is Awesome.
The information that he gave is something that I will use for sure.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum