Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wxGTk errors on kicad source after gcc-7.3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
clytle374
Apprentice
Apprentice


Joined: 01 Aug 2006
Posts: 193

PostPosted: Thu Jun 28, 2018 6:36 pm    Post subject: wxGTk errors on kicad source after gcc-7.3 Reply with quote

Not sure if this is a bug, and I have it fixed now. I'm running Kicad from git sources and started running into a error on cmake about wxwidgets and wxpython.

Code:

Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1006,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8).


I rebuilt everything with wx or python in the name and it did not help. I realize now that there is 2 different wxGTK packages

Code:

x11-libs/wxGTK-3.0.3:
x11-libs/wxGTK-3.0.3-r300


So when I kept rebuilding wxGTK it was only rebuilding the second of the 2 packages.

I ran a emerge world and that didn't fix it.

Later I catch the 2nd package and specify the package emerge =x11-libs/wxGTK-3.0.3. This resolved the problem. I looked at genlop -t x11-libs/wxGTK-3.0.3 and it clearly stares it was build about 6 months ago.

I can't figure out why it didn't get rebuilt with emerge world.

Code:
genlop -t x11-libs/wxGTK-3.0.3
 * x11-libs/wxGTK

     Tue Jan 16 19:26:31 2018 >>> x11-libs/wxGTK-3.0.3
       merge time: 5 minutes and 58 seconds.

     Thu Jun 28 14:05:49 2018 >>> x11-libs/wxGTK-3.0.3
       merge time: 3 minutes and 36 seconds


But if I emerge -pv world now both wxGTK packages are listed for rebuild.

These 2 people had similar problems/.

https://forums.gentoo.org/viewtopic-p-8189688.html?sid=8f7f8cb35317d199075b184a959b1d80

https://forums.gentoo.org/viewtopic-t-1063358-start-0.html

I assume the gcc is what caused this. Can someone please tell me why emerge world didn't rebuild it? I assume that if I was using the kicad package it would have been rebuilt.

Thanks
Cory

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
_________________
NooB since RedHat 6.1
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5671
Location: Removed by Neddy

PostPosted: Thu Jun 28, 2018 6:53 pm    Post subject: Reply with quote

emerge world doesn't rebuild all slot atm :( I got bitten by this when I converted to 7.x some time ago and took a while to figure it out
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
clytle374
Apprentice
Apprentice


Joined: 01 Aug 2006
Posts: 193

PostPosted: Thu Jun 28, 2018 9:53 pm    Post subject: Reply with quote

So is emerge world catching it now since it's been called by name instead of being pulled in as a dependency?
_________________
NooB since RedHat 6.1
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum