Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Startx cannot start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
gentoo-find
n00b
n00b


Joined: 07 Apr 2018
Posts: 58

PostPosted: Fri Jun 29, 2018 8:43 am    Post subject: Startx cannot start Reply with quote

Code:
xauth:  file /root/.serverauth.1753 does not exist

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
(EE)
Fatal server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE)
(EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
Invalid MIT-MAGIC-COOKIE-1 keyxinit: giving up
xinit: unable to connect to X server: Resource temporarily unavailable
xinit: server error


lspci | grep -i VGA
Code:
[AMD/ATI] RV620 LE [Radeon HD 3450]


lspci -k:https://paste.pound-python.org/show/kv0hrZp2FoUXxyL6L9wP/
/var/log/Xorg.1.log:https://paste.pound-python.org/show/6xVB6McliCtDtcdjyFWp/
emerge --info:https://paste.pound-python.org/show/A0t78uhsu5NT6OpecAuk/
/usr/src/linux/.config:https://paste.pound-python.org/show/4UhCt1b7Yeki89LXGAlc/ 





[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
hhfeuer
Apprentice
Apprentice


Joined: 28 Jul 2005
Posts: 165

PostPosted: Fri Jun 29, 2018 11:43 am    Post subject: Reply with quote

Try
startx -- :2
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5762

PostPosted: Fri Jun 29, 2018 3:24 pm    Post subject: Reply with quote

What's the output of `stat -c %A /usr/bin/Xorg`?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13855

PostPosted: Sat Jun 30, 2018 12:22 am    Post subject: Reply with quote

Why is xauth trying to write its auth file in root's home directory? Did you try to startx as root?
Back to top
View user's profile Send private message
gentoo-find
n00b
n00b


Joined: 07 Apr 2018
Posts: 58

PostPosted: Sat Jun 30, 2018 4:44 am    Post subject: Reply with quote

Ant P. wrote:
What's the output of `stat -c %A /usr/bin/Xorg`?


-rwxr-xr-x
Back to top
View user's profile Send private message
gentoo-find
n00b
n00b


Joined: 07 Apr 2018
Posts: 58

PostPosted: Sat Jun 30, 2018 4:45 am    Post subject: Reply with quote

Hu wrote:
Why is xauth trying to write its auth file in root's home directory? Did you try to startx as root?


User still running error
Back to top
View user's profile Send private message
gentoo-find
n00b
n00b


Joined: 07 Apr 2018
Posts: 58

PostPosted: Sat Jun 30, 2018 4:47 am    Post subject: Reply with quote

hhfeuer wrote:
Try
startx -- :2


Error
Back to top
View user's profile Send private message
gentoo-find
n00b
n00b


Joined: 07 Apr 2018
Posts: 58

PostPosted: Sat Jun 30, 2018 4:51 am    Post subject: Reply with quote

No problem using xf86-video-ati
When I try to configure ATI Radeon
core
/etc/portage/make.conf
VIDEO_CARDS = "radeon r600 ati"
Then an error occurs
Back to top
View user's profile Send private message
gentoo-find
n00b
n00b


Joined: 07 Apr 2018
Posts: 58

PostPosted: Sun Jul 01, 2018 10:14 am    Post subject: Reply with quote

Code:
[    0.947461] [drm] radeon kernel modesetting enabled.
[    0.947918] PCI Interrupt Link [APC8] enabled at IRQ 16
[    0.948178] [drm] initializing kernel modesetting (RV620 0x1002:0x95C5 0x1462:0x1180 0x00).
[    0.948636] ATOM BIOS: 113
[    0.948714] radeon 0000:02:00.0: VRAM: 256M 0x0000000000000000 - 0x000000000FFFFFFF (256M used)
[    0.948788] radeon 0000:02:00.0: GTT: 512M 0x0000000010000000 - 0x000000002FFFFFFF
[    0.948864] [drm] Detected VRAM RAM=256M, BAR=256M
[    0.948911] [drm] RAM width 64bits DDR
[    0.949153] [TTM] Zone  kernel: Available graphics memory: 3045966 kiB
[    0.949201] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[    0.949249] [TTM] Initializing pool allocator
[    0.949300] [TTM] Initializing DMA pool allocator
[    0.949390] [drm] radeon: 256M of VRAM memory ready
[    0.949439] [drm] radeon: 512M of GTT memory ready.
[    0.949498] [drm] Loading RV620 Microcode
[    0.949561] radeon 0000:02:00.0: Direct firmware load for radeon/RV620_me.bin failed with error -2
[    0.949635] r600_cp: Failed to load firmware "radeon/RV620_me.bin"
[    0.949686] [drm:r600_init] *ERROR* Failed to load firmware!
[    0.949734] radeon 0000:02:00.0: Fatal error during GPU init
[    0.949782] [drm] radeon: finishing device.
[    0.956877] [TTM] Finalizing pool allocator
[    0.956927] [TTM] Finalizing DMA pool allocator
[    0.957027] [TTM] Zone  kernel: Used memory at exit: 0 kiB
[    0.957078] [TTM] Zone   dma32: Used memory at exit: 0 kiB
[    0.957125] [drm] radeon: ttm finalized
[    0.957507] radeon: probe of 0000:02:00.0 failed with error -2


[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43208
Location: 56N 3W

PostPosted: Sun Jul 01, 2018 10:27 am    Post subject: Reply with quote

gentoo-find,

You have a Radeon HD 3450 video card from
Code:
[   107.831] (--) PCI:*(2@0:0:0) 1002:95c5:1462:1180 rev 0


Xorg is using automatic driver detection
Code:
[   107.963] (==) Matched ati as autoconfigured driver 0
[   107.963] (==) Matched modesetting as autoconfigured driver 1
[   107.963] (==) Matched fbdev as autoconfigured driver 2
[   107.963] (==) Matched vesa as autoconfigured driver 3
thats good.

You have kernel support missing in your kernel
Code:
[   108.055] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   108.055] (II) [KMS] drm report modesetting isn't supported.
[   108.055] (EE) open /dev/dri/card0: No such file or directory

That stops the video driver from working. Its in two parts and you only have one.

Follow the Wiki.

If you want ATI Radeon built into the kernel you must also build in its firmware, so until it works, <M> is a good choice.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
gentoo-find
n00b
n00b


Joined: 07 Apr 2018
Posts: 58

PostPosted: Mon Jul 02, 2018 7:28 am    Post subject: Reply with quote

NeddySeagoon wrote:
gentoo-find,

You have a Radeon HD 3450 video card from
Code:
[   107.831] (--) PCI:*(2@0:0:0) 1002:95c5:1462:1180 rev 0


Xorg is using automatic driver detection
Code:
[   107.963] (==) Matched ati as autoconfigured driver 0
[   107.963] (==) Matched modesetting as autoconfigured driver 1
[   107.963] (==) Matched fbdev as autoconfigured driver 2
[   107.963] (==) Matched vesa as autoconfigured driver 3
thats good.

You have kernel support missing in your kernel
Code:
[   108.055] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   108.055] (II) [KMS] drm report modesetting isn't supported.
[   108.055] (EE) open /dev/dri/card0: No such file or directory

That stops the video driver from working. Its in two parts and you only have one.

Follow the Wiki.

If you want ATI Radeon built into the kernel you must also build in its firmware, so until it works, <M> is a good choice.



Is set to module set in the following options?
Device Drivers --->
Graphics support --->
<*/M> ATI Radeon

dmesg | grep radeon

[ 0.977577] radeon 0000:02:00.0: Direct firmware load for radeon/RV620_pfp.bin failed wi$
[ 0.977651] r600_cp: Failed to load firmware "radeon/RV620_pfp.bin"
[ 0.949561] radeon 0000:02:00.0: Direct firmware load for radeon/RV620_me.bin failed with error -2
[ 0.949635] r600_cp: Failed to load firmware "radeon/RV620_me.bin"

Device Drivers --->
Generic Driver Options --->
[*] Include in-kernel firmware blobs in kernel binary
External firmware blobs to build into the kernel binary
ADD radeon/R600_rlc.bin radeon/R600_uvd.bin radeon/RV620_pfp.bin radeon/RV620_me.bin

problem solved
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum